Screen settings keep changing back to default

Hi,
using 0.9.24 on a Ubuntu 20.04 machine with a screen resolution of 1920x1080 I adjust screen settings and layout to suit my needs.
However, every time I restart Lightburn I find it reverts back to default display settings and I have to start all over again.
Checked the various settings and options.
Is there a way to save my settings so Lightburn always starts the same way ?
Thanks!

Default Screen:

Prefered screen:

The only time we’ve seen it do this is if there isn’t enough room for the display layout chosen. Check to see if that’s a possibility here - giveaway is the tabs for the laser / Cuts&Layers / etc windows being scrunched up.

You can force a particular screen size using a script and wmctrl. See:

The Laser tab appears to be fine - see screenshot.

However, had to place an earlier post on here as I could never find the colour bar and then discovered it being hidden behind my taskbar - hence always have to re-arrange the layout to suit.

Resolution is 1920x1080
Also just checked to ensure it is standard resolution - not enlarged, as I know that can sometimes cause problems.

Happy to report I finally found a fix / workaround:
(This applies to KDE plasma screen on Kubuntu and hence may not work for every Linux flavour)

  • By right-clicking on the top titlebar, then selecting “More Actions” followed by “Configure Special Window Settings” you’ll get a special menu.
  • Pick the “Size & Position” tab
  • Select “Size” and option “Force” then enter a suitable value for your particular screen resolution.
    ( you may have to try different settings)
  • Click on “OK” and you’re done.

…I had a little bonus surprise as I suddenly got a pointer location indicator on the bottom left corner which I never had before.

Follow up: After further testing and actual use with Laser I’ve made the following observation:
With above mentioned method the initial screen is fine. However, when loading a file the screen is refreshed and it reverts back to original settings. → Fix for this is to select “Special Application Settings” in above mentioned menu, rather than the Window Settings.
Unfortunately this results in all sub-windows displayed within Lightburn reverting to your custom screen size. I.e. opening the Machine Settings will be full size as well.
I still prefer this to not having all components of screen displayed as it was before.

Thank you for providing this detailed update and marking ‘Solved’. We appreciate the effort in helping folks find this in the future. :slight_smile: