Window Sizing bug in Linux [Workaround]

Latest LightBurn for Linux,
Running on Lubuntu 18.04,
Window size doesn’t stay with last settings (keeps resizing on each new start to a size larger than my screen) although Prefs.ini has the window size values appearing to be correct.

Note: My screen is low resolution (1366x768) because I’m using a touchscreen but I can layout the tool windows to fit nicely in a single group. This works well on my MiniPC with Windows 10, doesn’t work on Linux.
I’ve attached my prefs.ini in case that helps.
prefs.ini.txt (127.5 KB)

Do you have the windows stacked vertically? Every window has a maximum size, and if you’re trying to arrange them so the total of their sizes is larger than your display, it just can’t do it. You may need to stack the windows on top of each other (tabbed).

Like this: Update to 9.10 and 9.11 to big window "Laser" - #10 by LightBurn

I have all the tool windows tabbed on top of each other. They fit well and are useful that way, but the window size still is set larger than my screen everytime I start LightBurn.

I can do a screen cap when it’s setup properly if you want.

Yes, show me a screen grab when you can.

This first shot is what I get when I start LightBurn. I need to use a mouse to ‘reach’ up and resize the screen - the touch screen positioning won’t work.

This is what I can shrink the window to. I probably wouldn’t make it THIS small, but just to show you that it all fits.

@TomWS did you try deleting your configuration file and starting anew? I ran across an issue in one of the earlier updates which cleared with a clean config file.

Which configuration file?
The LightBurn installation was a totally first time installation on the new AtomicPi system. The only thing that was ‘leftover’ from previous installations was the imported device file.

That’s not completely correct. I did load a couple of LightBurn design files to make sure I could access the data properly.

ah, that’s pretty fresh then… I wonder if it has to do with the window layout you have going.
I have all but Art Library and File list enabled which gives me the Laser section below on the right side.
ie large window on the left and vertically split 2 windows on the right.

That doesn’t work with the low vertical resolution. You need to tab the windows if the vertical is less than some value somewhat greater than 768 (my V res).

I probably should have had the Laser or Cuts tab showing rather than Console.

1 Like

did you know you can detach the tabs from the main window? You can detach them and when you close they will open up detached again.

1 Like

I didn’t know that. So… I could conceivably have the laser tab floating as a separate window?

I’m not sure that will help if the main window keeps opening larger than my screen size. However, it might be worth messing around with that to see what the effect is. Thanks for the tip!

One thing that would help somewhat is if the launch bar on the bottom of the screen could be set to autohide. I looked around a bit a while ago and didn’t find a way to do that.

1 Like

did you try:
How do I turn on auto hide taskbar?

Just follow these simple steps:

  1. Right-click on an empty area of the taskbar. (If you’re in tablet mode, hold a finger on the taskbar.)
  2. Click taskbar settings.
  3. Toggle Automatically hide the taskbar in desktop mode to on. (You can also do the same for tablet mode.)

I did try something like that that gave me advice on clicking on some ‘object’ on the taskbar, but I didn’t have that ‘object’ on my taskbar. I don’t recall if I clicked on the taskbar itself, but I will try it tomorrow.

right click in the large open area across the middle, select Panel Settings, then open the Advanced tab.
Near the bottom will be Minimize when not in use which you’ll want to enable. It will now hide and only show up when your mouse in on the bottom edge.

gets you a dozen or so more pixels for your full screen app.

1 Like

Man! That’s so obvious! Ok, will do, next time I’m on.

Yup, worked like a champ! Thanks!

FWIW, I can use wmctrl to resize the LightBurn window to a useable size after starting it using the command:
wmctrl -r "<untitled>" -e 0,87,30,1261,720

There might be a ‘tighter’ linkage to the app using something other than "<untitled>" but it’s too chilly in the loft right now to mess with it.
I suppose this could be a temporary workaround, but I find it odd that the LightBurn window always starts up larger than it should. FYI, wmctrl -lG listed the vertical size of the freshly loaded window as 851 pixels. Physical screen size is 768.

UPDATE: I put a launcher for my script on the Desktop and that will work fine as a workaround for the time being.

I just noticed the window title is “untitled” and that’s a bug.

FWIW, I just noticed I can not shrink my Lightburn window vertically very much. I’m going to see what size the minimum is.

@TomWS I see your bug! I could not resize my LightBurn window below 811 pixels until I removed the “Cuts” tab and the “Laser” tab sections and then I could resize the main window smaller. BUT, as you mentioned, when exiting and restarting Lightburn it will not size to the smaller window size previously set and on mine, it restores to 811 pixels high. I’ve reported this in the Beta thread.

Untitled isn’t a bug. That’s what you get when you first load LightBurn since there is no file opened yet.