Sculpfun S10 doesnt connect to lightburn


I just assembled my Sculpfun S10 and tried to connect it to Lightburn. I am using an IMac with Mojave 10.14.6 and the laser is connected via usb. When I click on “find my laser” it is not to be found. When I click on “create manually” sculpfun is not listed? I appreciate your help!

Having not attempted to connect a Sculpfun S10 personally I would proceed with the steps outlined in the Sculpfun S9 setup video that LightBurn created.

My assumption is that the CH340 driver was overlooked.

You can skip ahead to 8:09 where the Mac install begins.

hello John, thanks for helping me out here. i have installed the driver but the laser still can’t be found. and when i try to select it manually, sculpfun doesn’t appear in the list?.
many thanks!! Jana

also i can not try to change the comport because the assistant popup is on top. if i close it, the program automatically shuts down as it says i have to select a laser in order to use the program :frowning:

Same problem here. We’ve also installed Lightburn on another device but still no connection. it’s excactly the same as you say in your comment. following this topic for advice

1 Like

Skip the video through to 11:45 and attempt the recommended steps.

If the engraver isn’t connected and powered when the Mac is powered up it might not discover it.

If this doesn’t get it connected - click ‘create manually’ and enter the Sculpfun S9 information covered in the video. If you still aren’t there we’ll dig in a little more.

Normally I’d split these but it’s great that you’re here and following - have you tried the steps in the Video?

After having installed the driver, you need to manually add the laser (do not use autodetect). Afterwards you can choose the right port in the dropdown menu in the laser window. I think the mentioned video shows it, but here I have some step by step instructions using screenshots: Setting up the software - Diode Laser Wiki (The S10 is the same as the S9 in that regard).

Hi Jana
Did you solve you issue with S10? It seems that we have the same issue but i use Win 10 on laptop. I installed all drivers and the laser is working with LaserGRBL but if i switch to lightburn it does not work. :frowning: Still searching for solution…

Ladislav, did you add the laser manually to LightBurn? And afterwards, selected the correct COM ports?

Hi there. Unfortunately Not. I also tried using a windows laptop. And I can’t install it manually as sculpfun does not show up in the list. I kind of gave up. Waiting patiently for someone else to solve the problem :wink: next step for me would be to find another software. Sad, because everyone recommends lightburn but I am tired of trying. Good luck to you.

No, there is no Sculpfun laser in the list. You need to add it as “grbl” device. See the link posted above, there is a step-by-step guide.

Hi Misken

Yes, i add the laser manually and then select the com port. I try it again today and suddenly it works! :D. I did not change anything.I use the old profile. I am happy now. :smiley:

Try to add it manually as GRBL device. Restart computer, start the machine and then start the software, select the com port on the right side. You should be able to move with the virtual buttons. You can also try LaserGRBL software, it is simple and quid handy to install the drivers

2 posts were split to a new topic: New Sculpfun S10 not connecting - Tried Everything