Sculpin expansion origin issues...trial 2 days in

Hi, I have set up machine as per instruction,…with extra long cable supplied for 900mm expansion.
watched a tooonne of vids, but I can’t get the origin working, all 3 options.
when framing image it never goes to the origin, hit rails and made lots of noises.
moved image side to side but laser burn doesn’t change framing position.
centering is at one end according to laser burn.(not the centre)
my page is 410mm x 900mm(50mm spare)
30 hours hard in and have no change in movment. hopefully some has same probs.
I wonder if the cables maybe backwards but the are color coordinated etc…
I am assuming the left bottom is the origin in device setups?
tanks again ahead of solution

Processing: is it back wards.png…
Uploading: still bang sinto the sides.png…

Can you confirm that your laser does not have limit switches and does not automatically home when first turned on? Homing is where the laser would automatically move to the “home” location and then stop until the command is received.

Some requestions and questions for you:

  1. Please explain your startup procedure. What do you do when you first startup the machine?
  2. Once the laser is on, are you able to use the jog buttons in the Move window to move? Do the buttons behave as you’d expect? Left moves left, right moves right, etc?
  3. Please send screenshot of your Device Settings
  4. In Console window run these commands one a time and respond with all output content

Note that the images you were trying to attach the last time did not make it. You may have posted your message before the upload had a chance to complete. Can you repost please?

Hi, thanks for reply!/

And its a sculpfun S9(spelling error in title sorry)

No limit switches
No homing
Machine does not move all when turned on
jog buttons move as per expected. left/right and up(back) down(front/circut board located)

I will send pic via e mail as I waited a longgg time for them to up load, and apparently they did reach you.
have tried to load again, if you receive these I will email them…

Appreciate the help, especially on the holidays

Processing: device settings.png…
Processing: device settings.png…

…looks like they didn’t upload.
I got a error… “new user” can only upload two links… as I have 11 screenshots I have emailed them.


hi, also I noticed this morning when opened Lightburn interface, there is no 'Set origin or clear origin buttons in the MOVE tab.
Maybe this will be of help?


Hi, am assuming its operation/human error on my part with making start/home points/origins artificially as I have no home or limit switches.

I spent some time this morning working on that idea but just when I think I am getting some where, it goes all wrong and bangs into the sides or ends.

…as previous I’m assuming operator error.

note my start procedure:
I turn on machine, its already plugged into computer/usb
I move with hands laser to the middle of frame X and Y approx away from the sides and ends.


…one more thing. I am assuming also that the S6 in the same as my S9.
wondering how many S6 users are there in the forum with there origin setup procedure?
are they the same?


Not sure of the difference between S6 and S9 and the Sculpun website seems to be oddly silent on it.

Typically for machines without end stops you will need to manually position the head of the laser to the front left of the machine before turning on the controller. The position you start from is set to 0,0. From that point software limits should prevent most crashes into the frame.

There can be complications that prevent this from working in some cases so let’s walk through any of those.

Confirm that starting position is indeed 0,0 by moving head to front left and cycling power on the laser. Then check Get Position in Move Window.

If the coordinates are indeed 0,0 then you’re good to go and you’ll be able to use Absolute Coords as well as the other 2 coordinate systems. I’d recommend sticking with Absolute Coords until you have a good feel for how the laser and LightBurn work.

If it’s not 0,0 then run the following commands in the Console window and copy back all the output here:


Also, I haven’t seen any direct messages from you so not sure what’s going on there.

hi, thanks for that.

I will continue with instructions but im not sure what you mean by ‘copy back the output’ ?

Screenshots of each command result?


Hi, I seem to be getting some were!

kinda sorted an artificial home position using the go’ function and navigated the laser around and no banging into the rails at all!

No actual layering yet…

I will keep in touch for further progress.

what a relief.

special thanks to Berainlb for your help , during holidays too!


Just to confirm, what is your position after starting the machine from the front left?

Hi, when i start machine with laser theres no movement to any piont or any sounds or single its on.

When lightburn is opened theres a little noise that sounds like the machine/gears are talk ing to each other ready to engage but no movment.

I have to move the laser head manually by hand or jog to the left front. Then ‘get positioned’ to make it 0.0

I also jog it 5mm OR 10mm X and Y away from the rails, this becomes the 'home position kind of :slight_smile: .

The software reads at 0.0 etc regardless of were the laser module is on the machine when both are turn on.

hope this helps


Okay. So this is working as expected. Wherever the head happens to be at start-up is 0,0.

You should not need to “pull-off” away from the rails if you’re following the process of starting up in the front-left. You can power cycle the laser if you needed to manually move the laser head there to get to 0,0. You can alternatively issue a “G92 X0 Y0” in console (without quotation marks) if you want to zero-out without power cycling.

This were I go a bit blank. As I have never used one before and have never seen the console codes ever before or even new they existed. When I am asked to do such a thing I am blank as to what to actually physically do to…i.e. “change gear” in an automtic car verse a manual, some people have never seen a manual so changing gear would require a bit extra trial…so bare with me hahaha.

I tried to type in G92 X0 Y0 in the console bar at the botttomof window but nothing happened…asumming this is correct place to type it.

You would enter the commands into the area of Console where it says “(type commands here)”. The command isn’t “registered” until you press enter. After that, you’ll probably see something show in the small screen above to acknowledge the command.

If you enable the slider “Show all” you’ll see all the chatter between LightBurn and the laser controller.

You should at least get some acknowledgement in the console output window but can’t recall exactly what. How you can tell for sure if it worked is if Get Position in Move window shows 0,0 after being pressed. This should be true no matter where the laser head is positioned when you run the G92 command.


Alternatively, you can get the position information in Console by entering ? followed by enter.

how do I insert an image to a post? all screenshots I have had to email as they won’t upload in the posts…I waited 5 mins for image to upload but still hasn’t. email takes 2 seconds…
and I can’t exit upload other than canceling the whole post a re typing.

I typed G92 X0 Y0_enter but 'get positioned is not 0.0

As a ‘new’ user you are limited on how many things you can post…


ok, thanks.

hopefully I’m not breaking the new user rules already …this will be my last post.

Is there any sculpfun users that can help me with running the machine in light burn?

are there nuances in that difer from other machines.

thank you to everyone who helped.


Another user of Sculpin is having some issues. I reference them here, but I thought I might let you try ‘over there’… :crazy_face: