Sending files to AWC608 doesn't work anymore

I have to K40 laser one with AWC608, one with AWC708C Lite. I could work fine for a few days with both of them. AWC608 must be added manually with AWC708C switched off. Both lasers work fine for a few days, but then sending files to AWC608 crashes Lightburn. Although the file is not shown in the control-panel, it can be found in the controlers file-list. It can also be selected and executed, but it stops after a while. So it appears that the file is not complete.

Loading files with LaserCAD still works. But I would like to switch completely.

Greetings from Vienna

The Trocen controllers can fill up with old files. Can you see how many files are in the controller?

Do you get a crash report that you can share?

I see Win 10 in your profile - Which version of LightBurn are you working with?

This could be helpful for framing problems in the future. :slight_smile:

Thanks for reply. That’s what I suspect too, but it goes deeper. The error occurred with the second upload after a “delete all”. So the file list was nearby empty. Maybe there is some data junk in the memory, which cannot be seen in the file list, or some kind of memory fragmentation. The controllers menu has the option “Memory Manage” (which is poorly documented). I tried “Check Memory” and could send one more file afterwards. But with a second file it failed again.

Unfortunately there is no error massage in Lightburn. After the very next click the application freezes and Windows says “Keine Rückmeldung”, which means “No Reaction” (I don’t know the correct term of this Windows message).

I will try the second option of the controllers menu “Format Memory” as soon as the laser has finished the recent job, which will be Monday or Tuesday. The term “Format Memory” without useful documentation frightens me a little bit. So if anyone has experience with it, please tell.

Yes it is Windows 10, latest Lightburn version in trial period. I also tried for Linux which seemed to work for AWC608 (standard USB driver?) but not for AWC708C because of the missing driver. Though I am no Windows user in common, I am used to control the lasers with it.

As you can see I am no native English speaker, please have mercy :wink:


You are doing just fine.

I suspect “Keine Rückmeldung”, is intended to mean “Windows, Not responding”. I get this on windows devices when i am using a large amount of memory. Are you working with a large file in LightBurn and do you have a browser open?

Have a look here for the FTDI driver for your AWC708C

USB cables can be problematic. Do you have robust cables with Ferrite beads and shielding?

Thank you for the roses.
Lightburn-files a really small in comparison to pwj5-files. Based on the same PNG-Files and directives the pwj5 has for instance 18718KB while lbm2 has 153KB and ud5 has 1644KB. I guess the later is the one which is send to the laser.

Meanwhile things go worse. I run into the same problem with AWC708C, although it behaves good now after “All Delete” in Controllers Panel.

The “Format Memory” Command in AWC608 has not taken the desired effect. I could still send no files with Lightburn. What makes me panic is, that the upload with LaserCad now fails randomly and gives a “Communication failed” Message. Of course I have only one application opened at the same time.

As far as I can remember the USB cables are the original one, and there have never been problems. I still have the option to connect via network.

I cannot see what’s going wrong: USB cables, Windows10, a bug in Lightburn (“Delete all”?), a memory-junk? And the Installation Guide of the FTDI driver really frightens me. The only thing I know is, that I have to keep the lasers in production. A few days it worked very fine and I had high hopes for a more convenient application and the ability of Grayscale Engraving (only AWC708C though), which let me produce 3D-structures in shorter time and better quality. So I am quite desperate for today. Sorry for that.


There are notable issues with the USB cable connections. Connecting with Ethernet is highly recommended.

USB cables are designed to wear out the connector over time. I would try a new High Quality Shielded USB Cable with Ferrite Beads before being too concerned.

is this of any help?

The FTDI driver isn’t used by the 708’s, and was only used briefly for some 608’s as far as I know. It’s possible that one of your cables or connectors is failing if both LightBurn and LaserCAD are experiencing similar issues.

Yes, it must have been a faulty cable connection or something with the USB hub. After buying an ethernet switch, both lasers are connected via network and work proper since then. And what makes me really happy: I can use the linux-version now. Thank you for helping me.

Maybe it would be worth it to catch the error in case of failed connection.

Greetings from Vienna


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.