Setting up my Ortur Laser Master 2 in Lightburn

I just put together my Ortur Laser master 2 and I’m connected to my Mac Pro. I set up the laser machine in Lightburn exactly as the manual says using GRBL. But, I keep getting “error:2” and “ok” over and over. (same thing in candle and other Grbl type softwares)

My connection says “ready” but won’t home. There is power to the machine. It will home after a while if I click the button enough times or unplug the machine or reset it. I’m not sure what’s going on…

I got it to finally try and cut a letter A on FILL setting but it only did two little lines.

If I jog the machine in any direction, it turns the laser on and moves at the same time.

Does anyone else have this issue/issues?

Okay, I got it to cut another rectangle in line mode. the fill mode doesn’t work at all.
After it finished cutting the rectangle, it just stopped and now the program won’t respond. I had to restart the program and now it isn’t letting me home the machine or anything.



Seems you have a bit of a configuration issue
Could you confirm you used GRBL as the initial setup (top most option) and you set your home position as Front/left

Also in console, if you tggle “show all” as gree
And you type $#, can you post an output of the console output please?














I can do line segments perfectly fine but the fill or image burn doesn’t work. It tries to but then I get an error message:


On or near line 9:

Stream completed in 0:00











I pressed the stop button. Now it says “waiting for connection” and then “ready” under the laser window. Isn’t this supposed to say “ortur laser master 2 ready”? in the console? I’ve never seen that.

Okay, now its not doing anything just says “MSG:Check Door”

Now check door is a first for me, but seems you have a configuration problem in your lightburn.
Would you be able to setup a remote access so i can take a look, seems a too many issues at once to be an easy exchange of messages. Could you private message me via the forum message function please?

Switching to a PC solved my issues.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.