Shifting on X axis during layer changes

I’ve had an issue that seems to randomly happen with some files.
Basics:
80W CO2 Laser
RDC6442GB Ruida Controller
Firmware: RDC-V8.00.65
Lightburn version: 0.9.14

I normally run 3 layers:
Normal Shade
Outline Shade
Cut

The horizontal shift happens between the outline, and the normal shade.
Here you can see that the x shift caused work to be cut outside the framed area
https://i.imgur.com/NpY3QrU.jpg

Here it looks like one piece completed successfully, yet the other shifted again towards the left
https://i.imgur.com/JP75T46.jpg

Due to being a new user, and not having the ability to post multiple links… I’ll have to split this post

This is what the pieces look like when separated
https://i.imgur.com/3xHmJ26.jpg

If I babysit the laser, and cut all the layers separately (enable and disable layers one by one) then I can but the work without issues. Obviously this is not ideal.
I have skirted around this bug previously by changing the optimization settings to go by “Order by Group” only. Unfortunately this did not work here.

I have also previously cut these files with no issues. I have had this issue with various files. Some of them modified in lightburn (copy + paste to increase quantity), and some untouched by lightburn except to cut.

Closing/reopening software, and power cycling laser seems to have no effect. The problem will persist.
The belts are not loose. They feel sufficiently snug.

Lastly, I don’t believe it is an acceleration issue. I have tested dropping the acceleration to extremely low values, and the problem clearly persists. Here is a video showing this layer shift + extremely slow acceleration happening on another file
https://photos.app.goo.gl/m6AGg8cb6Q3zNQqa6

Lastly, here are my optimization settings

How are you connected to the machine? I wouldn’t suggest using flood fill unless it’s absolutely necessary, though that shouldn’t be causing layer shifting. It also looks like you’re running so fast that it’s probably hurting your cutting time, because of the amount of overshoot.

Check the Idle Acceleration and Idle Speed settings, which are the setting used by the controller when moving between cuts. If those are too high, that could cause the slipping you’re seeing between cuts. Also the Line Shift Speed value is used when moving vertically during engraving, and that being too high can cause trouble as well.

If you can post the top section of the Machine Settings window (cutting and scanning params) something might jump out.

(I’ve bumped up your trust level, so you’ll be able to post more easily)

I’m connected to the machine via what appears to be a good quality 6ft USB cable. It has Ferrules at either end as well as the official USB logo and claims that it conforms to USB 2.0 specifications (I 'm not sure of its authenticity, but at the moment I don’t suspect the cable)

With the video I posted in the first link, I showed that the shifting happens at excruciatingly slow speeds as well, though I may be confusing terms here.

I’ve researched a bit about the overshooting, and what I’ve found is that there’s no way to adjust that myself correct? With my old laser, I had a C3D board, and I was able to adjust the ‘overscanning’, but this board doesn’t show that option on lightburn. Are you suggesting I lower my scan speed? I haven’t tried anything under 400mm/s but more than open to trying

I wasn’t aware flood fill was turned on on the second layer until you pointed it out. I must have accidentally turned it on at some point when trying to select the ‘Fit groups together’ switch. I must have accidentally enabled this over the weekend.

The last time this issue occurred (and I hadn’t seen it again until now) I did have the flood fill option selected as well. I’m not sure what other changes I had done to alleviate the problem, but it may be a factor after all.

Here are my machine settings

Thanks for all the help!

Your X acceleration of 10,000 mm/sec^2 is very high. Try turning that down to 3 or 4000 and see if that helps.

Thanks Hank,
Alright, I’ll give it a shot.

No luck so far. Shifting seems to happen no matter what.
I do not believe it is due to acceleration issues either. I’ve lowered acceleration to requested amount, yet sometimes I still have odd shift issues.
@LightBurn The video I posted in the first post showed an example of the laser running with 1/3 of the stock acceleration values, and still running into the same issue.

You changed the X-axis acceleration for engraving for that video? If this was a software problem it would repeat identically with each run - there is nothing in LightBurn that is random or non-deterministic, so if you give the exact same inputs, you get the same outputs. Since you’re describing an issue that happens randomly, with some files, it’s more likely something mechanical or a communication glitch. I would suggest trying a different USB cable, just to eliminate that, as well as a different USB port on the computer.

Sorry, I don’t think I spoke properly there.
The problem isn’t that it is a random problem with one set of files, the problem is that it will always happen with certain files.

If I load up a problem AI file, I can expect a shift every single time the job is ran after the first layer. The only way to get a proper job from that file, is to run each layer individually. (disable all but one layer at a time). Doing so this way there is never a shift. I’m not ruling out communications issues, but at this point it seems extremely unlikely to me.

Are the shifts always in the same place? Machine resonance can be caused by certain orders of moves at the right speed - even small moves done relatively slowly, if the movement sequence is “just right” can cause lost steps, and running the job in a different order can reduce those.

If you can email me a LightBurn file, and a saved RD file from your system I can try running it here. Use upper-left ‘User Origin’ so I can place it correctly. If the RD file exported from your computer runs properly on my controller then it would have to be something in the machine itself or the comms.

You can actually import an RD file back into LightBurn, and that makes it possible to check for errors in the file itself.