SHX files for Lightburn

Good day, I downloaded some SHX files shared by another member (thank you) but I do not see the single line ones
Please see screenshot

Did you tell LightBurn the location of these SHX Fonts? Fonts and Text - LightBurn Software Documentation

LightBurn uses the SHX fonts identified in the settings and will show the font type in the dropdown font picker.

Hi Rick, thank you, yes I did tell Lightburn where the fonts are, the problem is I went basically through all of them but could not find the single font ones, only the “crazy” ones as in my post

What is the name of this font you are showing? Show us the settings for the SHX fonts you have in the Device Settings along with showing us the drop-down font list.

It looks like you also have ‘Filled’ rendering set for the visual display. LightBurn is intended to work in wireframe mode, so it is a bit difficult to see what you are displaying. Please show the same but include the entire LightBurn screen this time. Some of what I want to see is missing in your shot.

Hi Rick

Sorry, please make LightBurn full-screen first, and capture with the font list pulled down like I show.

You missed some of what I asked. Helpful to know these things.

This is a good post providing a list of single line SHX fonts and some ways to manage. If you haven’t already, this may be worth review.

Rick, there are many fonts and the pull down menu does not show all of the, here are some

Rick, thank you, downloaded them and working 100%

Glad to hear you are sorted. BTW, you can select the ones you like and only load those. Just place a copy of the ones you like into a new directory, then update the location in LightBurn. You can also ‘Add to Favorites’ with a right-click.

Rick, appreciated, and thank you for your help

I got a little over-zealous and installed a bunch of the SHX fonts. Is there some way I can uninstall many of them? (I thought they would appear in the Windows Font subdirectory, but they don’t)

SHX Fonts are different and do not install / uninstall the same way. You can just move the ones you do not want to another directory, or you can delete the font file by moving to the trash.

As I said,

Somehow (I forget how) I installed too many SHX fonts. I want to uninstall some, but even after searching my hard drive, I can’t find any files with the .SHX extension. And when I go into LightBurn, Settings, Files and select the Set SHX Font Path, I don’t see any SHX fonts. It says that directory is empty . . . even though I see them in my fonts dropdown window. What am I missing?

Click the ‘Gears’ icon near the center-top of LightBurn screen to expose the ‘Settings’ window. From there, select the ‘File Settings’ (marked with the number 2), then hold Shift and click the ‘Set SHX Font Path’ button. You should then be presented a dialog asking if you want to clear the SHX font directory. Select ‘Yes’ and you should be set.

Hover your cursor over most everything for tool tips.

Update: We have added a button to that page that will clear the directory path. This should help with clarity. The Shift-click will continue to behave the same. Should be in the next release. :slight_smile:


I don’t see the button yet . . . ? But shift-clicking the button which says “Set SHX Font Path” works well! Thank you.

1 Like

It is in the beta version we are currently testing as a release candidate. Timing…real soon-ish. :wink:

I’m new to lightburn, I tried to open/ add the shx fonts in font book, however they are grayed out and won’t load into my font list in lightburn

SHX fonts won’t be made available in Font Book. You need to specify their location within LightBurn itself. Rick shows how to do this in the earlier post in this Topic.

Once completed, the fonts will show in the LightBurn font pulldown.

1 Like