Simplex or line-type font

Hello everybody.

Say, is there a way to get a Simplex or line-type font (if I’m using the correct term)? The type of font I use most is just lines. I have to write my text in this kind of font in my CAD program, explode text, save as a dxf, then I can import into my Lightburn project. However, any time I want to modify the text I have to do this all over again which is obviously quite cumbersome and time-consuming. Though I have downloaded different fonts from the internet and they do appear in my font index in Lightburn, I cannot get a simplex font which is an option in my CAD program.

Please advise if there is a way to change the font types in Lightburn to simplex line-type as shown in my example.

Thank you.

TIm

I found a free download for a simplex font.

It installed with zero problems (in Windows 7) with the following result:

Watch out for all the fake download buttons on that site. At least the real one shows you the filename.

Thanks, but that’s not what I was after. I’m after a line-type of font like in my example.

Tim

Here’s a link to a page with info and links to single line fonts …
Single line fonts

There’s one called mecsoft which I’ve used in the past. Works very well for laser cutting.

Hmm, thanks guys. I’ve visited the font site and downloaded Mecsoft, but here’s what I get when I type it in…

If it matters, I’m using Windows 10.

Thanks again so far!

I’m pretty sure that single line fonts are being looked into by the Lightburn team, hopefully they might be in the next release.

Brilliant guys!

I found this one in the “Bargain Bin” at On Line Fonts.com:

http://www.onelinefonts.com/index.php?main_page=product_info&cPath=137&products_id=320

Paid the $5.00 and downloaded it. Now it’s in my font library for Windows 10 which shows up in Lightburn too. Now all I have to do is select this font, type in my text and it makes editing so much easier. Seems to have a small quirk though if I type in too small or too large a font size or something else I’m not quite sure of, sometimes (not always) the text disappears as I type. My work-around that is to type my text in a different font, then change to the desired line font.

Anyway, I’m a happy camper now and life is a little easier.

Tim

When using single-line fonts, turn off the weld button on the font settings, or it’ll get confused. TrueType and OpenType don’t have the ability to render “open” shapes, so single line fonts usually have a pair of lines on top of each other.

There’s a type of font called SHX, which is an old Autodesk / AutoCad format that I’m adding support for. It’s partially done, but will still be a while - their arc handling is pretty strange, and once that’s working I have to figure out how to add these to the font list.

Hey, thanks!

Yea, I was playing with “Weld” and found it helped (but couldn’t remember if it was better with Weld on or off). I’ll turn it off - thanks again! :slight_smile:

Being able to use SHX fonts would be great.

I have a bunch of single-line TrueType fonts but they always end up looking hinky due to the way TrueType works.

They’re getting much closer. I have all the arc handling done now, and have Unicode SHX working too. Still need to write a bunch of UI to let you choose them.