Sizing wrong since last update

Updated to 1.04.01, Windows 10, xtool D1 10w with Devil 1 kit from Coby Schmidt, Lightburn 8mp120 camera. I had things dialed in with size and placement with camera to within a few thousandths. Started a project with a previous file that worked perfectly. Things didn’t fit right. Started checking and cut dimensions are way off. Seems the update forgot my settings, didn’t even know what camera I have. Went through the camera setup and alignment 4 times. Tried using both camera adjustment from scratch as well as the one made for my camera. Mostly got alignment close but, not as close as I had. Big problem is x and y sizes are off. A 4 inch square measures 4 3/16 X 4 1/16. Changing X & Y in machine settings only seems to make it worse.
As I stated earlier I had all of these settings working.

Forget the camera for the time being. You need to get your axes calibrated.

How are you doing this?

If you’re not familiar with manually deriving those values I’d suggest you use the Edit->Machine Settings->Calibrate Axis.

Make as large a rectangle as possible and enter values for the design dimensions vs the actual burned dimensions. Try to set the cut settings to make as thin a line as possible.

Once your dimensions are locked in then rerun camera alignment. If you are getting distorted images rerun your camera lens correction before running alignment.

By the way, note that LightBurn and the upgrade would not be related to axis calibration changes.

I thought I explained that I had done that.

Done what exactly? The only portion that looked similar was the portion I quoted. And it sounded like you were editing the value from Machine Settings directly.

Also, are you saying that 4x4 is the largest square you can burn?

I did that, tried a number of times.

are you saying that 4x4 is the largest square you can burn?

I can burn as large as my bed is. I used 4" because that is as large as my caliper will measure.

Is the 4 3/16 x 4 1/16 measurement as accurate as you can get it? If not, can you provide as accurate as possible?

Please run this command in Console and return output:


For a 101.6 mm square it resulted in
x=107.86 mm
y=115.03 mm
$$ after doing Edit->Machine Settings->Calibrate Axis using those figures

I don’t seem to be able to copy command output. Is this what you are looking for?

That resulted in
X=107.86 mm

These values are a bit odd. This makes me think something else might be at play.

Can you first make sure that you’ve not enabled rotary function? If yes, disable rotary and retest.

If not, can you enter these commands in Console?


Then rerun the same test. What are the results?

Can you confirm that you have the same stepper drivers and stepper motors for X and Y? Are the pinion gears the same size for both motors?

Also, note that you should be able to copy from Console output by right-clicking after highlighting.

A post was split to a new topic: Sizing changed since last update

Rotary was and always has been off, never used it.

Those settings resulted in


Nothing has physically been changed on the machine since it was working correctly.

Not what I expected… but reviewing my work not sure how I arrived those values.

Can you try these settings please? These seem more reasonable.


Success, with a bit of trial and error I am within .02" of being square and that could be because it’s wood and measurement error. I cut 6 squares of various sizes from 5" to .5" all are within .02". A 1" circle is within .005 of being round.

I changed the settings to
and realigned the camera. So far in my tests camera alignment has been spot on.

Not sure why settings got changed or even if it was with the latest LB but, I learned some things witch is a good thing. Thanks for your help, it got me going in the right direction.

I’m not understanding why such wide variation in the values but glad you’re up and running.

I’m tempted to try something like 100.050 but don’t want to push my luck.

Well, unless there’s something else fundamentally wrong you should always be able to go back to known good settings. If there is something wrong you probably want to find out now anyhow.

You’d have to likely recalibrate the camera, however.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.