Snapmaker 2.0 A350 Rotary Attachment re-visited

LB_Rotary_test_line_360.txt (1001 Bytes)
LUBAN_Rotary_test_line_360.txt (1.3 KB)

After a significant hiatus, I noted some changes to the broken setup for the Snapmaker Rotary Module (added a B axis option) so grabbed an upgraded license to test this out. Sadly, it’s still broken.

Whilst the Rotary setup in LB works as expected when hitting the ‘TEST’ button, the generated g-code does not.

@LightBurn - I know the number of Snapmaker users is probably small, but as you came so far in supporting it in the past (thanks!!) I am wondering if a g-code breakdown might help with a fix?

Scenario - a 50mm cylinder [circ. 157.08] with a line circumscribing 360° as a single path test;

See below the generated code from the native ‘LUBAN’ software for the SM2.0 [I’ve scrubbed the thumbnail png from the header to condense the file] and the LB equivalent. Added comments per line.


;Header Start
;header_type: laser
;tool_head: levelTwoLaserToolheadForSM2
;machine: A350
;renderMethod: line
;file_total_lines: 49
;estimated_time(s): 50.546
;is_rotate: true
;diameter: 50
;max_x(mm): 0
;max_y(mm): 50.005
;max_z(mm): 0
;max_b(mm): 180.089
;min_x(mm): 0
;min_y(mm): 50
;min_b(mm): -179.75900000000001
;min_z(mm): 0
;work_speed(mm/minute): 500
;jog_speed(mm/minute): 3000
;power(%): 1
;work_size_x: 320
;work_size_y: 350
;origin: bottom-center
;Header End

; Laser multi-pass, pass 1 with Z = 0
; G-code for laser engraving
; Generated by Snapmaker Luban
; G-code START <<<
G90 ;ABS positioning/coords
G21 ;Millimeter units
M106 P0 S255 ;FAN Index_0 ON, Full speed
G0 F3000 ;Set RAPID speed to 3000mm/min
G1 F500 ;Set FEEDRATE to 500mm/min
G0 X0.00 ;RAPID to X:0
G0 Y50.01 B-179.76 ;RAPID to Y50.01, ROTATE B -179.76°
M3 P1 S2 ;Laser ON, Power 1%, Power, S, as 8bit [integer]
M3 ;Laser ON, but could be quiery
G1 Y50.01 B-0.66 ;FEED @ Y50.01, ROTATE B to -0.66°
G1 Y50.01 B180.09 ;FEED,@ Y50.01, ROTATE B to 180.09°
M5 ;Laser OFF
G0 Y50.00 B0.17 ;RAPID to Y50.00, B0.17°
G92 B0.17 ;Specify B axis is at 0.17°
M107 P0 ;FAN Index_0 OFF
; G-code END <<<
G91 ;Relative position mode
G0 Z0 F150 ;RAPID to Z0 @ 150mm/min
G90 ;ABS positioning/coords


;Header Start
;header_type: laser
;max_x(mm): 238.5
;max_y(mm): 170
;max_z(mm): 0
;min_x(mm): 81.5
;min_y(mm): 170
;min_z(mm): 0
;Header End
; LightBurn 1.2.04
; SnapMaker device profile, user origin
; Bounds: X81.5 Y170 to X238.5 Y170

G21 ;Millimeter units
G90 ;ABS positioning/coords
G0 X0 Y0 F0 ;RAPID to X0,Y0 @ 0mm/min [no feed?]
G91 ;Relative position mode
; Cut @ 500 mm/min, 1% power
M106 P0 S255 ;FAN Index_0 ON, Full speed
M05 ;Laser OFF
G0 X-78.5 a0 F0 ;RAPID, X-78.5 [regular 3-axis move here and not B rotation]
;ROTATE A to 0° [assumed!?!]
;[should be Y:50 and B:-179.76]
; Layer Internal Cuts
M03 P1 S2.55 ;Laser ON, Power 1%, Power, S, as 8bit [float]
G1 X157 F500 ;FEED to X157 @ 500mm/min [regular 3-axis move here and not B rotation]
M05 ;Laser OFF
G90 ;ABS positioning/coords
; return to user-defined finish pos
G0 X0 Y0 F0 ;RAPID to X0,Y0 @ 0mm/min [no feed?]

It appears the LB g-code for the most part is for regular 3-axis moves. No referencing for B-axis as set in the Rotary Setup options.

Is it possible to fix this?

Thanks in advance

Team Lightburn,

A wee bump here - would be great to know either way if this issue would receive attention in the future.

Thank you :smiling_face:

It would be extremely handy for Lightburn to work on fixing this with a “Plug and Play” easy setup for the Snapmaker rotary but as of right now it doesn’t work at all. Very disappointing. They might sell more licenses if this worked as Luban is not a very user friendly software.

1 Like

I concur entirely. The Luban solution, despite having a few years of development, is pretty awful and some fundamental features seem to be missing and some significant bugs still prevail. I do think that the rotary axis post-processing is simply not implemented at all. Latest versions add odd ascii characters in the compiled gcode when rotary is enabled, despite the ‘test’ button executing the correct code to the B axis when pressed! Frustrating. I do appreciate that the team must be busy with bug-squashing the new version, but some insight as to if this might get some focus would be helpful and greatly appreciated.

I got really good results etching grayscale images on glass w/o the rotary after switching out the laser firmware and some plug-in changes as recommended over at the SnapMaker forum. This led me to purchase an LB license. However, I never bothered to check the rotary axis. This is a bummer, I managed to get something lasered (using 1.2.04) but it was nowhere near as good as the non-rotary images. I hope we can get some more support here. We’re so close!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.