Snapmaker not connecting correctly

Hi - I’m new here and had found a thread before joining that I had wanted to comment on - but upon joining I can no longer find it.

I’m trying to connect my 350 to LightBurn - I’ve gone through and added my machine manually, picked the correct Com port, ensured that the correct driver is installed (CH340), turned off the door detection on my console for the enclosure and changed that baud rate to 115,200. LightBurn software is showing that the laser is “ready” but I have no “move” tab. I’ve tried to get it to frame, go to origin and home - all with nothing happening on the machine.

Please help!

Enable Move tab in the Windows menu.

Can you open Console window and capture what it’s showing and post here?

Also, please take a full screenshot of LightBurn with Laser window showing.

Thank you - I have enabled the move tab.

This is the Console:

Full screen:

And my device settings:

Try right-clicking the Devices button in Laser window. If you see the “Ok” in Console, can you type $I in the entry field and hit enter after that? What does Console show then?


Sorry. Forgot that Snapmaker doesn’t run GRBL.

So it seems LightBurn is connected to something.

Can you check to see if the jogging controls in Move window work?

And can you confirm if COM4 is indeed the Snapmaker? I would expect it to be more chatty than what you’re getting.

Also, what device type did you setup the Snapmaker as? Did you pick the SnapMaker device type?

I have no idea what I did - but now it seems to be connected to my Snapmaker. But for some reason when I tell it to go to the origin - the laser is not even on the bed. I have the bed size set at 320 x 350 y but this is how the laser is sitting.

Nice. Make note of the port that it’s connected to. You may need to manually select that port at times.

Hi Chelsea, was this the thread you were looking for? Snapmaker 2.0 A350 Setup Guide

No, I have read that one - thank you though!

Now I’m trying to get my origin to match with the edge of my bed properly

Does your machine home? If so, to what corner and what is the reported position at home using “Get position” in Move window?

If you jog to other corner of machine are you able to make full use of the bed?

Yes if I tell my machine to home - it goes to the top left corner. The reported position is shown:

I believe I can can get full use of the bed - I haven’t tried yet. Just trying to get everything sorted out here before throwing a full bed project at it.

After I get this sorted out - I have to figure out how to focus the laser.

So your position after homing is -19, 347? Does going to 0,347 put you on the bed? Or perhaps there’s a buffer on the Y axis as well?

I remember this had come up before but unfortunately can’t recall the resolution to this. Some searches here should bring up some Topics on this.

Yes that was the position it was showing after homing. I shut the machine off last night, and then came back to it this morning and it is showing the same coordinates. 0, 347 puts me on the bed, but even though the machine coordinates appear to be set correctly (320x- it won’t use the last 35mm at the top of the bed.

I assume there’s some sort of home offset configured in the firmware.

How close to the front of the bed are you at 0,0? If that’s dead-on then can you simply increase the workspace area in Device Settings?

0,0 takes me off the front edge of the bed

In that case does increasing Working Area height in Device Settings allow you to address the upper portion of the bed?

No it does not. I have even tried to increase the work area to 400 and it still will not reach the top of the bed

In that case likely something on the firmware side limiting this.

I will reach out to Snapmaker and see if they might have a solution