SOFTWARE - cant connect but Laser GRBL can

Hi Support.

I have been using my laser for some time with Lightburn. So it was working : )’

I recently purchased a desk top computer and my problem started.

It had Windows 7. This proved to be a problem and I had to update the USB driver. After the driver was updated the PC was connecting to the laser but would not operate, home or frame jobs.

I relieved the following message on the console in Lightburn: Grbl 1.1f [‘$’ for help]; [MSG: ‘$H’|‘$X’ to unlock]; ok

I tried updating the firmware but cant paste the BIN folder to the Ortur. I recieved this notification - Error 0x80004005: Unspecified error

NOW, I cant connect to the laser and receive the following error on the console in Lightburn: Waiting for connection and Port already in use?


When I use Laser GRBL - I can make the laser move

Please help me to connect Lightburn to my laser

Paste is an unusual word choice for reflashing firmware. Perhaps your hurdle is procedural: This will take you to the instructions provided by Ortur.

You may also want to scroll up on that page to see the warning about McAfee total protection.

With a fresh install of Win 10 you may not have installed the STM Micro driver.

The LightBurn Ortur setup video is excellent.

It is common for Win 10 to not be looking for the correct port and USB seems to reassign ports. Also, if another software package such as LaserGRBL has grabbed the USB port where the laser is connected it won’t share. Please confirm that LaserGRBL and the reflash utility are both closed (not running) before proceeding.

With everything powered and connected, open the Laser window and the Console window in LightBurn. If you are still getting the ‘not connected’ information, select a different COM port in the Laser window and wait a few seconds. Hopefully you see the connected device.

1 Like

Ortur does not use CH340 drivers
The error presented seems to be a mismatch in firmwre version installed → tried to update

now what would be important is to understand if
a) Device manager detects laser when usb is plugged
b) Lightburn is being configured to use the correct COM port (i suspect not)

1 Like

My apologies. STM Micro driver.

I’ll remove the error from my post.
I’m grateful for your contribution (and Ortur’s contribution) to the forum and the community.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.