Software crashing on Mac

I am trying to run lightburn on my Mac with operating system macOS Mojave 10.14.5 and when I scan for my newly installed laser it crashes. I have tried uninstalling and re-installing the software and restarting my computer. I’ll note again this is the first time trying to use the software.

Try disconnecting the XCarve and plugging it into a different USB port. I’m not sure why, but that controller seems to lock out ports on the Mac fairly regularly, and this causes problems with the port scan.

I’ve seen a single XCarve show up twice on some systems as well.

I’m having the same issue. Tried suggested above, didn’t work. Also on a MAC. Machine is Shapeoko. Powered down completely, used a different USB port, same result.

Please do not double post. It creates double the work. We are addressing your issue separately on your other post below.

I tried this along with keeping the x-carve unplugged and scanning for the laser and the software crashed the same both times. So I am guessing it is on the software end.

Is there any progress on this issue?

LightBurn should not crash. Are you getting any crash report displayed when this happens? Please copy and paste all contents of this report and sent via email to developer at lightburnsoftware dot com for review.

Sent the crash report. Changing the USB port does not work. Quick question tho … If I connect the machine via LAN to our main switch, Will the search find it via LAN ?


I think the best answer given to me by support was to close the autodetect window because whenever I run that on the mac, the thing just crashes. So do not let that run but simply manually add your laser instead and all works as it should do :slight_smile:

It will not auto-find via LAN. USB is easier because the protocol includes things like vendor and product identifiers, where Ethernet would require doing a full port scan and things like that tend to freak out sysadmins and firewalls.

I am aware of the scanning issue on the Mac, but haven’t been able to reproduce it yet, or figure out why it’s a problem. As Jonathan mentions, you can configure the device manually and that should be ok.

I gave up and bought Parallels to run the windows version. I wanted to use the built in bootcamp but it wasn’t cooperating. I just wish I didn’t have to spend extra money to get this to work. I’m on the trial version and the trial isn’t off to such a great start.

You don’t need to run the Windows version under Parallels on Mac. The Mac version works great and I have been using the native Mac version for better than a year now. The issue you are having has to do with the ‘Find my Laser’ feature, so don’t use that at present.

As Oz and Jonathan suggest above,

You can search this site to find other posts on how best to manually set up for your Shapeoko.

Could not get LightBurn to get past auto find. Added my EleksMaker manually identifying it as grbl and LightBurn seems to work fine. Less than 24 hours of experience but so far so goo.

Once I have my hardware back again I’ll be able to dig into this and see if I can figure out what’s going on.

I am new to light burn and i am running el capitan10.11.6 and having similar problem. LB starts, says click next to scan for your laser and crashes. I’m sure I’m the problem but don’t know why. RDC644XG orion motor tech 700 x 500 laser. LB will work if I use PC but i need that to run another device. Any ideas ?

here’s screenshot

sorry for being an idiot, I setup manually as you suggested so it appears i can start trying it out, thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.