Spacebar doesnt work as PAN (Windows 11 - Lenovo Laptop)

I’ve got a laptop, it has a touchpad, I can’t use Pan if activated by pressing and holding spacebar (mouse movements or click+drags do nothing.

If I choose pan from the toolbar it works as expected.

It feels like windows has taken over the key binding and is repeatedly pressing spacebar instead of sending the keydown/up event once.

Somewhat counterintuitively spacebar alone won’t cause panning. Spacebar essentially enables panning but needs to be accompanied by a click-drag to actualize the pan.

You can confirm this if the pointer icon switches to the hand when spacebar is pressed.

There-in lies the problem, when you release spacebar, the mouse-selection mode is activated and Pan de-activated. If I maintain the spacebar held down then mouse movements and click+drag combos do nothing

Nice video. This is the sequence that works for me. I also have a Lenovo with toudhpad and W11. Not sure what might be at play.

Are you running and background apps that could be modifying your keystrokes? Perhaps a key modifier or even a password manager type application?

Can you confirm that middle wheel/mouse wheel click-drag with an external mouse works as expected?

This worked for me, give it a try!
Sticky Keys feature enables you press one key at a time for keyboard shortcuts. As a lot users reported, disable Sticky Keys feature help them save their spacebar back to life. So when you find your spacebar not function, the first quick fix you can try is to check the Sticky Keys.

  1. Press Windows key + I key together to open Settings Window.
    Then scroll down to find and click Ease of Access.
  2. Click Keyboard on the left pane. Then check the icon of Sticky Keys. If it’s on, set it to be off.
1 Like

That’s a really good point. Latest windows 11 update brought back magnifier to an old shortcut (Fn+Tab) which I can’t disable, but sadly sticky keys is off. I do however have windows powertoys installed, but disabled most of the keyboard shortcuts.

I use Powertoys as well with some limited keyboard shortcuts, none that are directed to LightBurn. And yet this works for me so not likely something inherent to Powertoys. Perhaps try disabling Powertoys entirely to see if it makes a difference. I have noticed that some Powertoys functionality only resets after a full reboot so you may want to reboot at some point as well.

1 Like

Just to add, it works as one would expect in Inkscape, the newest 1.2 (not got the old one anymore to test sorry). I press and hold spacebar while using a random drawing tool, the cursor changes to pan and all mouse moves scroll the view, then when releasing spacebar the cursor goes back to the expected previous drawing tool.

Interesting. I get the same behavior in Inkscape. The only difference I experience in LightBurn is that I must add the mouse click while I drag for this to work.

Very odd how this doesn’t work for you.

Have you confirmed if middle-mouse click drag with an external mouse works in LightBurn?

1 Like

no mouse at the moment

Plugged in external mouse, works fine. Touchpad doesnt work. I tried clicking with the mouse and moving the cursor using the touchpad which works. Using the mouse movement with touchpad clicking does not work.

Interesting. When you use the touchpad are you physically pushing down on the touchpad to the point where it clicks or are you using single tap click? I have to physically click for this to work.

Perhaps try updating the driver for your touchpad if available.

Can you confirm your touchpad click works elsewhere?

Every other program works as expected. No driver updates offered, regularly run windows and lenovo update. Running beta/dev release track of Windows 11

Can you try one thing?

Can you try using space+click drag with external mouse? Hoping this will isolate if it’s an issue with spacebar or an issue with the click.

Yeah sorry thats what i was trying to say, it works if i click drag with the mouse, and it works if i click with the mouse and move with the touchpad, so its the touchpads click that is the problem.

As a softwarw developer I should have been more clear. Happy to run a debug copy etc, if there’s anything useful i can do then let me know.

And just to be clear, you’re not talking about middle mouse click drag (without keyboard spacebar), correct?

I’m out of ideas at this point. I was actually leaning toward it being a spacebar issue rather than a click issue but seems your tests show otherwise.

Perhaps the @LightBurn folks have more insight on this. They may ask you for more debug info.

Correct, I am not

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.