Start Button Not Working

Using Ruida 644XG. For some reason the Start button in LightBurn will not work. Every other setting I can figure seems to be working properly, I can still Frame the image but it will not start engraving when I press Start. I have tried troubleshooting everything I can think of but it won’t work.

Which version are you using? If this is 0.9.22, and you’re connected with USB, upgrade to 0.9.23 and that should be fixed.

It is 0.9.23 and am connected through a USB, using windows 7…
I mention this because we got in 3 lasers, 2 of them are hooked up to machines running windows 7 and the third is hooked up one running windows 10. The one running 10 is perfect, but the ones running Windows 7 both have the same problem with the Start not doing nothing.

Starting with the basics, when was the last time you power cycled these machines? And how long are the USB cables?

Cycled the machines within the last hour, no luck.
USB is 6 foot, what came with the machines.

Try re-running the LightBurn installer on the Windows machines, and check the box at the end for the FTDI device driver. Let me know if that changes anything.

Ok, just did, still no change.

I am able to Send a File and the laser does see it.
But when I press Start the Pen moves and the laser fires, but
then the rotary does not move.

This again is on both lasers.

This is the first you’ve mentioned the rotary. Are you using a 6445? We’ve seen the ‘Start’ button issue with those on both LightBurn and RDWorks, when the rotary setting is enabled, so this points to a firmware issue, not software.

Mark, Did you figure anything out with this? I am having the exact same issue have been looking for firmware but haven’t found anything yet. Just wondering what you ended up doing.


Was there any progress on this? I can control U-Axis from controller, from lightburn. But the Start Button in LB will not send a job. Have to manually send it over to onboard storage.

Which OS and version of LightBurn?

I am Windows 10 with Ruida 6445GC(EC) firmware is V15.0.22. I am running Lightburn 9.24

I’m Having the same problem windows 10 with a Ruida 6445G(EC) firmwareV15.1.27 and Lightburn 9.24.

Is this only with the rotary, or for all jobs sent to a 6445G?

I have the same problem
The problem is with the rotary
But i can frame the job just that the start button is not doing anything.
And if i dont check the rotary enable i ca send and start the file but i need to adjust my y axis to work.
Is there any solution?

Can you send the file to the laser, then run it from the console? You’re saying that it’s only the ‘Start’ button that doesn’t work, correct? And only when the rotary mode is enabled?

I can send it to the console but i get an error from to console regardin the position.
The console is seeing the y axes at 0 and it thinks i dont have space for the project to run safely.
My problem is strictly regarding the start button in the rotary enable mode.
But i can frame the job using rotary mode just cant start it.
I use current position top right to frame the job and its doing it no problem.
But when i hit start it doesn’t do anything and the laser doesn’t react to it.
If i disabled the rotary then i can start the job from lightburn but i have to change the size of my y axis to go correctly i asume.
I didn’t try it yet.
By the way, when i connected the rotary my laser was stopped and i switched the wires
Then i start the laser and with a metal thing tap the sensor so it can stop turning the rotary for no reason.
Should i switch the cables after turning it on and place the x and y axis to the desired location?

Thank you for the quick response.

No, you shouldn’t move the cables when the machine is powered - that can damage the stepper motor drivers. What you’re doing is correct, it’s just that they apparently changed some commands for the 6445, and I have to figure out what those are.

Have you tried running a rotary job using RDWorks, and the Start button there, just to see if it behaves the same way? If it does, that would point to an issue with the firmware, not the software.

I have the same issue. When I enable the rotary, I can FRAME the logo but when I hit START, nothing happens.
I disable the rotary and it will work, however when I test burn a circle, it comes out as an oval.
From the videos I have watched, it is suggested that I change speed or object diameter. No matter what I input the burn does not change at all.
What am I missing??
Does seem like a communication issue

Details about which specific controller model you’re using, for one. :slight_smile:

If it’s a 6445G with the newer rotary firmware, it may be something about how that controller communicates when in rotary mode that we haven’t updated yet. I will have to look into this.