Start job>start air compressor>delay 2s>start cutting, any chance?

Hi
Is there a chance to set Lightburn to delay a job, after starting it?
I mean, when I use a standard aquarium air pump, it’s fast enough to start just when the cutting or enraving starts, but that blower is not enoug for me.
That’s why I use external 50L air compressor with a 12v solenoid valve, but it’s slow reaction doesn’t satisfy me. There’s a 1-2s delay in getting proper air pumping after the air compressor is being powered. That’s why I need to: start job, turn compressor on, maybe set delay to 1-2 seconds, and only after that finally run the engraving or cutting process.
It would be also good to have a switch that will allow the compressor to run all the time between starting and finishing all jobs (engraving, cutting).
Does anyone have a clue how to solve my problem?
Thanks,
Darek

There’s no proper built-in way of doing this. When this has come up in the past one workaround that’s worked for people is to just create a simple object on its own layer with cut settings set to 0% power where the duration of that cut is sufficient to start air.

Alternatively, for a Line operation I suppose you could set a “Start pause time” at 0% power in Advanced tab but probably not ideal to do this in your proper layer settings as it may cause confusion.

The addition of sublayers could potentially be used in a similar way.

1 Like

The problem is that when I set the Start pause to 2s the laser head just moves to starting point, then wait 2s and when the delay time ends, starts the job + air assist. For the air pump it’s okay cause it has instant reaction, not holding any pressure. But always when proper air compressor is connected to air assist socket, it starts just a second after laser beam hits the material because of slow reaction of the external solenoid valve holding the air from compressor. It’s too late, some fumes can go inside the nozzle.
If it could only start one for Line job and end after cutting everything, that would be great but every single shape means cutting off the air assist and turning it on again.

Then either setting up a separate layer or sub-layer before the actual cutting layers should get you what you need. Just make sure that dummy layer is ordered to go first.

Ok, checked it again and it looks that my external 12v solenoid valve isn’t as slow as I thought and the problem is in the relay inside the laser. Checked it twice and just 0.2-0.5s after starting to cut, the relay is on and usually that 0.5s delay is too much to avoid risking fumes going inside the nozzle.
I have to check what you suggested, adding as a first layer short line with 1% power and air assist on but I think that after finishing that “invisible” line, controller will cut off the air and start it again on the new layer.
I still hope that I’m wrong :wink:

If your primary concern is the prevention of smoke fouling the lens then I’d suggest you setup a system where you always get very low pressure air and activating air transitions to higher pressures.

That would be good practice in general really.

3 Likes

I was not wrong. Relay inside the machine turns off after that invisible layer and turns on on a proper cutting layer and between different closed shapes…depending on a distance between them that’s sometimes just a 0.1s or something like that.

The only solution for me is to be able to set the -/+ delay for “wind” after clicking start, to make sure that the relay will start and air will go before the laser goes on.
it would be good if we could write our own starting scripts depending on a specified list of variables.
That would avoid extending the advanced controls and let us users to set it very precisely for our needs…or just a simple control for “Wind before laser” set ON and a value of 1.5.
I think I’m not the only one who would appreciate that :slight_smile:

What you suggest is some sort of solution to my problem but I keep my air compressor outside with just only a pneumatic tube through the wall, and a valve just behind the laser, 10cm from the air inlet and would like to keep it as silent as possible and adding a small air pump would generate a noise.

There’s been a good amount of discussion about having an openly available API or scripting capability. From what I recall there’s some openness to the idea but not sure where that fits into overall priorities for the team.

You may want to take a look at the feature request site to upvote the items that would work best for you.

1 Like

Problm solved. Sorry, I misunderstood cause I’m still learning on a new laser cutter after my old K40’s.
After reading this topic: Setting Air Assist (0.5sec before cut)
I was reading your “Start pause” layer setting suggestion as a “Start delay” in device settings which I tried before but with no succes in my case.
That’s my fault.
Now only “problem” is that the delay set to 800ms delays cutting every single shape, even in a group but I hope I’ll also find a solution to that.

You get a delay between every shape? In that you’re saying it cuts air during that time?

That surprises me a little in the sense that I wouldn’t expect air command to be sent on a per object basis. But I’m not familiar with how that works.

SOLVED (solution below)
Let me answer first :slight_smile: If I set “Start pause” for a Line layer which is ten circles, each one is slightly smaller than previous one outside. Program stops for the amount of time set in start pause parameter.
Means that all cutting process takes 10 seconds more if we set 1s start pause value.

Solution for Ruida controllers is to install RDWorks, Go to “User” tab on the right panel of main RDW window, check “Other” field and click “Read” button below the tab.
This will read all the parameters from the controller and “Blow Type” setting will appear and “Laser On Blow” is a default setting. It has to be “Processing blow”.
Then “Write” button to send changed settings and voilla…you can close RDW, disable “Start Pause” setting, because from now on the air assist relay will start just at the moment when the laser head starts to move - and that’s one or more seconds before the actual cutting starts :slight_smile:

Just an FYI, On my Gcode machine my solution to turning air assist and extraction on with a delay before starting to cut/engrave is to use the Gcode function under the tools settings in LB. I have added this code to the start to give 5 secs from stating the pump/extract.
M8
G4 P5

And this code to the end to give me 10 secs more extraction (and air assist as they are electrically connected in parallel) to clear the case before opening the lid.

I have a solid state relay connected to the wind output on the processor:
Solid State Relay - 40A (3-32V DC Input) - COM-13015 - SparkFun Electronics

Hope this helps.

Cheers

David

It’s not an option for any DSP controller like Ruida ones.
There’s no GCODE option under Tools menu… maybe it is if you have all the extensions licensed or maybe the menu items change depending on currently selected device. I don’t know.
Happily there’s a simple way of solving this problem when reading settings with RDWorks, before setting everything up in Lightburn.

Unless you don’t have a Windows machine… Many people have macs/linux and not every version of RDWorks has that option, from what I’ve read…

No everyone has a windows machine and not wanting one, I don’t know much about that software…

Fortunately mine was configured correctly … It would be nice if Lightburn knew how to access some of these more obscure options… so we could ‘play’ around with them…

:smile_cat:

LB has all the Ruida config available like RDWorks. Many are cryptically labelled and we don’t know what they do. But I could find no delay between start of a signal for Air Assist and the laser cutting.

The prob is >50% of our users use WORK origin and the head will already be at the work origin when starting. So it can fire instantly without any delay to spool up the compressor. It would have been SO simple to write another line of code inside the Ruida…

Where is the ‘blow’ option in Lightburn?


His was set to turn on when the laser cut, after the change it stays on for the layer.

I think I read about this in the forum here and there was no option in Lightburn…

:smile_cat:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.