Still having issues with engraving, suspect LPS

Please see the old post for context.

For a year now i’ve only been able to use my CO2 to cut rather than engrave.

The attached photos are a 50mm box, then filled (same size/position) with the scan offset to to -1.1mm to get them to align.

To me the laser isn’t switching off soon enough, it’s taking time to discharge hence the dots on the trailing edge.

This was done at 10000mm/s 30% power.
Obviously happens at all powers and speeds fast enough to make it visable, cut speeds are fine.

Cloudray M100, came with the 90W tube as a bundle from cloudray.
New ruida i’ve just set up is RDC6445S(CE).

Any other suggestions than the power supply is not good?

I am certainly not accustomed to your 90W machine, I have a 60W Omtech CO2

My 2 cents? How do you get your machine to travel at 10000mm/sec? I believe you need to slow that way down. It is trying to move so fast it can’t stop quickly enough to keep the lines where they belong.
Try setting at 250mm/sec and 30% power. Work from that setting to get your best engrave.

Thinking along @ferg comments… Whatever you set here will be limited by the maximum speed set within the controller.

Since we don’t really know how fast you’re actually running, it’s difficult to make much of a suggestion.

I will add that Ruida and other DSP controllers don’t seem to work well with a scan angle of anything other than a multiple of 90 degrees. So a 45 degree angle doesn’t allow the hardware to do this and is done by Lightburn generating code to be at this angle…

Unless you know otherwise or can explain why, I’d keep the scan angle to some increment of 90 degrees, preferably zero.

I can run fast, and I don’t have anything near what you have for a scan adjust…

The pwm frequency (period) on my Ruida is defaulted to 20kHz (50uS). I would think you could enter the 20000 value into the Lightburn machine settings and write it back to the controller?

It won’t let you enter the 20000 value of my machine?

This may make a different with metal tubes. With co2, it will take an analog voltage also, so I don’t think it matters although I’d think a 1kHz value would be more standard.

From the linked post… what does 24k refer to?

I’m old and I’m thinking we aren’t speaking the same language… :thinking:

Are your photos in the same orientation as it was cut on your laser…? I.E. is the Y direction up and down?


Sorry guys - mm/s is a typo, that’s 10,000 mm/m. so only 166mm/s.
So yeah, speed wise should be capable of going much faster.
Sure OMtech state up to 24,000mm/m.

I’ll edit the main post now!

So, the photos just uploaded sideways, those lines are done in the usual orientation of 0 degrees, and then the one box is tried at 45 degrees, just to see if it changed the outcome at all.

As for the frequency comments from the last post, that concern was really around topwisdom/lightburn compatibility where I wasn’t seeing a value of 20kHz in the right box. But scratch that I’m on Ruida now, and the PWM is definitely set to 20kHz which is what’s recommended by the laser tube manufacturer…

so yeah, just doesn’t seem to be switching off fast enough to me. Like the voltage is slowly dissipating.

You may need to develop offset Scanning Reverse Interval settings for your new Ruida controller.

This may be worth a look.

Hi John,

That’s what I’ve already had to do to get the lines somewhere close in either direction. A 1.1mm offset for 10,000mm/m

However if I draw a 20mm box, then a 20mm ‘fill’ - it overhangs the box on both sides quite substantially. So an offset would just push it left or right, but not shorten the scan line at all to make it fit in the box?

That’s what makes me think it just seems slow to ‘turn off’ the laser, so my line is longer requiring a bigger scanning offset to make it look correct. But even when it looks corrected, I’ve just actually corrected a 20.5mm line to appear square instead of it being a 20mm fill for example. Hence why it doesn’t fit in the 20mm box drawn.

Does that make sense??


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.