Strange texture while engraving

I’m new to Lightburn and still looking if it’s worth to buy a license after the trial ends.
My laser is an Atomstack P9 M50, I’m doing a lot of engraving test with different materials with the builtin “Material Test” function.
What I get as result is a strange pattern while engraving, not consistent between power and speed.
I attach a picture because it’s difficult to explain.
Line markings seems not affected, but everything is “Fill” result with this distorted texture, on the box with speed 200 and power 10 it seems that the Laser power fluctuates.
I’m not sure if it’s software or hardware related and what to do to resolve the problem.

post here the value of $120 $121 $122

1 Like

This pattern called “Moire”. This is most likely frequency beat between Laser PWM and stepping.

Atomstack P9 M50 has ESP32 micro, meaning that almost certainly it runs variety of FluidNC. That in turn has laser power PWM frequency adjustable. I believe this is $33 settings (please verify, I’m not sure). Default on most is 1KHz. Try to go up to 8KHz.

Not to leave other possibilities - Looking at zeros on the left - there is a lot of wobble. Can be just the way machine tuned or running too fast, but also can be the sign that something is loose. If changing PWM frequency does not help - try to tighten rollers and belts.

1 Like

i’m happy to always learn new things in this forum :smiley:

1 Like

Let’s first get confirmation from Ettore that this is in fact a solution, then we can celebrate.
(Unfortunately most will never come back to confirm, or not for that matter)

1 Like

you don’t know how much you are rigth on this…

1 Like

Axis acceleration is 500, I already lowered it from 1000 factory preset

$33 is indeed 1000, but there’s no apparent way to change it as 33 is not available to edit in Lightburn either LaserGRBL. Belts are already tightened, but I don’t think this is the problem. As you can see the “pattern” changes with the combination of power and speed in a geometrical fashion. If it would depend by rollers or belts it will be a fixed pattern changing on speed and not power. It seems some kind of interference in TTL output from the micro, or small variation of moving speed.

Anyway I tried to replicate the test pattern with the same parameters and I got a totally different result.
This is a Fill square with the same 200 speed and 10 power.
It’s totally different from the Material test square.
There are still some lines missing but not as the test one

And is a very strange behavior, but i agree with you, there is some interference in ttl output.
Btw i still see some wobbling in those lines

$33 is not a common setting to change, very few controllers have it (now more than before).
You change it in terminal, just type “$33=8000”. (no quotes).
To verify - type “$$” and look for $33 line.

Additionally, it is possibly that your laser shutting off below 10%. Would be specific property of your laser head. You may want to try different model.

And yet another possibility is that your power supply have some problem.

Start from changing frequency, then maybe different power supply.

Separately: that wobble over zeros is not pretty. Maybe you just need to run everything slower?

1 Like

I managed to change $33 value with $33=8000, and it seems it persist after a powerdown.
I done a test on the same sample, glass painted, and looks like it resolved somewhat

Wobble on text is because it’s running at 3000 of speed and P9 have only one Y axis so I think it’s quite normal at these speed, I’m waiting for new rollers (original rollers have flat spots so I can’t tighten them too much) so I can setup the machine to maximum possible rigidity.
As I already said, the pattern is so precise that it’s not possible that it’s a mechanical or a power supply problem. Looks like some sort of resonance or clock disturb on TTL output.

1 Like

You may try to go higher, I really have no idea what max frequency for PWM is. I know 10KHz sticks but I did not measure if it actually is. So try. ESP32 is very fast micro, I will not be surprised if frequency roof is very high.
Other aspect of the same problem: This caused by specifics of integrating circuit of the laser. Most will filter that frequency out. The good thing - your laser is faster, the bad - PWM is leaking through laser.
Try different laser head. Most users will do it anyway at some point.
Try different power supply. My reasoning - 10% row, thin lines are visible but fill is not. Perimeter done in pulses, fills usually more continuous, power may have time to sag and cause these skips. I would try better power supply.

1 Like

Since the patterning happens only at higher speeds, and your text looks extremely rough, I’d bet this is machine wobble. The filled swatches are small, so as the machine scans back and forth across them, and takes steps to move, it’s likely vibrating the laser head, and that vibration is making those lines shake. If you set a higher interval value, like 1 or 2 mm, you’ll be able to see the line wobbles much more easily.

1 Like

Changing max frequency seems to not solve the issue, high frequency result in less power at the Laser output.

Lowering the speed it gets better but as you can see at speed 3200 there are less lines than at speed 1867 for example, I’m thinking that speed is not the major problem.

Looking at the above samples at speed of 6000 but with a power of 20%, the result is quite clear, the defect arises at 30>% power.
I tried another power supply with 10A of capacity but the issue persists.
I was looking for a Firmware upgrade but I didn’t found something for this board.


Back to regular broadcast: that last test card: Moire looks pretty identical for any frequency. But worth to note that it is not the fact that 10K and 20K are valid values and controller actually producing it. Have you checked with the scope? I know 1,2, 4 and 8K are valid frequencies. It is possible that last test card is not valid because controller not necessary able to produce these frequencies. I would suggest to repeat at binary frequency sequence above. I also refer to previous test at 8k that has noticeable difference. Need good explanation for that.

Otherwise I would agree with OZ (who wouldn’t !?!?) that is it a wobble. Get new rollers and tighten everything. And run slower, less acceleration. (GRBL still don’t have jerk control, I think, though available computation probably allows it now. Maybe next version?)

I have another observation. In previous test low power lead in-lead out was cropped. Now it is smooth. No longer choppy fill. What is the difference? Something else has changed.

Maybe are not valid but there’s a result difference so I think the controller is using the new values.
Sorry no I don’t have a scope to check the frequency.
In this test I used cardboard instead of painted glass. Paint on glass is thin and react at minimal variations of power.
I have some more tests that can prove that is not just a speed problem:

In this is quite clear that the Laser is pulsating, near the border is traveling slower so the pulsations are closer and when it speeds up they become more distant. This explains why at lower speed the pattern is gone because the pulses are so close together that are overlapping.

Missing lines in the same part of the logo in opposite sides

I’m agreed with your conclusion. That pattern over apple looks like laser power is unstable and in sync with burning.
Can you tell more details?

  • It this brand new setup?

  • Was it ever working right?

  • Did this Moire onset instantly or gradually?

So what can make it unstable?

  • Laser head itself. Caps may go bad, making it unstable. The very next thing I would try is to swap that laser head.

  • Cable. If gauge is too thin and signal is low - ground lift at laser end can do this trick. (if brand new build.)

  • Try render it with M3 vs M4. this may give some hints.

I hardly can believe that firmware can do that. But who knows! If you go that way: FluidNC is specifically made for ESP32 and installation is super easy. GRBLHAL is another alternative but very involved in compiling and configuring.

The Laser is an Atomstack P9 M50, I made no modifications so it should be supposed to work out of the box.
I’m in contact with Atomstack to diagnose the problem, I will post more if I find a solution.

1 Like

I would just get some cheap module from Amazon, just to test, and as a spare.
At this time my bet is the laser module.

I’m intrigued. Let us know?