Surface Pro 2 and LightBurn/Thunder cam issue

Hello!

I began setup of my Thunder cam today and when hooked to my surface pro 2 it doesn’t seem to work. If I hook the cam to my desktop pc, it shows up fine in LightBurn. Too bad that pc is too far away to use. Are there any issues with the surface pro and LightBurn?

I’m using a LightBurn bridge as well. Looking forward to the cam integration.

I really don’t know that machine, it looks like a regular laptop, assume it’s running windows…

Since it works on your pc you know the hardware is good.

The other machine is probably missing the required drivers. That’s usually the issue.

A number of us are waiting for the camera option in the Lightburn Pi Bridge.

:smiley_cat:

Yeah, it’s odd. Running Win 10. Checked the drivers and they’re up to date and listed as usb 2.0, so everything checks out. It runs the machine perfectly fine from LB bridge, so at I’ve got that currently. I’ll keep digging and see if I can find the issue.

Since it works via wifi, it about has to be drivers or a bad cable… You know it works up to HAL, so it’s more than likely drivers.

I’m not a windows person, so I can’t do much for you from here…

Good luck

:smiley_cat:

Figured out the issue!

Maybe this might help others in the future. If you are using a Windows based laptop with a built in camera, you may have to disable it first in the device manager. Under your ‘hardware and devices’ in control panel, set the new usb camera as the default imaging device. Then, under ‘camera’ in your control panel, give the usb camera rights to access apps. Bit of work to make it function, but happy I got it setup and doing its thing now.

Thanks for spelling it out for others to find.

Take care, have fun…

:smiley_cat: