LightBurn Bridge LightBurn Camera integration?

I know the software is being worked on but are their plans to make it the most perfect solution available by having camera integration?

I setup my LightBurn Bridge up today and it’s brilliant, the setup is fantastically simply and the functionality is perfect. Thank you for the hard work and I know I’m being greedy but as a Mac user it would be perfection with camera integration

Do I need to send beer or coffee???

As far as I know, this still isn’t officially supported, but I’ve cobbled together a workaround if you don’t mind messing around in the command line a bit. You need two pieces, mjpeg-streamer on the Pi and OBS on the Mac. This should work pretty much identically on Windows or Linux. The basic overview is this:

Quick disclaimer, I have this working through lens calibration. I haven’t managed to do the camera alignment, but not due to a camera problem. I am able to use the camera connected to the pi in LightBurn on my Mac. I believe that once I can burn the alignment image I’ll be able to use the camera fully, but I haven’t actually done so yet. Also, there is some lag with the camera view, but that may be due to the poor wifi connectivity in my garage.

MJPEG-Streamer
First piece is to install mjpeg-streamer on the Pi you’re using for LightBurn Bridge. If you open up the Mac terminal app, you should be able to connect by running the command:

ssh pi@lightburnbridge.local

Not every network will support connecting to the device as lightburnbridge.local. If yours doesn’t you’ll need to connect to your router’s admin interface and find the IP address of the Pi (which should be called lightburnbridge). Once you have the IP you’ll connect to:

ssh pi@<ip address>

It should ask you if you want to connect to the unknown device, say yes, then it will ask for a password. The default password is raspberry. You won’t be able to see the password as you type, you just have to trust that it’s working. After you enter the password, you should see a black screen that gives some LightBurn Bridge details. At this point hit Ctrl+C to clear out of this interface. In my tests this doesn’t seem to disable lightburn bridge, it just lets you operate on the command line.

Next you’ll need to get git and then download and build mjpeg-streamer:

sudo apt install git cmake libjpeg8-dev nano
git clone https://github.com/jacksonliam/mjpg-streamer.git
cd mjpg-streamer/mjpg-streamer-experimental/
make
sudo make install

I don’t believe I needed to install any dependencies other than the ones in the first apt install line. If you run into any trouble with the commands above try:

sudo apt-get install gcc g++ build-essential

Next add two files to make the streamer run at startup.

sudo nano /usr/local/bin/start-mjpeg-streamer.sh

Copy and paste this content into the file:

#!/bin/bash
cd /home/pi/mjpg-streamer/mjpg-streamer-experimental
mjpg_streamer -o "output_http.so -w ./www" -i "input_uvc.so -r 3840x2160"

Hit Ctrl+x to quit, it should prompt you to save. My camera is a 4K camera, if yours is not you’ll need to change the resolution. For the regular LightBurn Camera you’ll want 2592 x 1944.

Next create the second file:

sudo nano  /etc/systemd/system/streamer.service

And paste in the contents:

[Service]
ExecStart=/usr/local/bin/start-mjpeg-streamer.sh
Restart=on-failure
RestartSec=5s

[Install]
WantedBy=default.target

Again hit Ctrl+x to quit and save when prompted.

Now run the command:

sudo systemctl enable streamer

Now you should be able to direct your browser to http://lightburnbridge.local:8080/ or http://:8080/. Click the “Stream” menu item. In the box where you can see the stream, right click and select “Copy Image Address”.

OBS
Setting up OBS is much easier. Just download and install on your computer to start from here: https://obsproject.com/.

Open up OBS. In the sources box (bottom-left) hit the +. Name your media source whatever you want (“LightBurn Bridge Camera” perhaps) and hit OK. In the input box paste the image address you copied up above. Alternatively you can try: http://lightburnbridge.local:8080/?action=stream. Your camera stream should show up in the preview area. If you right click on the image you can do all sorts of things to the view. I needed to do “Transform → Rotate 180 degrees” since my camera is upside down so that the wires route more easily.

Hit the “Start Virtual Camera” button. Your remote camera should now be available in LightBurn as OBS Virtual Camera.

You might be able to find something lighter-weight than OBS for the “Virtual Webcam” piece, but OBS works well for me. I tested something call IP Cam Driver (ipcamdriver.com) but it capped the stream at 720P. It might support higher resolutions in the full version, but with an open source alternative I didn’t see the need to shell out money to find out. I believe on Windows and Linux there are more options.

Hope this helps!

1 Like

Holy crap that is amazing!! I’ll try that tonight!

Thanks

Eric

Give us an idea of how long this takes and what issues you’ve had. :eyes: great.

What OS?

:smiley_cat:

LightBurn is working to integrate camera usage via the LightBurn Bridge. No official timing, but we are working it. :slight_smile:

9 Likes

Thanks for this write up, Aaron! I’m tyring to get this to work, but having issues. I’m using a USB camera, so I’m not sure if that is part of the problem or not. I see my camera listed under ‘lsusb’ on the pi, but I can’t seem to get an image to show up. I can connect to “http://lightburnbridge.local/?action=stream” but it only loads my LightBurn bridge info with no camera view. I’m using the Thunder Laser Camera, which is a 4K 110 deg camera on my Nova 51.

Really hoping to get the official LightBurn bridge camera support very soon! It will be so nice to have <3

I am also using a USB camera, so that shouldn’t be your problem. It looks like you’re missing the port in the URL you’re hitting to connect to the camera. You need to connect to http://lightburnbridge.local:8080/?action=stream. The :8080 part is important.

@EFletcher were you able to get this to work?

I grabbed Angry IP Scanner, and I see port 8080 is used by another device. I’ll try and assign another port to my Bridge’s IP and see if that clears it up. Thanks!

Hi,
I set this up and I can see the camera stream in OBS, but when I click on the start virtual camera button, I’m not seeing the camera show up in LightBurn. Is there anything else I would need to do?

Thanks

Are you in the “Camera Control” screen with the “OBS Virtual Camera” selected from the dropdown? What’s showing up in the camera preview?

Hi, the OBS Virtual Camera never shows up in LightBurn Camera Control. I do see the stream from my camera in OBS, but when I click on the Start Virtual Camera button, I never see the virtual camera in LightBurn. Any suggestions?
cam_control

I have the same issue. Could not get the OBS ‘virtual camera’ to show up. This is where I gave up.

I could also not get the camera to automatically start on the Bridge - I had to SSH into it and manually start it each time.

Are you running Windows 10 or 11? I’m running 11, wondering if that has anything to do with it. For me, the streamer starts automatically on the bridge pi if the camera is connected to it.

According to this OBS doesn’t support Windows 11 yet: Windows 11 | OBS Forums

Thank you, that is likely the problem. I guess I’ll the camera connected to USB until they support 11 or the LightBurn Bridge supports the camera.

Windows 11 here too

I must not have something loaded that I need. If you don’t mind looking over what I have.

I seem to be missing ‘jpeglib.h’. Here is an annotated cut/paste of the command window…

install.txt

Thanks…

:smiley_cat:

Have you tried installing the dev package for that:
apt-get install libjpeg-dev

Then rerun make.

Don’t think so, will try that now…

Looks good so far… Compiled ok…

Thanks…

:smiley_cat:

Got the camera today. Went through the setup and all went fine up to the ‘direct you browser’ to the bridge. It returns ‘Problem loading page’.

Can’t seem to find the feed from the camera.

Any suggestions?

:smiley_cat: