LightBurn Bridge LightBurn Camera integration?

A few things to try:

  • Based on information you DM’ed me, this isn’t your problem, but anyone else having this issue should try going to lighburnbridge.local to see if you can connect to that domain at all. If you can’t, the OS you’re using doesn’t support zeroconf networking or is using a different TLD than .local for local hostnames. You’ll need to use the IP you figured out earlier.
  • sudo systemctl status streamer - This should tell you if it failed with an error
  • sudo systemctl restart streamer - Will try to restart the streamer again

If neither of those gives you anything you can use, make sure that the service is stopped and then try starting mjpg_streamer manually:

sudo systemctl stop streamer
cd /home/pi/mjpg-streamer/mjpg-streamer-experimental
mjpg_streamer -o " -w ./www" -i " -r 3840x2160"

If you post what you’re seeing here I can try to troubleshoot.

Hi and Happy New Year!
I took me a day to install and get the Raspberry Pi4 up and running with the USB 8MP cam.
The installation guide did not work that good. But this guide lead me the right way:
Secure Webcam streaming with MJPG-Streamer on a Raspberry Pi (
So the Raspberry Pi 4 is attached to the Laser and the camera is automatically streaming.

But I have the same issue, in LightBurn with Virtual OBS Camera - it does only show a black screen.
In Firefox or in OBS, the USB cam streams perfectly.

But I can run Skype and see the OBS Virtual Camera stream without issues.

Installing the IPCamDriverInstaller gives me a livestream.
Atm I did not decide if I should buy the full version of it.
I’m running Windows 11 and there you have to disable Core Isolation Memory feature (driver signing) to get the driver up and running. This is something I personally dislike about it…

So is there a solution for OBS Virtual Camera?

you can use a different port then 8080 - I used the 8085 just start the mjpg_streamer like this:

mjpg_streamer -o “/usr/local/lib/mjpg-streamer/ -p 8085 -w /usr/local/share/mjpg-streamer/www” -i “ -r 3264x2448”

I can connect to lightburn.local

The ‘status’ of the service was of immense help. Thanks…

I think this is the issue, the 203/EXEC error…

● streamer.service
Loaded: loaded (/etc/systemd/system/streamer.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Thu 2022-01-06 21:04:46 GMT; 1s ago
Process: 6267 ExecStart=/usr/local/bin/ (code=exited, status=203/EXEC)
Main PID: 6267 (code=exited, status=203/EXEC)

I ran it from OBS on the Linux box and got a still picture. Same in Lightburn, so some of it is making it to the machine. Probably some setting in OBS that I don’t have set right.

I’ll keep fiddling. Generally it appears to be working. Will keep in touch…

Thanks for the assistance…


I sometimes have to stop and start either the virtual webcam (if Lightburn’s image is out of date) or the camera source (if OBS is out of date) in OBS to make the camera update in Lightburn. Usually OBS will have a regularly updating image for me, but I’ll need to stop and restart the virtual camera from time to time to keep when I need to get a new image in Lightburn.

If I do the steps manually, it appears execute properly. When I try to invoke it via the systemctl it fails with the 203 error. I don’t know what file it can’t seem to find.

I ran as I did yesterday from the command line, with OBM running and not running.

pi@lightburnbridge:/usr/local/bin $ cat *.sh
cd /home/pi/mjpg-streamer/mjpg-streamer-experimental
mjpg_streamer -o “ -w ./www” -i “ -r 3840x2160”

pi@lightburnbridge:/usr/local/bin $ cd /home/pi/mjpg-streamer/mjpg-streamer-experimental
pi@lightburnbridge:~/mjpg-streamer/mjpg-streamer-experimental $ mjpg_streamer -o “ -w ./www” -i “ -r 3840x2160”
MJPG Streamer Version: git rev: 310b29f4a94c46652b20c4b7b6e5cf24e532af39
i: Using V4L2 device.: /dev/video0
i: Desired Resolution: 3840 x 2160
i: Frames Per Second.: -1
i: Format…: JPEG
i: TV-Norm…: DEFAULT
ERROR opening V4L interface: No such file or directory
i: init_VideoIn failed

I assume the V4L is some kind of video interface it cannot find.

I’ll reboot the pi and try again.

Thanks for your time…


Try loading the v4l2 driver:
sudo modprobe bcm2835-v4l2

Not sure what it’s doing.

Couldn’t find any /dev/video0 for the camera or see it via lsusb. Ended up rebooting the pi and did the steps manually.

I did get an image via OBS in Linux and it showed up in Lightburn. The image was inverted, so I selected ‘rotate 180’ and it only shows part of the video stream. I guess I’ll have to work with it.

It’s not installed in the machine, just hanging around until I get it working and mounted. Printed a 3d holder for it.

The module load, went ok but no change, I don’t think…

Will keep you updated. I had to change the resolution also. Got this ‘informational’ message

i: The specified resolution is unavailable, using: width 3264 height 2448 instead

Changed it and fixed the informational.



I just can’t seem to get this to work. Unsure of what the issue is, but I can connecto to http://lightburnbridge.local/ with no issue, but using http://lightburnbridge.local:8080/?action=stream gives ERR_CONNECTION_REFUSED page. I’ve exhausted my networking knowledge with ensuring my firewall is allowing connections to 8080 through TCP and forwarding the port to my interal IP of the Pi.

Is there any sort of posts about where they are with LighBurn updates, like the camera intergration?

When you connect to the lightburnbridge.local address, do you get the status page?

What does it show? Screenshot would be nice.

It looks like, and I’m not PiSpert that it doesn’t have some kind of access or that you don’t have access to that port. I’ve also seen that when I’ve tried to log into one of the machines with a botched configuration and I can’t connect over the network.

Did this work?

If so, did the build/install of mjpg-streamer complete ok?

We know they are actively working on it…


Ok! Here’s what I see. I can control the laser with zero problems from my upstairs PC and the PC in my shop. Digging through other forums, I tried running some other sudo commands to see if they’d help, but nothing has worked. I’d would love for this to be a simple user error, hah.

Did the mjpg-streamer build/install?

Is the ‘streamer’ running?


Seems to be running? I restarted it, then tested it as well. Although the red text gives me pause :slight_smile:

It’s not executing. Try doing the steps in the .sh manually. I had the same issue and didn’t chase it down.

From a terminal that I ssh’d to the Pi, I enter these by hand…

cd /home/pi/mjpg-streamer/mjpg-streamer-experimental
mjpg_streamer -o " -w ./www" -i " -r 3840x2160" &

It doesn’t restart on its own. I get the same error, I’m sure it’s some form of protection level on the Pi.


You sir, are a gentlemen, and a scholar! It works! Hah. Thank you! Ok, so every time I need to run that to kick on the stream?

I just realized why neither of your services are working properly. I missed a step in my initial instructions. You need to run:

sudo chmod a+x /usr/local/bin/

The script doesn’t have execution permissions otherwise.

1 Like

LightBurn sees the OBS Virtual cam, but doesn’t display anything. Works great in OBS and now when I load the stream via the web. The last piece of the puzzle! Soooo close. Hah.

What version of Windows are you using?

Win10 Pro (64bit)

Also what are you guys running for frame rate on your camera from the pi? Mines currently 4K x 30fps and I think it’s a bit too much for the little guy to handle. Getting soft temp warnings and some hard boots from the pi. It’s only air cooled no fan or heat sink, but I could easily add one if need be. The pi on my mk3s runs at 30 just fine. It’s an actual pi cam camera though so resolution is likely lower.