The burning power is not uniform when engraving

Continuing the discussion from Engrave quality and uniform results:

A picture is worth a thousand words.

The engraving is made on double-layer ABS. The same thing happens on anodized aluminum. On the line where there is more left-right graphics, there is more laser power. I used speed 300mm/s and power 45%. I am attaching a photo.

So, unfortunately, my assumption does not fit. Until the real cause of this “phenomenon” is found, I will use a 45 degree crosshatch to get a more homogeneous look.

Are you saying that it is a “phenomenon” that occurs in many Laser users?

I’m thinking of using the ‘Flood Fill’ function. I noticed that the engraving is done in a different order.
Shot 0021

No, that’s not what I mean. But to get on with the project or find alternatives to solve the problem.

To find out why one’s engraving is not homogeneous or the same every time, some tests are required.
Is it the machine or the material that causes problems.
I had a problem a few years back with a diode laser that “behaved” as you describe your problem. The fault turned out to be a too weak or sensitive power supply, which reacted with power output drops every time the refrigeration machine or a large compressor in the workshop started. The problem was that this current fluctuation could not be seen without being measured.
I think it is important to find out if the error is reproducible and if it occurs at the same position, for example.

Sometimes, if there is not enough time for systematic troubleshooting, I try to see if I can achieve better results with process changes, such as change of speed, power or engraving direction. Especially for wooden materials, which by nature are not consistent in structure, the settings vary quite a bit. But that shouldn’t be the case with the materials you mention.

I’m thinking about all the options you mentioned.

  1. Starting the compressor (it has only 750 W) which is on the same socket (it is excluded because the ‘phenomenon’ is directly related to the graphic filling of each line).
  2. Should the power source be? Probably if I use maximum power, the source is at its limit and problems may arise. In this case I used only 35%. However, I will monitor the current on the manual adjustment clock during the engraving process.
    I engraved another anodized aluminum plate and also the engraving was not homogeneous. And with anodized aluminum it is really a big problem, the power must be very well calibrated.
    I mention that every time I did tests, but because they were on smaller drawings, they did not fit very well when engraving on a large drawing followed.
    This problem does not appear on wood, or better said, it is not noticeable because the wood is not homogeneous.
    Any suggestions are welcome.
    Thank you for your time and effort

I get this on wood all the time. It’s still quite noticeable. Would definitely like to have a fix though.

1 Like

Hello, are you saying that your wood engraving has the same problem? For me, it is only noticeable on materials with a uniform texture, such as ABS, aluminum, etc… but it is more visible when the engraved surface is larger, over 15x15 cm. At the first opportunity I will try the Flood Fill function. In addition, this function is efficient because it reduces the engraving time in most situations.

Yes. 100w black/red Ruida controller.

Having the same problem with wood. Happens with Lightburn but not with Laserbox. Everyone said it had to be the image, but it happens with pretty much any photo. Again, it happens with Lightburn but it works perfectly in Laserbox.

Xtool D1 5w

I understand, it’s worth trying. Thank you for all the ideas, solutions. At the first opportunity I will try, but on ABS material or anodized aluminum. On these materials I have problems.

1 Like

Please let us know if you find a solution. I’m frustrated and everyone is saying it couldn’t be Lightburn related, but in reality, it pretty much could only be a Lightburn issue.

Sure you do. I am amazed and at the same time shocked that this problem occurs to many users.

Be aware that although this might appear to be an apples-to-apples comparison it is not. The D1 houses 2 entirely separate firmware: one proprietary and used by Laserbox, the other GRBL based which is used by all other software.

Although something working in Laserbox could rule out any major mechanical issue it doesn’t rule out issues with regard to firmware. Take a look at these forums and you’ll see a large number of xTool firmware bug issues.

I’m not saying that’s necessarily the case here as I’m not close enough to it but trying to point out the possibility.

Perhaps trying running the job in LaserGRBL. That’s a closer comparison to LightBurn as you’ll be using the GRBL side of the D1 although still not exactly the same due to differences in how the programs are implemented.

I do understand this, but this is an issue on non-Xtool machines as well. At least two people are using lasers with Ruida controllers and are having these issues.

The number of reasons why something doesn’t engrave properly is so vast that it would be incorrect to generalize it as LightBurn having photo engraving issues with Ruida and xTool controllers. Let’s remember that there are far more cases where both Ruida users and xTool users are engraving without incident.

So that leaves specific Ruida issues, specific xTool issues, and potentially issues from LightBurn.

If the output from the laser does not match Preview that’s generally going to be a machine speicfic issue. If the Preview is being generated in a way that’s causing the artifacts then that’s either an issue with LightBurn or something in the bitmap that’s interacting with the image mode that’s making the artifact appear.

My guess is that Laserbox has far fewer and more simplistic raster image mode options than LightBurn.

I am running into a similar issue now, areas wehre the laser is only on for a short moment is not getting full power.

Have you or others tried RDWorks? I had another older problem with another laser machine, here is the discussion: Wrong cutting position.
With RDWorks it works perfectly, but I admit that I discovered a higher value in the machine’s settings. If I remember correctly, it was the starting speed. After I lowered this value, it worked well with Lightburn as well. I like the Lighburn interface a lot and I fell in love with this software, I would not want to change it and I hope I won’t have to do that.

Yes, with RDWorks it runs evenly.