The saga of a failed Ruida based laser

I bought a fancy new 100W laser off Aliexpress about a year ago to compliment my aging 60x90 100W K40 style laser (still running the old M2 board on Whisperer, another story for another day). Upon finally getting the new Ruida (6442S board) based machine fully installed in my shop back in August just in time for my usual avalanche of fall orders, I bought lightburn and had the machine running great after just a couple hours of feeling out the software. All was great until a week ago. Mid-cut, the laser stopped, HMI screen went blank, all the lights on the Ruida went dark (except for LED 14 or 15, cant remember which). Obviously that was a rather dark day since I’d grown dependent on this machine and was epically failing at integrating a VMS board into my old laser (remember I said another story for another day). After verifying that 24V was still being delivered to the Ruida board, I went on a Facebook group asking for help, got no replies, and so decided to order a new board. Board arrived on Friday, fastest shipping I could find. Installed it, and the new HMI that came with it. Fired up the machine, and NOTHING. I asked facebook again, and got a couple responses that have yet to reveal the source of the problem other than one individual mentioning receiving THREE dead Ruida boards in the past two years. Is this really the state of things?

I did do some testing with a multimeter in hopes of determining whether something else in the laser killed the board or if it just died like this after only a few months of operation (there do appear to be scorch marks in a couple of places on the old board, especially at the power transistor). Here’s what I’ve found so far:
Without the any of the wires except the 24V plugged into the board, I get 4.6V between the wires that would plug into port 1 and 2 of CN5 and 1.2V across 1 and 5 of the same block. With the wires all plugged in, I get 4.6V between 1 and 2 of CN5, 0.8V between 1 and 5 of CN5, and 4.6V across 2 of CN5 to 3 of Axis U as well as all of the wires going into Axis X and Y, and ground on CN4 (the latter not surprising).

I’m currently in correspondence with the vendor of the replacement board (Cloudray’s ebay dealer, chosen purely because they had the fastest shipping). They are proving most unhelpful, insisting I try installing a new power supply which I don’t have. Looks like I may have to file a claim on them if it turns out the board is truly dead from the factory.

Can someone shed some light on what’s going on? I cant afford for this machine to be down any longer. Should I just part it out and buy a new one? Should I dump these worthless Ruida controllers and go to a different controller? Please help!

Most people are clueless about what CN5-Pin5 is used for… as was I, I had to go look…

It’s much better to use the Ruida names…

Pins 1 (GND) and 2 is (L-On1) … GND and L-On1 is much more descriptive and understandable.

Pin5 is L-AN1, which is the analog output.

None of these measurements are useful as most are dependent on the machines state, running or not…

These measurements, such as from L-On1 to 5V indicates your understanding of these signals is an issue …

L-On1 is relative to ground, not 5V

Identify what leds are illuminated on the Ruida. You should have, at least, the 5V (15) and ‘run’ will flash, if connected (hardware wise) via Ethernet the ‘link’ will illuminate.

‘err’ (13) should not be illuminated…

Check that the 24V input power to the controller doesn’t fluctuate …

I know you know what you mean, but I don’t … no lights, no power, no console no homing, no dinner … ?

If you’re going to deal with Chines companies you can’t beat cloudray for the best of these… One of the few that ‘make things’ right. However, they are from China and there is a time/language barrier…

Same with the Ruida … It’s one of the most popular, not because it’s easily broken or fails after a short time…

I know you are under pressure for a fix, but it does sound like something hardware wise failed… If you want help to chase it down, I’ll do my best…


No LEDs are illuminated on the board. The stepper drivers have their LEDs illuminated. I’m running a USB cord and never set up the ethernet from my PC, so no way to test that, however I can say that Lightburn is not even detecting that the USB is connected to anything anymore.

When I fire up the machine (as in release the e-stop), the accessories (bed illuminator, stepper drivers, and the AC accessories served by the rear outlets) come online, but that’s it. I assume the tube’s power supply is working, but since pulse testing is controlled by the HMI, I have no way to verify that. The power supply to the board of course also comes online, and so on, but the board and HMI are completely dead in the water. The laser illuminator is controlled by the board, and it is not coming online. Further incidator of the deadness of the board is that there is no homing or anything of that nature. Anything automated, not happening.

I’m not sure what you mean by fluctuating, but when I put a voltmeter to the 24V input to the board, I get a steady 24.1V readout.

Any ideas what hardware failure would precipitate a total failure of the board like this, or if that’s even possible?

see if your safety kill switch is not the problem, if mine hangs the ruida stays (partly) dead

If you pull the green plug (with all the wires from the controller) out of the HV power supply, pressing the Test button should fire the laser. If it doesn’t, then the supply is demonstrably dead.

That doesn’t seem to be (any of) what’s ailing your system, but it might save you from a preemptive expense.

100% Ruida forum. Those guys know the boards inside and out.

That would indicate there isn’t power to the Ruida, if that’s the ‘board’ you’re referring.

Have you measured the 24V into the Ruida?

If there is no 5V led on the Ruida, it’s got a power supply issue… either externally or internally. Since this is the 2nd Ruida, it would probably not the Ruida as the symptoms are the same from the previous controller.

Checked the 24V connector at the Ruida for voltage and ensure it’s well seated…

Have you removed all the connectors from the Ruida, except power to see if it will power up on it’s own…?


jkwilborn, yeah, it’s definitely getting 24.1V steady, no measurable ripple (tested the AC range on my multimeter). I tried changing out the plug, no change.

I’ve tried it with and without the accessories plugged in. No change.
Here’s the video I sent to the dealer: Ruida board failure - YouTube

IMHO… the Ruida does look dead… Assuming the power connector and it’s pins look OK, I’d return it to the vendor…

With it’s console plugged in and the screen attached it should operate, at least via the console…

Looks like you have one of them apart… did you see any issues there?

Don’t ‘pitch’ any of them… I’d probably pay shipping, assuming reasonable to get one I could ‘mess’ with… even dead…


ednisley, I honestly didn’t know that button was hiding down there. Now I feel a bit stupid. But, I used the button, and the laser makes fire. So at the very least I have a working laser system. Just would be nice to go back to being able to make the beam move around places. :frowning:

Yeah still fighting with the dealer via ebay messages to get them to honor the darned thing. They keep demanding more verification that the plug is working. I’m becoming concerned that I really will have to file a claim against them.

Do that right now, because their game plan is to stall you long enough to run out the clock.

Source: made that mistake.

Got the return initiated, package in the mail within a couple hours, and then the next day the vendor had the gall to message me to wait to send it so they could send me a shipping label to their international warehouse. Cloudray is NOT impressing me so far.

I ordered a Trocen board the day prior. I don’t expect it to give my anything even equal to the capabilities of the Ruida, but having an operable laser is the main thing at this point. If any of you have wisdom on what failure modes in the electrical system could cause a controller board failure, I’d really appreciate it. Would like to avoid the possibility that some other failure is what killed my Ruida.

I tried registering on the rdworkslab forum…apparently they don’t want new members. A crap ton of nosy questions about my computer and OS and physical location, then after all that I get a notification that an admin has to approve me application. That was 3 days ago. The forum isn’t even recognizing my password, so I can’t check the status, and I never did get an email event telling me that I’d initiated a registration. Is this normal?

The only thing the manufacture recommends is snub diodes on any solenoids (coil) operated by the Ruida …

I’m not sure where the failure would be except in power regulation, it’s going in, but the Ruida isn’t waking up …

I understand if you wish a different controller … the Trocen controllers are supported, but not the same way Ruida is supported. If you are wired up to Ethernet, I don’t think Lightburn can talk to it over Ethernet… they are looking at it, I understand.

Good luck, keep us updated…


Well things have gotten a bit interesting. While I’m awaiting the arrival of my Trocen controller, I had some down time and decided to play with the original Ruida which caused the start of this whole mess. So step 1, plug it into the 24V supply, see what happens. A decent number of lights lit up. Ok, that’s interesting, so let’s try powering it up with the HMI plugged in. Well the HMI came up and showed the usual menus. This, I find odd. I mean, this thing was DEAD. Now it’s not. Makes no sense.

I got the controller back in place, plugged the various wires back in, etc, and the machine now powers up. I get a “system resetting” message followed by the option to hit esc to exit. Now at first, it would return the laser head to the origin as soon as the controller fired up. Now not so much. The x axis seems to have stopped working as of this evening. That doesn’t capture the full issue. If I leave the system to reset itself, the y axis goes nuts slamming against the y stop (yes, I checked the switch, however, we aready know both x and y switches are working since the thing (was) homing correctly at startup. If I hit esc, I can connect with lightburn instead of the thing trying to kill itself. If I send it a cut path, it just gives the 3 beeps you get at the end of a run, no movement. Attempting to jog it gives a different result. Jogging in x gives no response. Jogging in Y, both positive and negative, causes the head to slam into the Y stop (so it’s like it’s reversed either way, and not responding to the limit switch). Lastly, status lights 3 and 15 on the controller are on, and light 14 is blinking. There are two red status lights active on the board itself (one on the smaller USB/Ethernet board, and one on the main board).

I’d love to ask this all over on the rdworks forum if they’d let me on, so hopefully someone here can decypher this insanity. Is this just a zombie board in its death throes, or might there be more to it? I’d think a wire was broken somewhere if it weren’t for the fact that everything outside the board seems to be functioning correctly. I assume the board has put itself back to factory settings or something, but that still doesn’t explain the now dead x axis that was at least homing a couple hours ago.

Given what it’s been through, the controller may now have a corrupted configuration in Flash memory, so doing a complete “factory reset” (through the HMI panel) won’t move you further away from the goalposts. It should restore the settings to something consistent, although not to values that will properly control your hardware.

After the reset, connect to it with LightBurn and save the Machine Settings as a backup.

Then go down through the entire list of Machine Settings to verity they are at least sane and won’t cause unexpected actions.

For example:

  • Rotary diabled
  • Water protect & lid sensor disabled
  • Signal polarities false = negative
  • Axis travel (size) matches hardware
  • Axis step length matches hardware
  • Speeds 100 mm/s
  • Accelerations 1000 mm/s²
  • Homing disabled for all axes

Then start with the simplest things and get each one working.

For example, starting with the lid sensor:

  • Use HMI to verify sensor input changes with lid open / closed
  • Enable the sensor
  • Make sure the polarity matches: open = on, closed = off

Then work on one axis at a time. Get it jogging in the right direction with the Direction polarity, the right distance with the calculated Step Length, and a reasonable speed. Enable Homing, get the direction right, set a sensible speed.

Then tune the speeds & accelerations to match your hardware.

Basically, assume nothing will work with the default configuration and proceed in very small steps as you bring up each piece in sequence.

It’ll definitely be an education … :grin:

Before the reset … after a factory reset all ‘vendor’ information is lost which is what you need…

It’s also possible that Lightburn saved your preferences, so check that … I’d make a copy of it somewhere …



From the descriptions thus far, however, the poor thing seems totally scrambled and there’s nothing to back up.

On the other paw, ya never know: back up early, back up often!

A Ruida is just another computer… who knows what it’s got in there…

Easier to have it and not need it than need it and not have it…


Saved backups as recommended. Factory reset (at least I think I did…I entered a password and it said success). Set accelerations to 1000mm/s2, speeds to 100, polarities to false, water protecton to disabled (no lid sensor), rotary disabled, homing disabled. Wrote that to the controller. On startup, controller no longer goes into reset mode, fine. In diagnose menu on HMI, I can get the x and y limits to light up. Water protection not so much. Attempts to jog in x via HMI and via Lightburn get no response. Attempts to jog in Y, both positive and negative inputs, all result in motion in the same direction, toward the origin. When the head hits the Y origin, job inputs result in it ramming against the stop instead of responding to the limit switch.

I get assuming nothing will work…but yeah, nothing works, and it’s not working in a really bad way that makes no sense.

Ordered a new power supply last night on the off chance that this board might be done for and that the power supply might have done something to it. Better to be safe than sorry since the Trocen board set me back $200 and I’d like to not cook it when it arrives.

I’ve given extremely serious consideration to just dumping this entire piece of trash for salvage to the first person who will come pick it up and hand me $1k for the tube and power supply. According to ebay I can have a new machine here by the end of January for $3300. On the other hand I’ve heard of several arriving with DOA controllers (sound familiar?)