TopWisdom questions

I’ve got a question about this “Start From” feature. (FYI, using a TopWisdom controller)

Does it use LightBurn’s internal memory of what the “User Origin” or “Current Position” are, or does it ever use the machine’s own origin?

So far, I’ve only gotten it to start from absolute zero no matter what I set it to, and it ignores the machines current position and origin.
The default behaviour of the AutoLaser is to start from the machine’s origin, and I’d like to keep doing it that way, at least for the time-being as I learn to use LightBurn.

Thank you!

p.s. I’ve noticed in the TopWisdom controller’s display, the “preview” of whatever I send to it always has this long vertical line stretching from the absolute origin to (presumably) the bottom right corner. Is that supposed to be there? Can it be disabled?

It should use the machine’s origin point, if you’ve set the ‘Start From’ setting to ‘User Origin’. You would need to jog to the origin you want and press the Origin button on the controller. If you have the ‘Start From’ setting set to Absolute Coords, it will always be positioned exactly on the bed as it appears in the workspace. (Keep in mind, you likely have more experience with the controller than I do at this point)

It’s not supposed to be there, and I’ve never seen this, though I have only the TL403cb to test with so far. Which model is yours?

That’s not what I’m seeing happen. I use the Origin button on the controller before any cut job.
Since the default behaviour of Autolaser is to start the job relative to that defined Origin position, it’s essential to ensure that the machine is jogged to the correct starting point every time and the Origin is set (via pressing that button) at that location before hitting Start.

With Lightburn none of the 3 settings respect the machine’s Origin.

  • Absolute does what Absolute should do.
  • User Origin behaves the same as Absolute
  • Current Position moves the laser head to 0,0 and starts cutting from there, regardless of where it just was or what the machine’s Origin is set to.

I’m not sure. Is that shown in the settings, or written on the controller itself somewhere?
I can check the next time I’m there.

i can confirm the odd line and the “start from” problem Hank is talking about. im running the TL-410C controller. i have a video made if you want to see it…

Hi all,
I’ve just bought an 80w laser which has come with a topwisdom controller.
First time I have used Lightburn and very impressed after using inkscape with my K40.

I am having a bit of success with the free download which is great. having a few issues where everything I produce needs to be mirrored at the final stage before being sent to the machine. Also no matter where I set the origin it always starts from the home position rather than current position or user setting.

Other than this its all work in progress for me and still happy to use the software.

Will the program work better if I buy the license.

Many Thanks

Matthew (UK)

Same here with the line, model Topwisdom TL-403cb

I’m not sure if I’m missing something here, but I can’t get this origin going properly.

  1. Machine 0 is set at bottom left
  2. Controller origin point is set to about x =2, y=2 basically bottom left,
  3. I tried all 2 selections on , current position, User origin and absolute coordinates with the same result.
  4. After I send the file to the laser it always start and runs the file at the top right of the bed.
    Anyone have a clue of what I’m doing wrong or is this a problem with the Topwisdom/Lightburn.

Autolaser always start at the origin point when I set it from the control panel. My controller is a Topwisdom TL-403cb.

It’s still a work in progress, so there will quite likely be bugs. I’ll be investigating the origin issues over the next little while.

2 Likes

Thanks, I wasn’t sure if it was me messing something up, let me know if I can be of any help testing anything out.

Same issues with the origin and the vertical line in the controller screen. Cant get it to take a manual origin to start a job. Topwisdom TL-410C here.

The vertical line seems to be specific to the 410 - I don’t have it on the 403c. I might have to get a 410 as well.

1 Like

OK, i have tested a few things,
i can get a perfect preview on the controller screen when i change the settings machine zero point from right to the left side. i tested to change from right top (original homing spot) to the other corners and they all come diffrent on the preview screen.
My guess is that the vert line that appears is that lightburn doesnt get the right position from the file thats sended. I think it also has to do with the fact that the user origin not coming tru when setting origin on the control panel of the TL 410

I finally got around to checking with TopWisdom model I have, and I’m not really sure.
Does this reveal anything? Or maybe it’s written somewhere physically on the hardware?

it should be on the controller itself.

Ok, got it for realz this time. It’s the TL-403CB.

Does that help at all? Anything I can do to help debug the vertical line and origin issues?
I’m also a software developer and can offer my skills to help debug the issue, although I understand if that’s not something that interests the LightBurn dev team.

So you have the vertical line issue on yours as well? I thought it was isolated to the 410, but if it’s not, that’s actually a positive thing. I’ll be getting my hardware set back up again shortly and digging into this again.

we have the 410c and can confirm the vertical line, also we use absolute co-ords to start from machine origin (top right corner)

Yep, the line’s definitely there on the TL-403CB.
Will gladly help out to get this fixed in any way I can. This is the biggest issue that I’m facing with LightBurn, but I just bought a license a few days ago anyway because I’m really happy with how well the rest of this software works. Feels so nice and smooth to use :smiley:

Also, I don’t know if it’s a bug or not, but whenever using Absolute mode (and currently all modes behave like Absolute mode), it always goes back to 0,0 first before moving to do the job. Does it have to do that? Would be great if it would just take the short path and move there from its current location.