Total noob, Neje Master 2S

Hello All,

I am a total noob here, so please bear with me.

I run Linux Ubuntu 20.04 LTS, installed LB, connected the Neje Master 2S to USB port, imported driver so that LB shows Devices ttyUSB0 Neje Master 2S GRBL, but Console shows Waiting for connection…
I think it must be a problem of baud rate. Correct?

I only have Linux boxes here, however, maybe I could install the Android app to update the Neje firmware, but in Play Store I did not find any “Neje” app, although there are several laser engraving apps.

Thanks for your advice,
best regards,

1 Like

Hi Gian,
I also have this exact same problem, and i’m a Windows 10 home user. NEJE offers a grbl uploader for windows versions, but i’m not sure if this also works with ubuntu. Regardless, I’ve found that even for windows, the grbl uploader that they offer doesn’t work as it gives a baud rate error in every configuration that is available. I’ve also went back and forth with NEJE product support to no avail.

I believe i’m just reconfirming your assumptions here with a different platform. Hoping someone else can provide some good advice for the best method to flash the laser.

IIRC (which I may not - ossified grey matter) try setting your baud rate to 38400.

Thank All of you,

I will try later to set the baud speed.

What is the Neje Android app called, and how is it supposed to connect to the plotter?

Also what is the RED little button for on the Master 2S?
I pressed it and almost set my desk on fire!


Gian, the NEJE wiki page has almost all of the info you’ll need to get set up, including all the apps and programs you’ll need. The program that Bo is referencing is called NEJE GRBL uploader v3.1, and can be found in the NEJE wiki page

The android app is connected via bluetooth, the same as the ios app.

The laser you’re using (same as mine except i only have the 2, not 2s) is capable of storing laser burns on it’s circuit board, and “burning” offline (not connected to a computer). when you press the red button, it thinks you’re ready to burn an image… lol i recommend getting a 2’x2’ piece of 1/2" thick plywood to stick under your laser for instances like that. my first burn was at 100% power and burned right into my vinyl flooring… the wife wasn’t too happy.

1 Like

Hi Bo, thanks for the feedback. i’ve tried to flash my laser with this program using all combinations of baud rate and grbl files… as well as Benbox and the LaserGRBL_3.1.2.exe program… with no luck.

Would you recommend resetting the laser somehow? Not sure if there is a way to flash it back to factory settings and then try the process you’re recommending?

a little background… i was successful at using lightburn without issue during the trial period, but right after that, it stopped working (i purchased the basic $40 license).

Hi. I’m stuck too at cconnecting my Neje Master 2S max with lightburn on windows 10. I followed rigorously the insctructions provided by Neje wki : nejelaser_master_2_max | NEJE Wiki
Still doesn’t work, just bought my lightburn license…

Hope we will find an issue.

What doesn’t work? Sorry to hear, but this only tell us that it does not work. What have you tried and what result are you getting? Does it power on? Can you get the software that came with this unit working? We need further information to offer help.

If I told you I have a car and it doesn’t work, and nothing more, it could be many things that could cause this. It could be the windows aren’t rolling up or down, a dead battery, no petrol, or the car is at the bottom of a lake. Each with its own issues for resolution. The details are important when asking for help. :slight_smile:

Hi Rick. Thank you for your feedback .
LB found my laser at startup, i can set the dimension, the auto-home origine but in the console it’s stuck a “waiting for connection”. The laser worked with Neje software but i can’t connect the laser to lightburn.
Install the driver USB-SERIAL CH340 : done
switch the firmware to grbl1.1f with neje uploader software : done (what baud rate to use is not mentionned)
start LB and setup the laser : done
communicate with the laser : stuck

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.