Traversal Lines are being burnt for text created in Lightburn

The traversal lines are being burned when printing outlined, stylized text in LightBurn. I have tried the GRBL, GRBL-LPC and GRBL-M3 profiles. GRBL is the only profile that is currently working for me. Any text converted to another format works fine but would rather outline the text than burn a picture. I’ve tried all of the setting and read any of the relevant topics but can’t seem to find any similar issue.

You haven’t told us what firmware you are actually running on your controller so…

The movement lines don’t turn off because you may not have laser mode enabled, or possibly because your spindle max setting doesn’t match the setting in LightBurn.

So what firmware are you running? (you can add that to your profile so when someone clicks your name, they can see your setup details in the future)

I am having a similar issue. I attached a couple of photos. The first one shows the traverse lines very bad. I then switched to scan the circle 1st (and added cross hatching to it’s scan). But even on the second photo, you can see some burned traversal lines. Any thoughts? I am using a Shapeoko XXL with Carbide Motion 4 (GRBL 1.1) and the driver from JTech for their 7W laser attachment.

I think I just found my answer. The J Tech website states “You can’t use carbide motion, as it creates a delay with the spindle command, which will give you dots where the laser turns on and off.” So I guess I will learn to use another “sender”. Probably UGC.

Why use a sender at all? LightBurn will send GCode to that machine.

Thanks LightBurn. I was wondering about that. I never leave LightBurn to “burn”. So I was wondering if it indirectly used CM or CM settings. So I guess my original question remains. What can be causing the burning of traversal lines?

A number of things:

  • Using the “GRBL” device in LightBurn with GRBL firmware older than 1.1f (you need to use GRBL-M3 for these)
  • If using GRBL 1.1f or later, not having Laser Mode enabled ($32=1)
  • Not having the S-Value Max setting correct. It defaults to 1000, which is the default for new versions of GRBL, but older uses 255, and some other software sets it differently. (The S-Value Max setting in Device Settings in LightBurn must match the max spindle value your GRBL expects)

See the “Short Version” paragraph here: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md

Don, (from above ^^^)

Thanks Rick. Firmware for which device? For the laser driver board? How do I check that?

1 Like

Don, this is starting to feel like a circle. What did you use to determine that you have grbl 1.1? “Grbl 1.1” is not complete and is usually followed with a letter and is important in determining the correct setup…

Let’s try this, when you start both your hardware and then LightBurn, look to the ‘Console’ window in LightBurn for the information presented there. That should report back the completeThen, look to the info Oz presented just above for the best way to setup LightBurn for your hardware.

The console states Grbl 1.1f. I did not realize that indicated the firmware. I thought it was the version of gCode that was being processed. I know they are related, but this is (obviously) not my field of expertise. That is why your circles are my ovals. Just trying to learn something new that will allow me to perform optimally with my device. If there is a good reading reference, please direct me and I will study better before I poke my head in here. Thanks for all your help and comments.

You will want to use GRBL in the ‘Devices’ window to correctly connect.
image

The movement lines don’t turn off because you don’t have laser mode enabled, or possibly because your spindle max setting ($30) doesn’t match the setting in LightBurn 1000 is the default in LightBurn and in GRBL, but some software changes it. You can see your GRBL settings by typing $$ in the console and pressing enter. This is what they all mean:

And please, no worries. I did not mean to come across harshly. We all had our start at one point. Please keep coming and asking your questions.

1 Like

I sent $32=1 and set spindle max to 1000 in LB software settings. That resolved the problem of traversal lines being burned. THANKS!!!
The interesting thing (to me anyway) is that it has been working fairly well prior to changing these settings. Just the light traversal burn lines???
IMPORTANT QUESTION FOR ME -> Do I need to send any settings to go back to routing with my CNC spindle? Or will Carbide Motion send these prior to each run? Like $32=0. Thanks for your input and patience with a learner!!!

Here is a good read that can help with switching between the 2 setups using macros available within LightBurn.

https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md#shapeoko

Yes, you would need to set $32 back to 0 - the $32 setting is “Laser Mode” and controls how the spindle speed output is managed. The spindle speed output is “instant on” in laser mode, and G0 moves turn it off. In CNC mode you don’t want that behavior.

Great advice. Can I include these settings in the macros (like “G10 L2 P1 X-812 Y-812”), or do they need to be “direct sends”?

You can do that in the macro. The following is from another document generated by one of our partners and is for a different, yet similar setup to yours. I share as it walks through the process for setting up 2 macros for exactly what you are trying to do. (saves me from typing it all over again :wink: )

Enter in “Use Laser” in the Label and “G10 L2 P1 X-812 Y-812” in the contents box. Press OK after.

Note: If you have a different work table size that you entered in the device settings, this number needs to be the same here.

Right Click Macro2.

|1024x576

Enter in “Use CNC” in the Label and “G10 L2 P1 X0 Y0” in the contents box. Press OK after.

|372x342

13. Click on the “Use Laser” Macro button. Then, Jog the machine to check the machine now moves correctly.

My fault for not being clear. Can the $32=1 or $32=0 be included in these macros as well? Or do those need to be sent in the command line?

Macro lines are sent one at a time, not streamed, so they can be console commands or GCode (they can include the $ commands).

No worries. As Oz said, console commands can be included.