Traversal lines burning in my design

I am getting the pink traversal line also burning in my project how do I get rid of the lines.

You have not said what you are using to drive your laser and the picture you show is covering the console window. I have not heard of the “cowboy21” laser before. :wink: Please update this, we provide this in your forum profile so we don’t have to ask each time you post.


You likely don’t have laser mode enabled in GRBL ($32=1), which would make the spindle PWM output ramp slowly instead of instantly, among other things. The spindle PWM output is used to set the laser power. This might be a helpful read (assuming you are running grbl): Common GRBL/GCode Setups - LightBurn Software Documentation

I enabled GRBL ($32=1 but I am still getting lines )

There is more in the posts I provided than a single setting. How did you make this change? Did it take? How did you confirm this? What version, exactly, of GRBL are you using? You have not shared much for me to go on and have not updated your forum profile, so I am still in the dark as to what you have and what the settings for this mystery system are.

I am using a Sainsmart 3018 with a 5.5w laser. The GRBL is version 1.1f. When I set $30=1000, $32=1 and S-Value max = 1000 the laser doesn’t burn. When I set $32=0, it burns but it also burns the traverse lines.

You’re asking it to go too fast then. $32=1 is ‘Variable Power’ mode which means the laser adjusts the power output from 0 at a dead stop to whatever power you request when it gets to the speed you request.


CNC3018’s are severely speed limited because of the screw-drives - they need to spin the screws a lot to move even a little, so the maximum speed is usually about 1000 to 2000 mm/minute. If you asked the machine to go 6000 mm/minute, for example, and it was restricted in the firmware to 1000, you’d get 1/6th of the power output you asked for because the machine never gets close to the speed you requested.

Thanks for the help; I will give this a try.

I gave it a try and it worked perfectly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.