Trocen won't connect over USB w/ Manjaro Linux


I’ve been beating my head on this for 4 hours and I’m about to give up. The gist is that neither the Find My Laser button or setting it up manually results in a proper connection with my laser.

This is what I see in the debug log:

Attempting port open…
Port open returned failure: -3
Access denied (insufficient permissions)

This is after making sure I was part of the “uucp” group (arch equivalent of the “dialout” group) and generally giving everything every permission I could think of.

Does anyone have a suggestion? If it matters, the controller shows up in “lsusb” but not anywhere in /dev

do you have the DSP version of Lightburn as this forum discussion mentions?

I’m 99% sure that I do, as it doesn’t detect and then say that I need a different license. This laser has also worked over ethernet earlier this year with this license.

any idea what “port” it is trying to connect to?

Also would be a good idea to look at what ‘dmesg’ outputs when you connect and turn on your controller.

It’s a USB port at the end of an active extender. I would test it plugged directly in but neither the laser nor the PC are mobile, and every other device works fine with the extender so I don’t think that’s the problem.

dmesg output:

[ 8828.333738] usb 5- new full-speed USB device number 32 using xhci_hcd
[ 8828.546689] usb 5- New USB device found, idVendor=1fc9, idProduct=0085, bcdDevice= 1.00
[ 8828.546696] usb 5- New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 8828.546699] usb 5- Product: AWC USB DEVICE
[ 8828.546701] usb 5- Manufacturer: TROCEN AUTOMATION
[ 8828.546702] usb 5- SerialNumber: _AWC_15028034

I would not be surprised if the Ruida too does not create a USB serial device but somehow Lightburn probes the USB and tried to connect to the device. Seems something doesn’t have privileges. I suppose trying to run LIghtburn as root might work but it is not recommended.

Maybe a bit odd but if you can boot Lubuntu 18.04 or even 16.04 off of USB( running LiveCD ) you could try installing and running Lightburn from inside the liveCD and see if it works. Otherwise the Lightburn Linux dev team will probably need to drop in.

Sorry I can’t help further.

Running as root actually works for setting up the laser manually but not Find My Laser button. Usable now, but I’d like to get to the bottom of this if anyone has an idea

If you use root and get connected, can you export the device configuration and then run as non-root and load the saved device configuration?

Also, are you sure your userID is also part of the uucp/dialout group? And if we know what device file Lightburn was using we could see what the udev system sets the privs to.

I can’t figure out how to export the device configuration. I’ve exported user preferences, but things like port don’t seem to be in it.

I’m positive my user is in the uucp group.

I’m trying to figure out which device file is being used but the debug log doesn’t seem to work when LightBurn is run as root.

Thank you for helping me along with this by the way

Export of the device settings is found under the Edit menu followed by the Device Settings menu button and then the dialog box will pop up and Export button is located at the bottom center of the dialog window.

Sounds like a protection issue with the USB port. Can you check ensure that the /dev/xxx has the proper protections set? You probably need to be in that ‘group’.

I put /dev/xxx since I don’t remember how the USB port showed up in Linux for the Ruida.

Plugged in the Arudino…

ls -l /dev/ttyACM11

crw-rw----+ 1 root dialout 166, 11 Dec 5 12:15 /dev/ttyACM11

This one is the arduino, but the group is ‘dialout’. You may need to associate it with a group you are in for access without ‘root’.

I dumped the USB port real fast and went to Ethernet.


I’m the helper, not the helpee Jack. The helpee has already stated there is no /dev/xxx created, he’s used ethernet but wants to use USB and his uucp group is what dialout is to Ubuntu. I recommend reading the whole thread if you’d like to help, it’s not really that long.

I’m no expert but I was having issues connecting my Ortur LM2 on manjaro, maybe something on this thread might help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.