Unable to connect to laser Ethernet

I have had issues with lightburn connection to my laser since the upgrade and I can not figure it out at all. It CAN READ the machine settings without issue, every time. What it won’t do is upload a file. Always goes to 100% then says transfer failed. I honestly don’t know what the issue could be. I have done the following:

  1. reset the switch, reset the laser, rebooted the computer multiple times in every order you can imagine.
  2. Changes the IP address on the Ruida controller
  3. Ran multiple TRACERT commands verifying everything is connected and working.

Tracing route to over a maximum of 30 hops

1 6 ms 6 ms 4 ms
Trace complete.

I can open lightburn read the settings even update the machine settings and that works. What FAILS is Send function. I really don’t understand it. I have to use a USB Stick and it’s very inconvenient.

It used to function about 4 months ago but since upgrading to the new version of lightburn it has not worked since. Even waited for 2 other releases and none of them fixed this issue.
My desktop computer is Windows 10. Its a RUIDA 6445G controller.
I can ping, and read and write settings. The issue is ONLY sending the file to the controller with the SEND button. Is there ever going to be a fix for this?

Have you tried reverting to an older version to see if this gets you back to a working state?

@berainlb is a good start, go back a release or two and see if you have the same issue.

Lightburn has to know it’s broke before they can fix it.

If you can read from it, you’re connected. Since you have windows I’d ensure the driver hasn’t been ‘conveniently’ changed for you by a Windows update. However, I doubt in your case this is the problem.

Since you can connect, it must be talking and I assume it shows ‘connected’ in the laser window.

Keep in mind that the Ruida uses UDP which has no error handling. The point is an unreliable network will kill you with this type of error. There is no way for the Ruida to even acknowledge reception with UDP and no guarantee that the packet will even get to it.

It’s the best option. If you have an extra Raspberry Pi you could move it to a wifi connection with code written by Lightburn to help with these issues. I run it, it’s been very stable. If only they’d add remote camera support :pray:

Does it work with ‘start’?

Good luck, wish I had a quick fix for you…


I uninstalled the latest version, and installed Version 0.9.24 this morning. And guess what?! It sends the file without an issue!!! So where do I go from here?

Nothing changes but the version of lightburn. Network is exactly the same, same ip, same everything.

SAME file by the way! I wasn’t sure it would open the same file but it did.

Let me also say this started with version 1.0.00, and has continued to be an issue ever since.

It’s great that you can at least get to a working state.

It might be worth trying to uninstall the working version and try the latest version again. Perhaps there was some configuration corruption that reinstalling fixed.

Also to confirm, you’re licensed for the newer versions of LightBurn that you were having problems with? I actually don’t know how license expiration manifests in terms of user interaction but I do know that your license is valid through the version released before expiration. LightBurn guys can clarify on this point.

Installed new version again and same issue. Yes I am licensed currently for the latest version

That is odd indeed. LightBurn folks will need to pitch in here I think.

I did encounter this older thread. Doesn’t sound quite the same situation as you as downgrading didn’t change the behavior. Turned out to be a NIC issue in this case. There might be some troubleshooting methods you could try:
Just updated new lightburn, now not able to send to laser - LightBurn Software - LightBurn Software Forum

yes unfortunately I have been following that thread as well and one other one. I have tried everything and this uninstall / reinstall just goes to show that something must have changed because it works on the old version

When you have a version that works and upgrade and some functionality fails, you need to notify the developers and let them look into it.

It’s much easier for them to say yes they know about it, than to find they broke it two versions ago. That seems to be the rolling growing snowball of trouble.

Some of the projects I worked on had over 2 million lines of code in them, it’s pretty easy to break something else someone wrote 10 years or more ago… Google has over 2 Billion lines of code in it’s search engine… ouch…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.