Unable to connect using Ubuntu 18.04

it says ttyUSB0 but it doesn’t seem to be creating the /dev/ttyUSB0 file.

I found a page which talks about FTDI and it says to try this:

  1. Unplug the device
  2. sudo modprobe ftdi_sio
  3. echo 0403 6001 | sudo tee /sys/bus/usb-serial/drivers/ftdi_sio/new_id
  4. Plug in the device

This might show something of interest too:
sudo modprobe -v usbserial vendor=0x0403 product=0x6001

1 Like

Not sure if you know what udev rules are but it might help to create a rule for this device. From what I’ve found googling, the FTDI devices have been a pain to quite a few people. I’ve never run across this problem but I generally create udev rules for all my plug/n/play hardware.

Put the following line in this file: /etc/udev/49-ftdi.rules

SUBSYSTEMS==“usb”, KERNEL==“ttyUSB*”, ATTRS{idVendor}==“0403”, ATTRS{idProduct}==“6001”, MODE:=“0666”, SYMLINK+=“ttyLASER”

1 Like

@RobC I wonder if this is what’s going on with your system. ie the brltty process is consuming the ttyUSB0 device when its created. See this post:

He removed the brltty process from the system and then the FTDI device showed up normally.

To see if it’s running on your system, if you run this it should show the brltty
dmesg | grep -i brltty

or
ps -fe | grep -i brltty

and this should remove it:
sudo systemctl stop brltty.service
sudo apt remove brltty

Did any of that help @RobC?

My FTDI cable just works but I do remember removing the brltty process from my system quite some time ago. Here’s what happens when I plug in the FTDI cable:

[ 2012.638984] usb 1-1: new full-speed USB device number 5 using xhci_hcd
[ 2012.792188] usb 1-1: New USB device found, idVendor=0403, idProduct=6001
[ 2012.792194] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2012.792198] usb 1-1: Product: TTL232R
[ 2012.792201] usb 1-1: Manufacturer: FTDI
[ 2012.792203] usb 1-1: SerialNumber: FTE3RR1N
[ 2013.328753] usbcore: registered new interface driver usbserial_generic
[ 2013.328821] usbserial: USB Serial support registered for generic
[ 2013.332741] usbcore: registered new interface driver ftdi_sio
[ 2013.332813] usbserial: USB Serial support registered for FTDI USB Serial Device
[ 2013.332877] ftdi_sio 1-1:1.0: FTDI USB Serial Device converter detected
[ 2013.332968] usb 1-1: Detected FT232RL
[ 2013.333164] usb 1-1: FTDI USB Serial Device converter now attached to ttyUSB0
(base) dlarue@Lenovo-Z70-80:~/Projects/NXT-Robotics/ROS$ ls -l /dev/ttyUSB0
crw-rw-rw-+ 1 root plugdev 188, 0 Jan 4 15:04 /dev/ttyUSB0

1 Like

This is a bit out of my range of knowledge. How do I do this? I have also removed brltty and it did not help

Sorry the website would not allow me to post anymore for 19 hours.

Did you remove brltty by first stopping the process and then removing it from the system using apt?
I generally use the process list command( ps -fe ) to first show it is running, stop it, then check again to make sure it stopped and then remove it.

Removing it with apt and then rebooting also works but I don’t like rebooting my computer so I always do it the controlled way.

1 Like

I just ran dmesg | grep -i brltty and got nothing so I don’t think it is running

I am getting in way over my head here. But, do you think it is possible to manually create ttyusb0

Run this to make darn sure brltty is not running:
ps -fe | grep -i brltty

if it is not running and you have rebooted and verified again it is not running, then do this:

  1. Unplug the device
  2. sudo modprobe ftdi_sio
  3. echo 0403 6001 | sudo tee /sys/bus/usb-serial/drivers/ftdi_sio/new_id
  4. Plug in the device

you should see no error messages and after plugging in the FTDI/Ruida controller see if there is a /dev/ttyUSB0 device created.

You can’t just create the file and have it work. The driver needs to create it and something is blocking that process.

1 Like

Here is what I got.


After running sudo systemctl stop brltty.service and
sudo apt remove brltty and then rebooting, I get the same results

Did you check to see if /dev/ttyUSB1 is there? You can see that the Ruida/FTDI device driver is attaching to ttyUSB1 this time so please see if that device is there.

1 Like

does not look like it to me

FYI Lightburn doesnt show a laser at all now. Before it at least said disconnected

You just showed output which showed that it was connecting to ttyUSB1…

What we are trying to do is see if the Ruida device is getting created so when you look at dmesg output and it shows the device then that is what you are wanting to look for. it showed ttyUSB1 so that is the device in the /dev directory you should have looked for.

The reason why we’ve been messing with the brltty application is because others( Please read the forum post I linked above ) found that the brltty application is attaching to the ttyUSB0 device and for whatever reason removing it.

also, for the 3rd time will you please run the 4 steps, I’ll list them again but this time, unplug your Ruida cable and turn it off, shutdown your computer, restart both the Ruida and the computer, log in, then

  1. sudo modprobe ftdi_sio
  2. echo 0403 6001 | sudo tee /sys/bus/usb-serial/drivers/ftdi_sio/new_id
  3. Plug in the device

look to see if the device has been created.

1 Like

That is exactly what I have done everytime you have asked. I will do it again.

when you don’t tell me what you got from doing the steps I can’t tell you did them… It’s also important to look and read the output shown after commands are run. Sometimes there’s information things didn’t go well and that’s important to know both if the ommands worked and if the device still doesn’t show up.

I only saw you show a picture of you running dmesg and grep’ing for brltty.

1 Like

I have one last thing to try… that is to create a device rule which will cause the device name to be ttyLASER instead of ttyUSBx. Run this command sequence: Notice after the echo word there is a single quote character and all the stuff in side should be there with matching double quotes around things and finally a single quote before the pipe symbol. The pipe symbol is “|” one.

echo ‘SUBSYSTEMS==“usb”, KERNEL==“ttyUSB*”, ATTRS{idVendor}==“0403”, ATTRS{idProduct}==“6001”, MODE:=“0666”, SYMLINK+=“ttyLASER”’ | sudo tee /dev/udev/rules.d/49-ruida.rules

After you run that, verify the rules file was create with:
ls -l /etc/dev/rules.d/49-ruida.rules

Reboot the computer and see if there is a /dev/ttyLASER file created after you plug in the Ruida cable.

1 Like

it didn’t work. Did I do something wrong?

My bad, the directory for the tee command should be “tee /etc/dev/udev/49-ruida.rules”
I had /dev/udev/… try again

echo ‘SUBSYSTEMS==“usb”, KERNEL==“ttyUSB*”, ATTRS{idVendor}==“0403”, ATTRS{idProduct}==“6001”, MODE:=“0666”, SYMLINK+=“ttyLASER”’ | sudo tee /etc/udev/rules.d/49-ruida.rules

1 Like

looks like it took the rules but did not verify

you are trying to list the same “wrong” file… Try listing the correct file.

FYI, you can start typing the command “ls -l /etc/udev/ru”
and along the way you can hit the tab key on the keyboard and it will try to auto-complete the path and file. If the characters shown are unique, it will auto complete to the next directory. If not you can hit tat twice and it will list all the things which match those characters

1 Like