Unable to "find my laser" - Atomstack A5 Pro - macOS 12/macOS 10.13

The “find my laser” feature does not seem to be able to find my Atomstack A5 Pro.

I started with using an M1 Macbook Air running latest stable macOS 12.4. I installed the CH340 drivers (which I assume to be correct from googling. The official atomstack page for driver downloads for the a5 is no longer found), but received an error that the drivers are built for x86/x64 arch.

I then moved to an Intel Macbook Pro running nearly-latest stable macOS 12.3.1. I installed the CH340 drivers, but am receiving the error that the system extension is blocked.

Finally, I moved to an old Macbook pro running macOS 10.13 (high sierra), installed the drivers, allowed the system extension, and attempted to find my laser again.

In ALL of the above cases, I hear the steppers on the laser kick on when my computer is searching for the machine, but the search window comes up blank. Also, I found that if I set up a machine manually, I am able to select GRBL and select my serial port from the dropdown list, and I can connect to the machine and send commands to it. That said, I’m not confident that I have all the parameters set up correctly in Lightburn for the manual laser setup.

So, in short:

  1. Do I have the right drivers? Does anyone have a guaranteed working link for drivers for the atomstock a5 pro that will work ideally on an M1 MBA running macOS 12, or at least an Intel MBP running macOS 12? Last resort I’ll use my old 10.13 device I guess.
  2. Is the “find my laser” step required? Am I good if I can connect to the laser?
  3. if so, is there a way I can find all the specific parameters I need to set up the laser correctly in Lightburn? Atomstack is unsurprisingly vague in this area.
  4. Otherwise, I have an old Pi 3B sitting around. Can I just set up lightbridge and plug into my Atomstack from the Pi and connect over lightbridge? Or will i run into similar issues?

The driver type is correct… having said that, you technically shouldn’t need to install a driver for MacOS 10.4 or higher as one should be included with the OS. However, people have had varying luck with this. I can’t seem to connect right now but you’re best off getting the driver directly from the manufacturer (CH341SER_MAC.ZIP - NanjingQinhengMicroelectronics (wch-ic.com)). I don’t believe they have an ARM driver currently.

There’s no real difference in the final outcome if the laser was detected with “Find my laser” or if configured manually. The one difference is that Find my laser will attempt to query some values from the controller but that can be easily done manually.

The primary values that you will need to get are $30 for “S Value Max” and $130, $131 for X and Y max travel respectively.

Just make sure this is how you’ve configured it:

  1. GRBL
  2. Origin at bottom-left (front-left)
  3. 410 x 400 mm for width and height
  4. disable auto-home

You can check for these in Edit->Device Settings. While there, make sure thst “S Value Max” is set for 1000. Baud rate should be 115200.

Bridge only works with Ruida controllers. It does not work on g-code based controllers (or any other for that matter).

1 Like

This worked a treat. Frustrating that things didn’t seem to work ‘as intended’, but I ran my first job last night and everything worked awesome. Thank you so much for your assistance.

I was not able to find where to set the following values:

$130, $131 for X and Y max travel respectively.

but they seemed to be good to go from the basic setup anyways. I did find the $30 s value max, and it was set correctly, so I assumed the others would be as well.

Nice. A good number of lasers or possibly laser/system combinations seem to have a problem with auto-detection. This seems more prevalent on Macs based on anecdotal evidence from this site but not certain. Once configured manually there’s no difference in behavior so all good.

You can see these values in Edit->Machine Settings or by running $$ command in Console window. Looking this up would only be to confirm the 410x400 mm for your workspace. I got those values from Atomstack site so they should be okay but I’ve seen lots of inconsitency in some online documentation.