Unique Power Supply Issue... I think it's the Power Supply

I’ll try to give as much context as I can. I have a 60w Blue Chinese Ebay Laser, an OMTech look-a-like. For a year my laser has worked perfectly. I moved to a new home and the laser went from working normally to gradually not being able to cut through even 1/8 inch mdf. When I start a project, the laser will still go through all motions of a cutting project but no laser is being emitted. I started looking online for solutions and read through a number of forums and watched videos. Following some of their recommendations, I have since changed the power supply, laser tuber and laser ON/OFF switch and it still isn’t working. Here’s what is and isn’t working:

  • Main power turns on and machine homes itself and prepares for normal function.
  • Water Pump ON/OFF switch works properly and circulates water. When turned off, the machine senses it correctly and will not complete a project.
  • When the laser ON/OFF switch is switch ON, power is sent through wires to the green connector that goes into the power supply. My meter measured 120V at the green connector.
    *Power supply does not turn on and show any readings on the screen (both the original power supply and the new one). The test button doesn’t fire the laser. No power goes from the power supply to the laser tube.
  • The “Lid Open” senser and emergency stop button work properly and stops a project in the middle of the project.

So there you go. I can’t seem to find anyone, online that is, with this same issue. Power goes to the power supply but even with a new power supply and laser tube the laser still doesn’t fire. I may not be the brightest tool in the shed but this seems weird to me. Any and all advice is welcome. Thank you!

Have you confirmed you’re getting mains voltage to the AC terminals on the LPS? Does the LPS have a test button? If so, does the laser fire if pressed?

If not, what happens when the button is pressed?

Nothing happens when the test button is pressed even though I know power is arriving to the terminals. Could it really be that I received a bad, new power supply? It’s an OMTech MYJG-60W power supply purchased from a reputable seller of ebay.

It’s possible but unlikely. Does the display on the LPS come on? What current does the display read when you press the test button? Can you describe everything that happens when you press the test button?

What is the behavior with the old LPS?

Sounds like the Ruida is working since it’s stopping the machine when various errors occur.

@berainlb advised to check … my same lps has a mA meter in it that lights up… Do you get that?

If no power there are only two options…

I’d double check the mains power not only at the lps, but ensure that it’s ‘mains’ plug is well seated into the lps. Since the lps isn’t powering up, it has to be power to the lps or a broken lps…

Do you have a mA meter in circuit?

Sometimes they don’t ‘screw’ the terminal down and the ‘glue’ is the only thing holding them in the connector… I’ve had an intermittent and other have to… You can ‘gently’ tug on the wires to ensure there are properly installed.

Good luck


Is it possible that the voltage selector switch on your psu is set for 240v and not 120v ?

The test mode works only with the controller connector unplugged. It won’t fire with the connector plugged in, which was the mistake I made the first time around.

The one I have runs at 50% power for as long as I’m willing to keep my finger on the button, so make sure it’s aimed in a safe direction.

Edit: With the controller connector plugged back in, set it for a manual pulse at, say, 30% PWM. Keep your eye on the power supply status LEDs while awkwardly reaching up to the control panel to fire the laser:

Is the yellow P (water Protect) LED on the not-a-network jack on continuously?

If not, then either the Water Protect sensor isn’t connected to the power supply or the P terminal is not jumpered to the G terminal.

Does the green L (Laser) LED come on when you fire the laser?

If not, then the L-ON signal from the controller is not making it to the L power supply terminal.

If both of those LEDs behave properly (both on while manually firing from the controller), then the amber LASER LED should come on while manually firing the laser.

If not, then something interesting is (not) happening …

1 Like

From what I can tell, it sounds like the lps isn’t alive. It has a screen that doesn’t light up…

That’s why I said if it has power to it, it’s probably the lps.

I’ve seen a few where the mains connector wasn’t seated, but other than that I don’t know what to advise … except another lps.

Wouldn’t be the first time someone got a bad part from China.


1 Like

Display doesn’t come on and nothing happens when I press the test button. The old LPS does all the same things as this new LPS. Which makes me think it isn’t an LPS issue.

Did you check that the connector is OK, I believe you stated it has the proper mains voltage?

Your logic seems good, but if you’ve gotten two bad supplies and a bad tube where would that leave you?

There are not many options if the unit has power in, but doesn’t show any indication it’s getting power.

Unless you are leaving out something, I think you should double check the mains connection to the lps for voltage… if it’s got voltage and there is no indication it’s got power … indicative of the that unit…

Since the controller appears to be working…


1 Like

I agree with @jkwilborn that something’s going on with the mains power. I’d suggest examining the connector on both sides and make absolutely certain that the LPS Is getting the proper voltage.

Make sure you’re doing this all safely.

1 Like

I changed the green connectors when I received the new LPS but nothing changed. I didn’t cut off the old terminals and crimp on some new ones on the wires that seat in the green connectors. This may be my next and only hope.

Thanks for all the help. I agree, there has to be something wrong at the green connector since power is arriving but somehow to turning the LPS on. This is where I’ll spend my focus. Merry Christmas. (Looks like some of my laser Christmas presents will be late this year, haha)

Why did you change these? It’s not a good idea to change out stuff like this. Every change you make could add another ‘problem’ to something that should be rather simple…

Did you photograph them before to ensure you wired it correctly?


I received new green connectors when I received the new LPS so I figured some fresh ones would be a good idea. And since I do electrical work for my day job, I’m not too worried about rewiring these types of connections.

I generally don’t replace things unless they need it.

I’m sure in your life, with your experience, you have never ‘mis-wired’ anything … :exploding_head:

The more things you touch, the more likely you’ll break something…

Anyway, glad you’re experienced with this stuff, makes it easier…

Since Christmas is over, we’re hoping for some good news from you …


The power supply’s FG terminal is connected to its case, but not to either of the AC terminals.

If your power supply doesn’t have a screw with a star washer punching through its nice powder coating to the mounting plate and the connector has its hot AC line on the FG terminal, then:

  • The Power supply won’t get any power
  • You’re one layer of powder coat away from testing the branch circuit breaker / GFI

Fun fact: Any wiring color codes you may know do not apply.

Not saying I’ve ever miswired anything like that, you understand, but I hear it could happen. :man_shrugging:

1 Like

Whoa, sorry if my reply came off as cocky. Not my intentions. I completely agree that the more you touch, the more can go wrong. But if this is where “all is right” changes to bad, then this is where I’m going to start touching. And since there are many ways of making sure you have the right wires in the right place (pictures, electrical tape marking, marker marking, changing one wire at a time, etc.), I’m not too worried about removing a couple wires to make sure they are making good contact.

I’ll head out to the garage today and see if I can work on the machine a little. Thanks for all the tips!

I’m sure you can probably handle it…

If you have issues, we are here …


Just wanted to give my thanks for the guidance here too as it’s the closest thread to my own issue and it’s been helpful. I’ve just attempted to set up my new OMTech 60W (first time laser user) and the machine has no indication of power anywhere. Thankfully the tube appears ok and has adequate water flow.

I’ve checked the power lead on another device and working fine. I’ve checked some connections but I’ve reached the limit of what I feel comfortable with so I’ve emailed OMTech UK and hopefully they can help, and soon, before the wife finds out after me buying it as a surprise present from me to me :sweat_smile: