(Update: Problem Solved) Laptop Won't Connect

I’ve read all the threads I can find and tried suggestions, but no luck… so I am asking for help, please… Bought a new laptop (Windows) and Installed LightBurn - no matter what I do, it will not find my Ruida (we run a Laguna 12/20 setup). We read that other users were having issues with recent updates, and so I have uninstalled Light Burn (and C++) multiple times trying older versions, still no luck (I went allllll the way back to 9.16). My new system does “see” the laser, it’s definitely connected (by USB), so I know it’s not an issue with the connection/cable or the laser itself. I have also tried manually setting up the laser with no luck, either. On my old laptop the software worked seamlessly and immediately found my lasser when I started the scan - not sure why it’s giving us so much grief this time around. PLEASE HELP :slight_smile: We have orders we need to get out and this is so frustrating.

My Lenovo laptop will not connect to my LM2 without the laptop being connected to power. Nothing I tried will work to get it to connect while on battery. Have you tried with the laptop plugged in?


Can you try setting up the ethernet…you can look at the IP on your laptop… then manually set the IP on the Ruida controller… this might give you comms.

Have you tried another USB cable, something short…away from any electronic noise…

Can your laptop connect with anything else USB using the csame cable ?

Im sure some of the more experienced guys will jump in… you’ll be lasering before you know it…



This might help, if you need it


1 Like

Thank you so much, Gary! We finally got it up and running after a couple dozen (quite literally) uninstall and reinstalls, and tries with Ethernet as well. I appreciate the help!!

Thank you! We tried this as well based on your suggestion… at this point I’m not 100% sure what combo of magic it finally took to make it work, but after hours of trying everything we could think of and that was suggested in the forum, it finally started working! I did have the laptop plugged in when it finally worked, so that very well may have helped. Again, many thanks!!

You’re welcome :slight_smile: BTW, you can confirm if it was indeed the power being plugged in that solved it by unplugging that laptop and then trying again.

You are welcome and what an interesting resolution… very cool to keep in mind, just incase :slight_smile:
Glad you are back in the saddle :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.