Updated from 0.9.20 to 0.9.21 can't connect anymore

After update to 0.9.21 I can’t connect to my laser anymore (GRBL 1.1).
Uninstalled 0.9.21 and reinstalled 0.9.20 and I can connect again, so it seems like itäs something with the new version on Windows 10 and GRBL 1.1 devices (I have tried two different once)

I also had this problem with GRBL 1.1.

The solution was:
Check the ‘DTR enable’ flag in the device settings - try with it both on and off, and restart the software when you change it. That’s likely the difference.

The solution was given by: Oz - Lightburn.

Thank you. I will try that

I also have a connection issue with my trocen AWC 708C. I have to unplug the USB, than plug it in again. Then press Device buttom (right click) and than the connection is back. I have to do this for every print.

also having connection issue… Connected via network to boss laser. IP pings fine and has been working great but now only “disconnected” showing… Oddly I can still send files but I use the print & cut feature a lot and I can’t get the laser position info to light burn.

Is somebody having a solution for the connecting problem? Its driving me crazy. For every job a have to remove the usb plug and plug it in again. Then also a rightclick on the devicebutton. Please help :sleepy:

There is an update to 9.22 which fixes some issues but whether yours are one of them i don’t know but worth a try.

For everyone piling on to this thread, unless you have the same controller and the same computer, and are connecting the same way, it’s much simpler for us to help you if you start a new thread, otherwise it’s just a jumbled mess of people with different issues. At the very least, please say what controller you have, what operating system, and how you connect (USB, network cord, WIFI).

I have the last update from this morning. 9.22 and connecting by USB

I will start a new thread for this problem.

I went to version .20 I have a network connected trocen awc controller… updated to the .22 but still had the issue. limited connectivity.
can send files but can use print/cut function… .20 works fine.

@jerrylowery, You are working with a different control system than the OP.

Please review the following and share what Trocen model you have there in that post.

Also, please explain what this means, I do not understand the issue here.

You said, “can send files but can use…”

You said can twice, but I’m assuming one of those should be can’t. :slight_smile:

Yes, also some major issues here too…

On upgrading to 0.9.20 whilst everything worked well, every time I opened the software I was prompted with the message that 0.9.20 was now available (???)

I fought to ignore the offer and eventually, the message changed to 0.9.21 and that’s when the problems started

  1. After the 0.9.21 upgrade, all my preferences were lost (From Job Origin to my entire materials library) “Cut Selected Graphics” became unchecked as did “Use Selection Origin”. Simple to fix, yes - once you know they’ve reverted back.
  2. As reported by others, my cutter was lost too.

Then came the offer of 0.9.22 and sadly things are now even worse. While I managed to reset my preferences one by one (After much wasted material - It’s hard to remember all the incremental changes that you’ve made over time) I now find that (On a file that worked before) I’m confronted with the dreaded “Frame Slop work paused” error even though the User Origin is in the middle of the bed and the job to be cut is small and easily fits in the space available (As it always used to - The same file worked flawlessly on previous versions)

2 points here…

  1. Why pester us with constant offers of an upgrade? It’s human nature that sooner or later we’ll hit the big red “Do Not Press” button and chance things falling apart.

Suggestion: Maybe confine the upgrade info to the menu so those that want to can hunt them down while the rest of us can just crack on with our work?

  1. I’m now not in a position to do what I need to. I can’t get round the new “Frame Slop” error (Which I’ve never seen before, despite using the exact same cut files on earlier versions)

Is there a way to go back to 0.9.20? Everything worked flawlessly then and now I’m not even able to get a simple job done on 0.9.22. Could you make these “downgrades” available if they’re not already?

To get the current job done, I actually had to resurrect RD Works and that says it all…


The automatic check for updates can be disabled in the settings, under the ‘File Settings’ page.

Brilliant! Thanks Rick. All back up and running and my faith is restored.



If you’re willing to give it a shot, since you’re one of the known users with the failure, would you try a version that contains what I believe is a fix for the issue you had? I’ll send you a link via PM if you can tell me which OS version you use. Just do a couple tests with cardboard or something to verify that it’s not causing you issues, then if you want to keep using it you can, or just roll back to 920 again - I’m just trying to get known users with the failure to try it, because it hasn’t affected all machines.

Yes, happy to. I’m on Windows 10, 64 bit, Intel i7.


My messages keep getting truncated here. Can you switch to email?


No problem - Just send to support@lightburnsoftware.com and include a link to this thread. I’ll get it.