Updated to 0.9.23 and cannot send jobs to laser


I’ve recently updated my software and can now no longer send my jobs to laser via USB as I was previously. I had opened a recent file (a job I did only yesterday) and cleared my entire file memory but still cannot send the job to the laser. I can send jobs which have shapes/text from within lightburn. I am by no means an expert and very much so a beginner. I’d appreciate simple instructions here on what I’d need to check.

Many Thanks!

1 Like

Looking for a little clarity, you say you can’t send, then follow by saying you can. It can not be both :wink: , so if you could reword, that might help in our understanding the issue more fully.

What OS are you using on your computer? Please share the exact steps you take and what you are asked from LightBurn when trying to do so. We are wanting to see if we can duplicate this here and need you to provide as much detail as you can, if you will?


I also been having the same problems. I updated the 0.9.23 last night and my LightBurn would not communicate to my laser. I usually connect via USB, but I also tried ethernet and nothing would happen. I rebooted both LightBurn, my computer and my laser. Nothing happened. I reinstalled an older version and boom worked like a charm. I have a Ruida control panel.

To all posting, thank you. Please update and provide your Ruida model number.

Hi Rick!

I have the Ruida 644XG.

So .23 is not submitting jobs to my ruida it will frame and move the laser just fine but when I hit start it just sits there and then I click it again and it says it’s having issues communicating to the controller and then I have to restart the ruida for .22 to be able to work it I’m glad I learned from last time (.21) and I am keeping some of the older versions so I can keep going without any issues on older software

Same issue here. I had to roll back to 22 to get mine working. Ruida (Ryxon) controller, OMTech Laser 50 watt

Just did this update and now none of my jobs are sending to the laser control. I send it but its not on my control panel. I have a Boss Laser LS1416 Any idea?

What OS are you using on your computer? How are you connected to this Boss LS? USB, Wired Network, Wi-Fi?

When using ‘Send’, you will be presented with a dialog box asking you to provide a name to the file you are sending. Are you saying after doing so, you go to the HMI (human to machine interface) panel on the laser itself, select the files option, and you do not see the file you sent?

I’m connected via USB. I’m using a MacBook. I believe it’s Big Sur and I haven’t yet done the latest update. So I think I’m running 11.2.2 no longer at home to check.

Yes, correct. I push Send in Lightburn, save it as Leopard and that’s it. Go to my machine and it’s not there. Turned computer off and on. Closed and opened lightburn. Turned my machine off and on and not there

  1. List item

Yes, Big Sur 11.2.2 is what I’m running. Just verified.

Thank you all, again for providing these reports. I have merged these post together as they are all related. We are investigating the cause and will report back as we learn more.

For now, you should be able to roll back to the last version working for you until we can sort this out. How do I find older versions of LightBurn?

I guess I’ll add the other end of the experience. I updated to 9.23 on a Win 10 system with a Ruida 6445G and have no issues. I can start the job from within LB ( Start button ) or send it to the controller ( Send button ) and launch it from the controller.

So for me on win 10 no issue, have not tried from Linux yet.

Good news, thanks for that. This issue has exclusively been report by folks using macOS Big Sur at this point.

Yes same for me today… Downloaded update for Lightburn this morning, when I went to cut this afternoon the laser head would frame but when I would start the cut the laser head wouldn’t move.

Im running Big Sur 11.2.3 on my MacBook and have Ruida 644XG for my laser, had to download older version of LightBurn so I could use the laser to finish up some orders

Ok. Thanks! Will download older version. How do I know what Ruida Controller I have?

This issue has exclusively been report by folks using macOS Big Sur at this point.

My Mac mini where I had the same issue is running Catalina 10.15.7. Consequently my MacBook with Big Sur had the exact same issue. Downgrade to 22 fixed both computers.

Just to add a data point on this topic, MacBook Pro 13" M1 chip running Big Sur 11.2.3, using Lightburn LightBurn 0.9.23, built Wed 2021-04-07 @ 13:02 over ethernet. Lightburn indicates it has found Ruida RDC644XG. Actual controller is a RDC6442G-B (EC). I can send files using the “Send” button, read the “File List” and use the move controls in Lightburn to move the head. Hope this helps.

Once I go to that link, what should I click on to download the old version. There are several ‘assets’ and none of them are doing anything.

Clicking assets should drop down a list.