Upside down and backwards

The laser is engraving upside down. I also can’t get the laser to start where I put it on the camera.

help

Can you give a bit more?

Show us how you have things currently configured in LightBurn. Please remember, we are not there. We only “see” what you tell us, so the details matter.

Chinese machine with Ruida 644xx controller with RDLC-V8.00.47 firmware. latest version of Lightburn. Windows 10, dell desktop. I have not used the laser in over 6 months, it was working fine. I got on it today and everything has gone south. On the controller if I press up it goes down. Using the camera, the laser used to mark where I put the image or text, now it engraves where the laser sits. And the upside down thing. I reloaded the factor settings and nothing changed. I have been at this for about 3 hours.

The keypad buttons have their own settings in Edit > Machine Settings, near the bottom, called ‘Invert Keypad Direction’. Save what you have now, just in case, then check those. We have general documentation on configuring a Ruida controller from scratch that you can refer to as well: https://lightburnsoftware.github.io/NewDocs/ConfiguringRuida.html

Have a review of this to help in understanding the different ways to tell LightBurn how to cut a project: https://lightburnsoftware.github.io/NewDocs/CoordinatesOrigin.html

I want to double-check for clarity, “reload” or “reset”? There is a big difference. :slight_smile:

I’m not sure what the difference is. I wrote the saved factory settings. The keypad direction is fixed. I was able to engrave in the right direction with RD works, but not lightburn. I will go the the documents you sent.

I just set up the way the document shows and the laser still engraves where the laser is sitting not where the image is placed

How so? You can use more wording. I promise, we don’t charge extra and it really helps when trying to narrow in and provide you with the best possible answers. :slight_smile:

Where do you have the ‘Machine Origin’ set? It should match where your systems goes when first turned on.

So, I am not trying to be difficult…but I did share some guidance for How to ask for Help. Can you provide how you have things set currently? You are not offering enough information. Screen captures work well to illustrate what you see.

Where do you currently have the ‘Start From’ set?

Capture 1

Here is how I have it set up. I have the origin set in the front left corner, but it homes in the back left corner. I’m not trying to be evasive, I’m not sure what to include as I don’t have a clue as to what changed.

This is the issue. Set ‘Machine Origin’ to the same, back left.

Ok. We have progress. Text is going in the right direction. The other issue is: as shown in the picture, I placed the text in the lower right corner and the engraving occurred up and to the left. I tried this with user origin, current position and absolute and got the same result.

Capture 4

That is good to here. Our documentation can be helpful.

Hard to tell with the pictures you shared, but the art looks like you have it in the center of the workspace. Not following you when you say it is in the “lower right”. You also say, “engraving occurred up and to the left”, how so? Show us please. How far off is the result from where you expected?

There is so much going on in the images you have shared (multiple test runs, multiple objects on the bed and the gantry covering the entire center), it is hard to tell what you are sharing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.