USB Code 43 Connection Issue Problems

Hi Folks, I am new here and wanted to document a issue that I have been having with my Ortur Laser Master 2. I have been having a progressive issue with my laser connection to my PC. It would connect sometimes then it would drop the connection for no apparent reason. I tried so many things to fix my laser, tried at least 6 printer cables. Updated drivers, rebooted so many times I can’t remember.

For some reason I looked into the female USB connector plug that’s attached (soldered) to the circuit board. And I found one of the four pins that didn’t look quite right. I looked closer and found that one pin on the inside of the connector was pushed down in the female socket about half way. This resulted in a good connection part of the time and other times only 3 of the 4 pins would make a good connection. This issue generated a Code 43, very frustrating.

I unsoldered the “Type B USB” female jack socket and am now waiting on a order of some new sockets. If anyone is having an issue with “Code 43” or other connection issues take a very close look at terminals inside of the female USB on the circuit board.

I did setup a temporary connection with a standard USB Type A cable and eliminated the socket and have a rock solid connection. If I have any future problems with the new USB Type B connectors I will change back to the Type A USB since they seem to be more robust.

Anyone have any ideas on why the board was fitted with a female USB printer port?

This is fairly typical for the device side of a USB host->device connection.

Nice troubleshooting and repair.

1 Like

So after finding the issue that was causing the Code 43 problem I contacted Ortur and I received a reply from Gil Araújo. I sent him a few photos of the board, Gil wrote back and offered a new motherboard for my laser. Can’t beat that kind of customer service. Other than this problem I have had zero issues with this laser engraver.

1 Like