Various problems with lightburn, line shifting

I recently got the Cohesion Laserboard and I’m having a hell of a time dialing in the settings. The quality has been an issue, so I was thinking it might be a slight offset issue. That being the case, I disabled Bidirectional to see if that improves it.

With bidirectional disabled, things get tilted. For example, straight text will look italicized, and it happens in the same place spot of the print every time, regardless of where the print is on the bed. Preview looks good in all cases, but the errors are consistent, so it definitely seems like Lightburn is sending the incorrect signals to the board.

In this scrap picture, the TOP is with bidirectional enabled. The bottom two are disabled. Notice that the top and bottom lines of text are slanted. It’s not just text, it’ll slant graphics (or parts of graphics) just the same. This has happened repeatedly, but most of those pieced have personal information on them, so I just made this to show ya’ll what it’s doing

Also, even with bidirectional enabled, it’s missing lines. Same place, regardless of where the print is, so it’s unlikely hardware. I don’t know. To get high-quality prints I’m having to keep swapping back to the cheap Chinese board that came with it and using K40 Whisperer. Any help figuring out these problems are appreciated.

It could be settings - if you can include those I can have a look and make suggestions based on that. It’s not the software directly, as if it was it would be far more than you having the issue. Some of the settings, particularly ‘Flood Fill’ can make the machine bounce around a lot, and that can result in gaps unless the machine is really accurate.

LightBurn doesn’t send “signals”, really, it’s just gcode in a text file. You can save that GCode as a text file and run it in a variety of online GCode simulators to prove (or disprove) that the GCode is correct.

Line shifting isn’t a totally uncommon problem with the C3D, and the most common causes are going too fast, poor grounding, or not having the settings adjusted properly. The last one could be the issue - the C3D ships with relatively conservative settings for motor current, and you can change those on the SD card.

There’s a file called config.txt, and in it you can look for “alpha_current” and “beta_current”, which are the motor current settings for the X and Y axis. If those are less than 1.0 now, increase each one by 0.1 and try another run.

The current being too low could explain the skew on uni-directional engraving, because the head, when returning to the line start, will be moving faster, and if the motor current wasn’t high enough, it could be jumping a step or two at the end of that return move on each line.

Thanks for the response. I checked and the currents were set a 0.4 and 0.6; I’ve bumped them up to 0.5 and 0.7. I’ll give it another couple of runs.

How do I show you my settings? I read another comment saying to type $$ into the console, but I get invalid argument when I do that.


EDIT: Increasing current had no change. Also, I’ve never enabled Flood Fill.

EDIT 2: Ok, new info after some tests. The faster it goes, the more it slants; taking it from 300 mm/s to 75 mm/s almost got rid of the slant. What’s different when bi-directional is turned off that would explain it only happening in that mode? Also, I just noticed that during a pass, it slows down during the moments that the laser is firing. If that’s not normal, that might indicate a low-current issue somewhere I’m thinking.

That’s quite literally the only difference between those two modes.

The laser going slower when firing could be the result of the ‘Fast Whitespace’ setting, if you have that enabled.

The $$ settings are only for GRBL boards. Yours are all contained in that config.txt file, so you could attach that here.

Thanks for the help. Attached is my config file which causes the behavior. ‘Fast Whitespace’ scan has never been enabled. Also of note, I’m engraving from the bottom up, so the head seems to stop too soon on the return and start engraving a slight bit ahead of the previous line (and it seems worse depending on how ‘busy’ the line is, but I’m still testing that theory.) Again, only when bi-directional is disabled. I’m going to try to play with a few settings and see if I can narrow down the issue further. Any ideas appreciated. Thanks.

config.txt (28.4 KB)


  1. On both axis; Reducing maximum rate from 24000 mm / minute to 18000 mm/min made no change.
  2. On both axis; Reducing maximum acceleration from 2500 mm / sec to 1500 mm/sec made no change.

I’ve tried everything I can think of, no fix, and still can’t get a quality print. I have to assume it’s a power issue. If the laser is on, even when I creep up just barely until it turns on, the X-Axis motor slows down dramatically at 200mm/s. The slant when bi-directional is turned off I have to assume is due to the laser slowing down when moving right, and and not slowing down when moving left because the laser is off.

If I disconnect the Cohesion board and go back to the original, fire up K40 Whisperer, 300mm/s like butter and looks great. No slowdown or power issue.

If anyone has an ideas, I’m open to trying whatever. I can throw up a video to show the difference if that helps. If not, I have no choice but to be done with Cohesion and Lightburn, which is unfortunate since I spent as much on the Cohesion hardware and Lightburn as I did on the entire Engraver.

Any help appreciated.

It’s possible that you got a bad board - It’s rare, but it’s not unprecedented. It’s more likely that you have poor grounding or electrical noise that’s causing interference on the step or direction line for the X axis when the laser is firing. I would check all the wiring connections and make sure they’re secure, and check the Cohesion3D knowledge base for guidance on grounding and wiring.

I can say with certainty that it’s not the commands being sent to the board - we have many, many C3D users who do not have this problem, and if it was the software it wouldn’t just be you having the issue. You can trivially verify that the GCode is correct by saving it to a file and running it on an online gcode simulator. (I do this regularly to check the output)

Sorry for my late response, been away from home for a bit.

I’ve done more tests, The GCODE is good, the servos/etc, are all good. The best idea I have is that somewhere between the gcode and the voltage leaving the board, there’s an issue.

Here’s a video of how it acts with Lightburn. Notice how the much it slows down whenever the laser is on. Also worth noting, it does this even when power to laser is completely turned off.

(Might outta mute before playing this, GoPro added some loud music.)

Here’s a similar print using K40 Whisperer and the Nano 2 board.

Notice that everything is as smooth as butter.

I’m confident it’s not the grounding. I have a grounding block for the house connected to both earth and building ground, it’s about the best ground you’re going to find on a residential property.

It’s also consistent on a per-design basis. Every error repeats itself exactly every time you laser that design. The exception is that sometimes there is a line shift with Lightburn, but I think that’s due to the uncontrolled slow-down of the axis.

As far as connectors, the only connectors I have to move to change boards are the 4 connectors between the Lightburn board and the OEM board. The connectors are fine.

I think I’ve got a bad board. If there is any test you would like to me to conduct to confirm or rule it out, please let me know. Thanks.

What image settings are you using? The board itself has no problems at all running 300mm/sec, but image processing requires massive amounts of GCode, and Smoothieware isn’t super fast at processing those. The stock, default, older firmware caps out at about 80mm/sec with the default image settings (0.1mm / 254 DPI). If you are running the new Cluster firmware, that increases to about 240mm/sec (3x faster).

So far in your posts you have only mentioned speeds, and nothing about DPI settings, image options, etc, and those absolutely matter. Higher DPI means more GCode commands to process, and the board maxes out (with Cluster mode) at about 2400 instructions a second, or 800 without.

Below is the info you’ve asked for:

edge-54d22942, Build date: Jun 5 2019 14:09:26, MCU: LPC1769

Device settings that are enabled:
Enable ‘Out of Bounds’ warning
Enable Smoothie Clustering
Reduce Smoothieware pause delay
Return to Finish Position.

For that print the settings were :

Interval: 0.1
Speed: 250
Max Power: Irrelevant, even at 0% it behaves the same.
Mode: Fill

Bidirection: On
Crosshatch: Off
Overscanning: 20% (less and it missed the beginning/end of a line.)
Line Interval: 0.1
Lines per Inch: 254
Scan Angle: 0
Ramp Length: 0
Number of Passes: 1

Fill all shapes at once: ON
Flood Fill: Off

There are no image or shape options, It’s just a solid black image made ‘Object to Path’ in Inkscape.

I don’t know how to determine instructions per second.

I’ll do some more tests tomorrow at slower speeds. I’ve done that before and still noticed the problem, but can’t remember of the severity reduced.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.