Version 1.0 - MacOS issues with Ruida

@LightBurn so I have run several times just fine but now all the sudden I am back to the issue I was seeing before. I am still on the 1.0.2 from a few nights back. The counter starts counting up but then the job never actually starts.

Isn’t there two existing solutions / alternatives that already exist?

  • Connect the Ruida controller via Ethernet
    :arrow_forward: OR :arrow_backward:
  • Save the Lightburn project to a USB thumb drive (and plug that in to the Ruida USB flash drive port)

The root cause of this is Mac OS and the FTDI chips in Ruida controllers (arduinos, lighting controllers etc…) due to Apple’s built-in “FTDI” (USB to UART) drivers that don’t play well with the 3rd party drivers also being installed on the computer.

I don’t have or use a Mac. Has anyone tried uninstalling the FTDI drivers from their Mac to see if this resolves the issue? That is what I am reading as the resolution for some.

Very interesting info in this thread:

https://www.ftdicommunity.com/index.php?topic=547.0

Just one more piece of trouble shooting feedback, I can cut lines, but can’t fill images on mac. Sure you realize this but just wanted to get that out here.

It all comes down to the size of the file being sent. Small files go through quickly, but once the size is large enough, the transmission throttling becomes really important, and that’s when it fails.

I have been communicating with my Ruida control over ethernet and have not had any problems. Even with the previous version.

Ethernet is completely unaffected by these issues.

Just tried the latest build and so far so good. I just ran 6 different files (with lots of parts) dry (no laser) and so far no issues. I could roll back before Big Sur if I needed to with no major issue.

Anyone else following, please post any results you have with the new version in the thread linked above.