Very slow laser?

Had to replace my controller, now I can’t seem to adjust my burn speed and whitespace speed. Attaching pics of my settings, any help greatly appreciated.

Additional info

What did you replace it with? This would be good information to share with us. I can also see that you have 1010 set for your ‘S-value max’ setting. Is that what you have set in your firmware as well? Those need to match, but while this is something to check, it is not the issue causing this:

Please post your firmware version and settings and we can go from there. :slight_smile:

Replaced with exact same controller, Keyestudio V0.9A, attaching $$ output, thanxGrbl.txt (434 Bytes)

Just post the text here so folks don’t have to download your file to review. You will get more comments doing so.

$$
$$
$0=10
$1=25
$2=0
$3=3
$4=0
$5=0
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=1000
$31=0
$32=0
$100=100.000
$101=315.000
$102=315.000
$110=650.000
$111=500.000
$112=500.000
$120=10.000
$121=10.000
$122=10.000
$130=200.000
$131=200.000
$132=200.000
ok

$
[HLP:$$ $# $G $I $N $x=val $Nx=line $J=line $SLP $C $X $H ~ ! ? ctrl-x]
ok

Make sure that matches the ‘S-value max’ set in LightBurn

Read this: https://github.com/gnea/grbl/wiki/Grbl-v1.1-Laser-Mode
and this: https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration#32---laser-mode-boolean

Did you save the firmware settings you had set on your previous controller?

These settings are your maximum speeds in the controller. You have them set to 650 mm/minute in X, and 500 mm/minute in Y. (That’s 10.8 mm/sec and 8.3 mm/sec respectively)

Thanx, what would a typical speed setting be for 110,111 and 112? also I turned on the correct setting for 32 and adjusted the s value. Appreciate your time!

This is entirely dependent on the capabilities of your machine. Motor size, drive type (belt vs ball screw for example), and more all affect how fast you can run. So cannot really say without knowing more about your machine.
Ideally you would have those values from your old controller that you could copy over.

Hope someone can explain the “S” value to me and what it does, have seached all my manuals and can’t seem to find anything.

The $30 setting is the maximum spindle value that the controller expects to see from the software, and the “S-Value Max” setting is what LightBurn sends for “100% power”. They have to match, and if they don’t you can get weird results.

On a CNC machine, S is the ‘spindle speed’, usually measured in RPM. When you send a GCode feed move the S parameter sets the analog (PWM) output that feeds into a device that controls the spindle speed, or in our case, laser power.

The S parameter can be literally any number - Some GCode systems use 0 to 1 (with decimals, like 0.52), some use 0 to 100 (percent), some use actual RPM (500 to 5000), and GRBL often uses 0 to 255 because programmers are lazy and when you read an 8-bit image, the values are from 0 to 255, so naively they’ll just send the 8-bit number right from the image file. (That’s actually wrong for a couple of reasons). Newer GRBL uses 0 to 1000 by default.

The software generating the gcode needs to know what range to use for the S parameter, and the controller reading that gcode has to know what range to expect, which is why they need to be set to the same number.

If I tell you “set your speaker volume to 10” that could mean a few different things - If I think stereos go from 0 to 10, then I meant “set full volume”. If your stereo shows 0 to 100, then you’d interpret what I said as “set it at 10 percent of full volume” which is obviously not what I meant - that’s why both ends have to agree on what the numbers will be.

Thanks to all, solved it with my acceleration settings.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.