Waiting for connection issue

I searched this forum for “waiting for connection” and found this closed thread from 2019: Waiting for connection... Waiting for connection

I am having the same issue. LB loads and finds the laser (GRBL driver) but I get the ’
waiting for connection’ message in the console and it never connects.

I’ve been back and forth installing, uninstalling, reinstalling. I’ll list the steps I use for manually adding a device here:

  1. Remove Existing GRBL driver
  2. Click Create Manually
  3. Select GRBL
  4. Select Serial/USB
  5. Select Next
  6. Use 400mm and 300mm for the work area
  7. Select Next
  8. Select Front Left
  9. Select Next
  10. Select Finish
    Device now shows up pane
  11. Select the GRBL device, click Ok
    I now have options for COM3/GRBL and COM4/GRBL but both have the “Waiting for Connection” Issue.

Other things I’ve tried:

  1. Installed LB with same Ortur LM2 device, worked instantly
  2. Bought a new USB cable, obviously not the problem as it works on the other computer

Are you saying this is a new computer? Have you installed the Ortur drivers on it?

No it isn’t new but the OS was recently reinstalled. I didn’t install Ortur drivers when I got it and it ran fine. I did an experiment with a fresh computer yesterday and I didn’t install Ortur drivers on it either. It worked right out of the box.

I encounter the same issue, and (for me) the solution was:

1/ Start LightBurn
2/ Go to the console tab, and when I see the ‘waiting for connection’ message,
3/ I plug in the USB from the laser (my LightBurn Camera stays plugged in all the time)

Then it connects, every time.

I also have a macro defined with all the GRBL settings I use, so just to be sure all parties are in the pool and talking … I run that.

I tried that and it did nothing for me

Click the ‘port list’ in the Laser window - it’s the drop-down list to the left of the box that says ‘GRBL’ (or whatever you named your laser). The box might say ‘(Choose)’ in it, or have the name of a port. If the wrong port is chosen you won’t get a connection.

I’ve tried both COM3 and COM4 to no avail. Device manager shows both ports are working properly

Exported my device info:

{
“DeviceList”: [
{
“DefaultCutList”: [
],
“DefaultToolCutList”: [
],
“DisplayName”: “GRBL”,
“EnableLaser2Offset”: false,
“EnableProcessOffset”: false,
“Height”: 300,
“HomeOnStartup”: true,
“Info”: “”,
“Laser2OffsetX”: 0,
“Laser2OffsetY”: 0,
“LastCamera”: “”,
“MirrorX”: false,
“MirrorY”: false,
“Name”: “GRBL”,
“ProcessOffsetX”: 0,
“ProcessOffsetY”: 0,
“ReverseIntervalCompensation”: false,
“Settings”: {
“CommPort”: “COM3”,
“UserFinishX”: 0,
“UserFinishY”: 0
},
“Type”: “Serial”,
“Width”: 400
}
]
}

I temporarily moved my office desktop pc into my shop until this laptop lightburn configuration issue is solved. This proves that the Ortur


LM2 works fine and works with lightburn. I can’t leave that desktop in my shop, I need it in my home office. I need to diagnose why lightburn will not work on my laptop.

Ortur tech support solved this issue

https://ortur.tech/support/ticket/waiting-for-connection/#reply-75418

Glad to hear you got sorted. Please post what Ortur provided as the solution. The link you offer is not publicly available. :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.