Waiting for connection... Waiting for connection

grbl

(Marc Urben) #1

Hi there

I have a “Chinese Mini CNC” with a diode laser based on a Woodpecker 3.2a board with Grbl 1.1f. My problem is, that on connecting to the device, I only see “Waiting for connection…” (sometimes multiple such lines) while the CNC drives the Z axis down and powers the laser…

Strangely, I got it to work twice by re-plugging the USB several times and hitting some GUI buttons at random. I can not describe it better, it was a really desperate try… :roll_eyes: When I got it to connect, everything works perfect. I spend multiple hours trying to get the connection going more times without any further success.

This is what I figured out / tried:

  • Right-clicking the “Devices” button also does not help
  • Connecting to the device with a serial terminal (screen, putty i.e.) works flawlessly and I get the Grbl prompt:
    1.1f [’$’ for help]
    [MSG:’$H’|’$X’ to unlock]
  • It matters not, if I use the Linux (Ubuntu) 64 bit or Windows 10 64 bit version, tested on multiple computers. Exactly the same result.
  • It works also flawlessly if I connect the device to CNCJs on a Raspi.
  • I Added endstops to the Mini CNC.
  • When I connect the CNC (and I give it 12 V power) the Z access is running down as fast as possible and the laser is turned on (!) (this is a really scary thing about this problem). The Arduino part of the board works without the 12 V, so I tested mostly without 12 V).
  • Enabling debug output does not produce any more helpful output.

It feels to me, as if LightBurn is either waiting on the serial port itself or is starting to send data without waiting for the prompt of grbl. The problem is definitely in the connection “step”.

I would love get LightBurn working, since it really seems to be the best software for my needs.

Hopefully, somebody can help.
Best regards from Switzerland, oXiVanisher


(Ray Kholodovsky) #2

Did you flash GRBL onto this board yourself or are you just using what it came with?


(Marc Urben) #3

I am using what it came with.


(Ray Kholodovsky) #4

First, are you on the latest LightBurn 0.9.02 ?

Random machines can come with modified, different, or otherwise "weird’ flavors of grbl that do weird things. In order to get yourself onto the same page as everyone else, I would recommend flashing a known good latest release of GRBL: https://github.com/gnea/grbl/releases

First, backup your existing settings by sending $$ in console and saving the resultant response list of $ values. You can also use Edit --> Machine Settings in LightBurn to read the values, and write them down/ take screenshots for use later.

After you have flashed, try running without a Z table first (what I mean by this is that only XY homing should be enabled) and work from there.

That’s the most common setup out there: official grbl with XY only.

Get that working, then deal with homing, Z axis, etc…

I should also mention that you are running some element of risk by doing all this, but it’s a necessary step in order to be able to debug further with you.


(Oz) #5

Before going through all that, give this version a try: https://drive.google.com/file/d/1xcfxBXgrx5_qHMaMjdICU72U9qRF-jTE

There have been a couple small changes to the connection handling and I’m wondering if this helps.


(Marc Urben) #6

That did the trick!

Luckily i stopped last night before bricking it, since it seems to work like a charm with 9.03. :slight_smile:

Thanks!