“Waiting for connection” on Mac Ortur Master Laser 2

Hello all, I just got my Ortur Master Laser 2 yesterday. Super easy to set up and I downloaded the free trial of LB.
I made 3 engravings inside (realized it was very smokey) then moved into the garage. After I disconnected and moved into the garage, suddenly I cannot connect my laser anymore!

The laser turns on and goes to home so I know it’s physically working.
“Find my laser” worked at first and even once after I moved to the garage. Then I couldn’t connect to the previously setup laser. I removed the device and tried again…Now I cannot “find my laser” or “create manually”. Console interface says “waiting for connection”. The provided USB cable worked at first so I assume it’s still working.

My only USB input is cu.bluetooth-incoming port, which I believe is what I originally used to set up. I was hoping to just choose a different port but there’s no options. Now that I “removed” the GRBL from my devices I cannot even map it again.

I’ve tried most simple things: resetting laser, restarting Mac, resetting my USB ports (they work with other devices), uninstalling lighburn and re-installing. Also fired up laser before lightburn as I heard that could work.
I don’t know what else to do, it’s very frustrating that it worked for a couple hours then just stopped.

Ideas

  1. Bad USB cable? I dont know how to test it or where to buy another one. It worked at first too…
  2. The port is being occupied by a dormant version of LB - but I uninstalled and reinstalled so don’t think so
  3. Don’t have Mac drivers? I didn’t see any drivers to download for Mac, and I did not do that at initial set up so don’t think it’s this
  4. For some reason it’s not recognizing the Mac USB port but I reset them and they work for other devices

Thank you

This is a Mac thing. It seems pretty common.
Have a look at this thread - It’s possible that this problem and solution set are similar to yours.

That worries me that it’s a “Mac thing”, I’m not going to buy a new CPU for this. I tried every combination of laser first then LB open, LB open then Laser on, laser on then LB open, then plug in etc. etc.

I cannot add manually nor “find my laser” so the port solution is irrelevant, at least at this point :confused:

Sorry, didn’t mean to make sadness.

plug engraver into wall and computer, start computer, start lightburn

post where you’re stuck - i think we can get through this - it’s a minor hiccup by most accounts.

1 Like

This is the fundamental problem. It’s not detecting your actual USB port. Try right clicking the Devices button to force a reconnect. If you can’t for some reason click the Devices button, then OK.

Does a new port show now? You may need to pull-down the selector to see the other ports. It should say something like “cu.usbmodem-12345” where the numbers may be different.

If that doesn’t work. Check that the laser is showing up in Mac System Report under USB. If you don’t see a device listed there LightBurn will not be able to use it. Key will be in working out why the device is not being detected in MacOS.

2 Likes

Hi berainlb, I have tried all of those things. Forcing reconnect does not work, especially now because the device is not even listed in “my devices” and “find my laser” or “create manually” wont work. A new port never shows up so I do believe you are right, the main issue is that my USB ports are not working - system report only shows Bluetooth as seen in picture.
I started reading some forums about the FTDI drivers having a conflict and basically getting hung up, but I am no CPU wiz and I am not sure which “solution” out there is actually right. I tried the Ctrl + Opt + PR keys to reset the ports which worked for other issues in the past, but did not work for this issue.

I hope thats the case, see my reply to berainlb about what we believe the main issue is here and see if you have any input

Ortur Laser Master 2 (not Pro) uses an STM USB chip. It’s not FTDI. It should not require any driver in any version of MacOS from I believe 10.3 and newer.

What is the Bluetooth USB Host Controller? Is that something you’ve plugged into the Mac? Try removing all other USB devices and plugging laser directly into the Mac.

It’s possible that the controller on the laser has also gone bad. Do other devices work in the USB port you’re using? Do you have another USB port that you can try?

Try resetting SMC on the Mac. How you do this will depend on your specific Mac model.

Do you have another computer that you can test to see if the laser is detected?

That’s good to know about the FTDI. I do not know what Bluetooth USB host controller is, but nothing else is plugged into my laptop. I only have 2 USB ports and neither work for the laser as of now.
All of these times I have had the laser directly plugged into the Mac via USB(and nothing else)

When I plug my iphone into the ports, my iphone does show on the system report which makes me think it’s working fine.

I have reset the SMC, but I will reset it again and check with another Mac i have access to tomorrow.
Also going to order a new cable to narrow my focus

I appreciate you’re help with this! I saw you on some other forums and you seem very knowledgeable

Glad to help. I don’t daily a Mac anymore so it’s a little harder trying to do this from memory so apologize if some of my guidance is off the mark.

Sounds like you’ll be able to cover all 3 major break points:

  1. USB port - if this is working with your iphone then this should work for other devices. You may want to test it on some other USB devices if they’re available to you. Printer would be a good candidate.
  2. USB cable - the new cable should give you assurance that the cable itself is not bad
  3. Laser controller - connecting the other Mac should give you relative assurance that this is working. You really shouldn’t need to even install LightBurn. If you can get the device to show in the list of USB devices then it should be enough for this to work

If all 3 of these pass, then it’s likely a driver issue. There may be a reason why the driver is not loading. I don’t like this because it obviously worked for you initially.

What model of Mac specifically are you using?

Hello, thanks again was busy at work a couple days. So I got a new cable, both new and old cables worked, the other mac recognized it so I tried the main laptop again and it connected via “find my laser”. I still am stuck on “waiting for connection” but I see 2 ports as options now, neither one connects, even if I try a force reconnect.

I have MacBook Pro 15” running 12.1 Monterey

Odd that you’re getting different behavior now but good that you’ve proven that cable and controller are good to go.

Can you take a screenshot of LightBurn with the port selector pulled down?

What year is your Macbook Pro?

I removed my laptop and not at home now, but this was the new port, and I also had the “cu.bluetooth-port incoming” as an option.
Its MacBook 2015, plenty of memory.

I was thinking about backing it up to a harddrive this weekend then resetting it from that backup, however, if the backup saves the issue…Ill be back to the same spot.

So it’s working now…didn’t do anything but tried once I got home haha. I’m glad it’s working but not convinced I solved the root cause, any ideas that you have are much appreciated! Fickle little thing

Thank you for all the help

Hmm… That’s great but as you hint at… not exactly comforting.

Normally once you have the right port displaying right-clicking on Devices would be enough to get you going.

One thing you might want to do is to go into your System Report and take note of the USB details for the laser while you have it running. Might give you some information to reference in the next cycle.

Good idea, I’ll post in here if I ever find a sure fire solution. Enjoy the weekend

What I think happens is that you need to 1) power up laser 2) insert usb plug into Mac and 3) open Lightburn. If you have Lightburn open and then power up, the laser will not show in Lightburn, although you can find it in /dev. Fix this by quitting Lightburn and then open it again.

To check the USB ports in /dev, open terminal
MacBook$ cd /dev
Macbook$ ls cu*

you should see
cu.BLTH
cu.Bluetooth-Incoming-Port
cu.usbmodem1234561

the last one indicates you Mac is seeing the laser.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.