Weird dots all over my engraving

Hi there,

I have had my 40w bodor for 2.5 years now. Always engraved like a dream.

New tube in November

For the past month I have been experiencing these weird “dots” all over my work when engraving. They show up more on mirror and leather.

I have another machine connected to the same Lightburn and have done for over a year now.

The technician has tried EVERYTHING. We are at a loss.

Troubleshooting so far:

New tube
New power supply
New controller
New USB cable
New mirrors
New lens
Air up, air down
Different fonts
Different material
Different laser head nozzle
Different settings
Alignment is bang on

NOTHING has improved it unfortunately.

Masking the back helps, but some dots still show.

Doesn’t happen when engraving a simple square, but all text it does. Tried different fonts, different files. It still happens.

Does anyone have any other suggestions for me? I’m at a loss.

Thanks in advance! :pray:t3:

it seems you have replaced everything but the wiring, motors and motion platform and so I would look at your wiring to see if something is causing the power supply trigger( L signal? ) to glitch. On my K40 the LPS-L signal gets pulled low to cause the laser to fire so anything which can interfere with the LPS-L signal could be causing this.

I would also look into what the effects are if one of the safety switches were glitching to see if rapid short door latch or water flow glitching might cause the laser to fire for a short moment while the switch returns to a valid state instead of just disabling the laser and re-enabling it. There is likely more random machine vibration while engraving text rather than a square box.

This appears to be a scan of the text.?

What is this material and how are you lasing it, back front…?

If you haven’t had this issue before I doubt it’s emi especially since the L-On1 or the lps L connection is very low impedance ttl signal. If there was an issue here, I think I would see it on my machine, as my pwm and L-On1 both go to connectors for my scope and have ‘long’ wires on them…

I doubt it’s a controller, but it can’t be excluded…

It’s tough since there appears no way to determine how it’s firing when it shouldn’t be.

I’m trying to think how to debug that type of issue…

:smile_cat:

I searched the forum and it seems this issue has arisen for a few people. No set fix for it though sadly.

Some are saying bad gas in the tube, some are saying wiring. Some are saying lightburn.

It doesn’t happen when I send the job to the laser from RD works.

Very very confusing!

Thank you. I’ll suggest that to the tech.

It doesn’t happen when I send the job from RD works. I’ve never used RD works until now.

However RD works gives me this weird double vision thing

The double-vision thing is the scanning offsets. You likely entered them in LightBurn, but not in RDWorks.

Did you set all other settings identically? (Speed, min power, max power, interval, etc?)

I’ve seen those random dots happen when using too high a power value and engraving on something reflective. The beam can bounce back toward the lens/nozzle, then back onto the material, causing occasional small dots. It’s most common when engraving paint off metal tumblers.

ah so it’s a Ruida controller then. As LightBurn mentioned, you’d need to check lots of settings to see that the configuration is the same between the two software options. Oz brought up a good point about reflections so I hope you are engraving that from the back instead of the front and your base material(under the work piece) is not reflective.

Yup engraving the back. Nothing reflective at all. Happens to leather too

It’s the same settings I have always used. 300 speed 20 power. Happens a lot on leather which isn’t reflective. Does not make any sense to me. Weird that it doesn’t happen via RD works?

I’m wondering if it’s happening as the laser head changes direction. At speed of 300mm/s there is probably lots of overshoot and why the dots are that far from the design.

Try half the speed at the same power. Ya it will burn deeper but for testing I don’t think you’d want to reduce power since you might not see the effect at a lower power.

Might be mistaken, but this looks like a scan, and it would not be scanning halfway then changing direction. There are dots everywhere…

Looking for something ‘relative’ to anything we can identify. I’m still wondering how it can fire like it is with Lightburn, but not with RDWorks… ?


@kimmicks07 … how is the artwork done? Is it a simple fill or is it something else.?

I assume none of these aberrations occur in the preview?

:smile_cat:

yes it looks like a scan with an angle of 0( horizontal ) and it would appear the setting is for Fill Shapes Individually. This is why I thought maybe there was some overscan glitching happening. it’s a fairly bulky laser head and doubtful it’s optimized so I figure there’s lots of deceleration happening on each side of the engraving.

With so much replaced I was thinking it was wire harness noise as the motors stop and reverse direction and acceleration and this is where peak power to the motors(wires) will likely occur.

It’s fill via lightburn. And definitely not on the design. Same file sent to my other machine (koenig) gives a perfect engrave.

I cannot find the reason why :sob:

I’ll try this now :slight_smile:

Same deal at half the speed unfortunately

1 Like

Hello, I got the same problem before, engraving on transparent acrylic. I cleaned my 3 mirors, inside the nose and cleaned my lense. I removed an air bubble in the tube, checked my mirror alignment and then those dots disappeared.
So, check if there is no bubble in your tube. Hope it’s the solution for you too.

And also I used dish soap with water sprayed on my acrylic, dried with non abrasive cloth before engraving.

About my settings on my 50watt co2, I reduced the speed and the power (to 220 / 20) and reduced the minimum power to 10.

Don’t understand how bubbles in the tube could effect this… an explanation would help me…

When I moved to a cooler climate, I added Propylene glycol to my coolant for freeze protection. My tube is full of little bubbles now, but they flow.

The danger of an air bubble, is when it’s ‘stuck’ to the tube, there is no coolant flow where the bubble is and the tube will crack there from excessive heat, thermal expansion.


For some reason it appears to be lasing at these points.

For a lack of anything else I can think of … With the same artwork that’s functional in RDWorks, generate rd file from each package and compare them. Might help out, might be a waste of time… You’d have to dig into the ‘machine code’ of the Ruida…

@kimmicks07 - you didn’t respond but am I to assume these ‘dots’ don’t appear on the preview in Lightburn.?

:smile_cat:

It’s a weird phenomenon for sure. It seems like it could be random reflections perhaps to do with glass/mirror glass, but then it happens on Leather as well. How well can you actually see the dots on leather? Are you sure?

I wonder what other materials it happens on. But it does not happen when using RDWorks software? Very weird indeed.

@Kimberley As you stated, this is engraved on the reverse side of mirror glass. Can you see little pin-pricks of light when holding up to a bright light and looking through the back of the mirror?

Have you had a really good look using a magnifying glass?

Thank you. No they don’t appear in the design in lightburn :frowning:

Tube was replaced with a new one, then old one put back in as that didn’t solve the problem so I don’t think there was an air bubble but I’ll check tomorrow.

I’ll try and reduce the minimum power too, thank you