Weird dots all over my engraving

They definitely happen on leather. I’ll try take a pic tomorrow.

It sure is a weird issue. The tech is at a loss too.

I don’t have a magnifying glass but zoomed in on my phone

There are even little dashes too

An image from the reverse side would be helpful. Those dots look bigger than I thought. Is it an actual text font? looks pretty low resolution - jagged lines everywhere. What focal length is the lens?

The dots aren’t all the same same shape, so… not sure - but maybe it means something.

Upon further reflection, the dots can’t be in the file itself because they are randomly positioned when looking at the various images posted - meaning the dots aren’t always in the same place when running the same file.

1 Like

If you run the faulty rd twice on material, are the dots in the same place? I.E. just re-run it…

If they are in the same place, it’s in the code, if they are not then I’d think it’s some kind of hardware anomaly.

Having fixed all kinds of computers/peripherals, a replacement isn’t always guaranteed to work.

The question was does it appear in the ‘preview’ within Lightburn.?

Did a good job here, girl :crazy_face:

You got us all picking our brains…


1 Like

That was what I was expecting. ie the “stray” dots are much closer to the engraved letters so this is looking like something is randomly triggering the laser to fire as it accelerates or decelerates on each pass.

In your LightBurn Cuts/Laysers you didn’t say if you had “Fill Shapes Individually” selected but it appears you do. If you change that to “Fill groups together” what I expect to see is stray dots only on the left and right side of the “Test” text.

If that bares fruit, then this is highly likely to be related to some settings in Ruida controller or the firmware.

I’m not a Ruida user but is there a way to look at what the settings are for acceleration when running in LightBurn vs RDWorks? My thinking is that the motor drivers loading the LPS 24V is causing a glitch on the 5V driving the LPS-L signal causing a drop and subsequent glitch turning on the laser momentarily.

Or, And, Also… How is this image being imaged? Is it a greyscale image, is it dithered? What method is being used? What are we looking at? I think Jack mentioned earlier that it looks like a greyscale or bitmap image (which it does) and not a native image from text in LB.

Therefore we don’t know, because we don’t know how the image is constructed in the first place.

My gut tells me it’s going to be something simple, but easily overlooked.

Haha it’s a tricky one hey!! No they don’t appear in preview, and they are all randomly scattered each time I run the file.

Same file on my other machine connected to the same laptop is perfect, no dots.

I get less dots if I increase the size of the engrave, I guess from the laser head moving faster so it throws the dots around more scattered?

I’m at a loss!

It’s just text typed out into lightburn. It’s not traced or anything. Just text. The quality is because line offset is 0.7 and line interval offset needs some work

Gosh I wish it was a simple fix!!

Would love to know the answer to this!

Oh I can look at this tomorrow!

Focal length 38.1. Doesn’t happen much when out of focus but that’s not feasible as then the machine won’t cut.

You can’t see them with the naked eye on the mirror backing but I can take a pic if you like?

It’s not only dots but little lines too

But you didn’t take an image/photo from the reverse side because it would be reversed. Still waiting.

I have a Ruida controller in a box I can try powering up and then connecting LightBurn to it. Can you post your LightBurn lbrn2 file so this can be looked at?

It will also give others on this forum some answers they are looking for.

Another couple of tests which will expose more about what is happening:

Create 4 vertical lines the same thickness as the vertical line in the letter “t” and space them apart about the same distance as the 4 letters in the word “test”. Set the cut/layer definition to Fill just as you have for your “test” word and set the speed and power the same. Make sure all other settings are the same as “test”. Show results. Expectations are to see same speckles left and right of each of the 4 lines.

Next, go into the Cut/Layer settings and change the Scan angle(deg) from 0 to 90 and run the test on the same 4 lines and show the results. Expectation is to see no speckles left and right of the lines and maybe a speckle or two above and below the 4 lines.

Much like grbl, the Ruida configuration is in non volatile memory. Neither RDWorks or Lightburn writes configuration data to the device without the users direct direction.

If the same file runs with no issues on another machine, that pretty much identifies it as a hardware issue. The same code can’t produce different results for this stuff to work.

I’d like to ensure…

Are you moving the actual RD file to the different machines? Like in ‘sneakernet’ or is it getting regenerated by software and resent to the working machine.? I’m trying to ensure the ‘identical’ data (RD file) is used in both instances.

I find it difficult to believe it’s the major hardware, such as the controller since all of these have been replaced and it’s a rather strange issue.

I can only think of a couple of things to try…

Powered OFF, go through the on the parts and ‘gently’ tug on the wires to ensure the are ‘sort of’ in the connector. I’ve seen this a number of times on these machines.

The problem with the issue you have is that to fire the lps, the control signal (L-On1) goes low. An intermittent would cause the machine to miss spots, not add them. The only exception is if that signal gets shorted to ground…doubtful.

Just for my curiosity, can you look into the electronics cabinet and see if you are using LPWM1 or L-AN1. One is a digital signal and the other (L-AN1) is the analog version. Most of these use LPWM1, but I’m curious since this is so odd. Is a wire in CN5 pin 1 or pin 3.?

Screenshot from 2022-06-30 13-09-19

@kimmicks07 is used to ‘target’ a specific person, instead of replying to each comment separately. Just use the @ sign and pick who you are responding to… Makes the thread much easier to read.

Good luck with this, we are all anxious. :crazy_face:


Hey, so I’ve had the same problem with two different machines, 3 different tubes, 4 PSUs grbl and ruida controllers and at different locations. I’ve tried literally every single thing. These dots only show up on very sensitive material, thermal paper gets very ugly.
I have one question. Does the bench/table that your laser sits on have any wobble at all while you run a job? The only thing that I haven’t changed is a piece of crap metal cart that I set the machines on top of. If you want to try, put your laser on the floor and see if that makes a difference.

@Bklynghost oh no! Sorry to hear. Did you ever find a fix for it? No wobble at all and it’s the same table I have used for 2 years. So no idea why it’s just started happening.

Would love to know if you found a fox

@jkwilborn so sorry I had no idea I didn’t realise I wasn’t replying properly. Sorryyyy

When I get home I will check that for you and take a pic. If not it will be tomorrow :slight_smile:

@DougL where dk I find that file sorry?