Weird dots all over my engraving

@kimmicks07 ah, ok so really no different from the other things. The only interesting data point I’ve seen is that the dots get closer to the engraved line when the speed is lowered. I thought for sure it was somehow related to acceleration/deceleration.

1 Like

I had it connected to the digital pin L-On1 I switched over to L-An1 and it fires throughout the whole the job. Tried switching the settings to High and moving to H on PSU, but it’s acting weird and firing when homing. What would be the settings for the analog pin?
BTW different controller didn’t fix it.

The L-ON1 uses PWM( pulse width modulation) for setting the power level of the laser(50% duty cycle ON/OFF is 50% laser power ). But the analog input is voltage level based so another pin on the controller is probably needed for driving that. ie if it’s a 5V signal then 5V is 100% and 2.5V is 50% laser power.

I don’t have a machine with Ruida but I’ve seen lots of Russ Sadler videos to pick up a thing or two.

Wait, if you are using the Ruida analog output you need to connect it to the LPS-IN signal IIRC.

That makes sense. Looking at my power supply, the water protection has a jumper going to IN. What’s happening there? shouldn’t it be grounded?

1 Like

Here is my wiring @Bklynghost

Those are all stepper connections. Could you take a picture of the power supply and laser control terminals?

1 Like

@kimmicks07 , Those look like they are all of your motor driver boards and the motor driver side of you controller. The other side of the controller is all about controlling the laser and the safety switches,etc.

1 Like

@Bklynghost generally the IN input is a voltage setting which determines the MAXIMUM output your laser can provide. On the cheap K40 machines, there is a variable resistor and the 2 pins on either side of LPS-IN are 5V and Ground. This lets you use a variable resistor to set what your maximum laser output power is and then use the LPS-L signal to pulse width modulate to vary the laser power output up-to the max set by the voltage on LPS-IN.

In your case, they just hardware IN to 5V so the Laser Power Supply(LPS) will put out max power and you probably have PWM out of your Ruida going to LPS-L. If you want to use analog control, which most Ruida setups use, then you connect your L-AN1 output from the Ruida to the LPS-IN signal on the power supply. You should be able to find schematics showing this. You would definitely want to remove that jump if you want to use L-AN1 analog output.

And L-OUT might have to be connected to LPS-TL which basically is like a laser enable signal.
Their manual sucks… it lists L-AN1 but then in their example schematic they don’t show L-AN1 but instead show it as a PWM label. But I think the connections are the same. ie Ruida-L-AN1-> LPS-IN and Ruida-L-OUT->LPS-TL

I got it working. Doesn’t look like much aside from higher power output.

1 Like

cool and I think the only difference is that you can get better control at the lower power settings so your range has been increased… But I still see the speckles/dots.

This is a suggestion from my technician. I’m hoping it will work?

1 Like

ya, it’s a shot but since @Bklynghost already put AC line filters on his and it didn’t change things I’m not hopeful. Myself, I still think it is somehow associated with the 24V and how stepper motor drivers load the 24V on acceleration. Two things I would still try and that is to drop the current(amp) setting on your X axis stepper motor driver( when testing vertical lines ) and see what effect that has. Next, I would go in to the Vendor settings of the controller and cut the Acc(acceleration) parameter in half and see what effect that has on the dots/speckles.

1 Like

My Ruida is wired as the diagram…

L-On1 → L on the lps This is laser enable (Laser-On) and turns the lps on, in essence firing the laser
LPWM1 → IN power control of lps

Ground is common and P of the lps is strapped to ground. The Ruida handles the wp/door protection.

Pretty much exactly how the diagram is laid out. You can run L-AN1 (analog) into the lps IN instead of the digital (LPWM1).

The only way to really control the lps output current is via the internal adjustment. Using a pot across to IN only changes the internal pwm not the actual lps current.

@kimmicks07 - If it’s only on the trailing side of the image (for the dots), that would indicate the lps is not ‘shutting’ down completely… IMHO…


1 Like

Yup, AC filters won’t solve it, at least they didn’t for me. I even used a fancy power conditioner. Acceleration will have an effect for sure, I remember other times when I was still convinced that this was a software issue, I lowered the acceleration and the dots tamed. Either the LPS can’t keep up with the pulse, or there are some type of stray currents that the tube is holding on to. Unfortunately it’s a slow season and I won’t be replacing those two any time soon.

@kimmicks07 Please keep us updated on what the tech comes up with and if the problem is fixed. This is my end of the road for now.

I’ve had the same issue when engraving clear acrylic. I process a lot of acrylic mostly clear but this happens on any color. I have a Boss Laser 20x14 with a 70watt tube. I reached out to them with pictures of the issue and they did basically asked me to tune the scan spacing. I got a feeling it’s got something to do with the air assist. I get different results with and without air and also varying the PSI on the compressor. I think these dots are engraving dust that sticks again to the material but I could be wrong. I’ve been having better results using the dish soap technique and engraving through it. Here’s some pics that I sent to Boss a while ago


Looks like the same thing as us. I doubt that it’s dust/air assist. If you scroll up a bit, you will see that we did scans with bidirectional setting turned off and only got the dots on the left side of the test lines. If it had to do with the dust, the pattern would remain pretty random. Secondly, I do engraving on forbon, it is a nasty material that liquifies and turns into black goop. It does not produce dust and has zero reflective properties.

Keep trying with Boss, read the whole thread and do the same exact tests that we’ve done to skip to the parts replacing process.

1 Like

What may also reduce the problem is multiple passes with lower power, or lowering acceleration. If your machine is still under warranty, keep pushing for replacement parts.

1 Like

@Bklynghost still no fix over here sadly. How bizarre is this issue hey!!

Thank for doing that, the test was just to simplify your issue and to try and force the dots to become more predictable. We can also rule out effect from acceleration/stepper noise, and LightBurn can also be exonerated, since RDworks does the same.

I have not personally come across this issue with the lasers I service, but it feels to me (as a layperson, not an electrical engineer) like there is unwanted noise from the high voltage circuit somehow looping/leaking back into the input/driving circuit. The heart of this issue I’m sure is the power supply but since it has been replaced I’m not sure if it is the primary actor and may be somehow receiving “help” in causing mischief by nearby players such as wiring, tube circuitry, poor insulation or poor grounding. Your technician might have some more ideas on diagnosing this and might be on the right track with noise suppression/filtering. What effect does increasing the power in the same test have on the noise? - If there is a reduction in the dots that would be interesting - and might suggest a power supply with more “gain” (sorry for simplistic terms - I work on a sound desk sometimes haha) is needed.

I also mentioned your dilemma to a colleague of mine who has more experience with these things and the first thing he said was to check the nozzle. I know you said the alignment was “bang on” but worth rechecking?

-Is it heating up during a job? carefully feel it after a job.
-Inspect the inside of it - are there any white scorch marks down near the end on the inside?
-Try completely removing the nozzle and see what results you get