Weird things happening Creality Falcon 2 Pro Calibrate Axis?

This is so annoying,. so I have spent the last 90 mins messing around with this Lightburn Machine settings trying to adjust what appeared to be a simple task according to a couple of YT videos and turned out close to a nightmare for me. So I have a pretty new Creality Falcon 2 Pro whereby the test profile I am cutting is a simple square 30x30mm. The measurements are X 29.75, Y 29.98. I can live with Y axis. So I went into Machine Settings (Latest Lightburn) and opened “Calibrate Axis”… It asked me to input the x settings which I did as per my picture. I saved and wrote it to the controller and what did I get? The XSteps per mm dropped to 80 where they were origianlly 115000 ish so when I tried to jog the head it moved at a ridiculously slow rate and the X axis instead of being closer to 30mm was 43mm… I tried it numerous times and every time failed to do what was intended. Each time I had to restore a backup to get back to where I started. I haven’t a clue what is going wrong, I don’t know if anyone can try the same to see if they have the same problem?
Any ideas please?

if you need to calibrate axis on a “branded” machine this means you have hardware issues
$RST=* in console to reset to defaults

Tighten the Y belts and X one (they dont say how but they come very loose from factory)

That should fix it

Also make sure Rotary mode is OFF

1 Like

Thanks for that. I did as you suggested and the x belt was a little slack. I gained .1 (29.75 now 29.85) The belt is definitely tight enough but I still have .15mm discrepancy on the x-axis.
I cannot understand why I cannot adjust it on the Calibrate Axis setting? All my other machines i.e. cnc’s and 3D printer are a doddle to calibrate. The LHG chap on YT shows it as being a simple task so I am confused as to why I am having such a problem?

I would reach the support of the brand
for the most part 99% of the branded machines require not calibration.
WHen calibration is suggested, it tends to hide a hardware instalation issue, which will come back to show its ugly face in other ways and then too many variables at play
0.15mm is a bit much is almost a step. so it might still be you are loose on belts,
Run this for me and take a picture with measurements
Dot Test with Angle.lbrn (46.3 KB)

1 Like

Here you go…

Note the body of the Y
Also - by eye - notice how the circle isnt a circle (you would have to measure)

so therefore your X still needs work

Make sure as well your Steps per mm are in fact both set to 80
You can type
$$ in console to check


So when you say my X still needs work, what are you referring too?

Belt tensions, make sure your movement is smooth, make sure the cables are not tugging on the module and creating tension
Overall give a once over and pluke the belts make sure they sound tight. all the same sound

1 Like

I have retightened as much as I am comfortable with and still the same. But I haven’t tightened the Y axis as they are ok. BTW I appreciate your help with this…

not the same a significant improvement, compare both Y letters
Whats the measurements of the box?

Still X 29.8 x Y 29.99… If I could get .15 on the X it would be pretty much spot on.

28.8mm x 29.99mm?

I actually asked the size of the box on my test
Should be 76mmx76mm

0.15mm i am not really sure you can get that level of precision.

Sorry, ok I will run it again and cut the outer layer out so as to measure it.

1 Like

Average on the X
X 75.70
Y 75.98

so slightly short on X
0.3% deviation on lenght

Tough! it is still mechanical but you getting into the realm of precision that you might lose more time chasing than its worth

Yes I get your drift but I am a semi retired design engineer and bought this machine for my prototyping on the understanding I could get pretty accurate so would really like to get it closer if possible. The differential seems pretty consistent across the whole bed. Could you run by me why I cannot adjust it in the Axis Calibration in LB and why I am getting such bizarre result when I follow the procedure?

because as is backlash on the X axis, you are just going to be hiding the backlash on cntrolled testing however it will then turn into problems elsewhere

You need to contact Creality (@Creality_Rachel ) and get them to give you the exact procedure to stablish the correct belt tension

I have a 2 pro i will try to test check my acuracy a bit later.

But all in all 0.3% deviation can be eaten alone by the beam thickness
Consider your module dot size is probably 0.15x0.2mm

Yes I understand what you are saying. Being an engineer you do get a bit anal on accuracy, especially as my cnc’s are spot on. No doubt there is some deviation caused in the kerf on various materials. I will contact Creality and spin it by them though. I would appreciate to know your measurements when it is convenient…

1 Like

I received a reply from Creality this morning…»

Dear customer,

If the belt is already tightened, it is recommended to compensate through software.

From your email, it seems that the compensation using Lightburn “Calibrate Axis” tool is over-compensated this time.

Please readjust the parameters and see if you can get better results?

It looks like I need to ask Light burn what the problem is with my use of “Calibrate Axis”. Any ideas how I can get in touch with them? Did you have any luck checking yours?