Welding multiple items has stopped working

Hi, I updated from 0.9 today to the latest and can weld 2 shapes at a time, but I used to be able to select all text to be welded and do it at once(the weld tool is ok for most of the text, but the font we use we have to overlap the capital letter ourselves).

If this purposely done or a bug? :slight_smile:

It seems to be hit and miss. I’ll post here when I figure out what exactly stops it.

The only reason you’d not be able to weld is if one or more of the selected shapes aren’t closed. Weld needs closed shapes to work.

Hi, theyre definately closed. I’ll try another machine.
I tried it with just squares and it works fine.

If you find something that doesn’t give you the option to weld, post it here so we can have a look. I can just about guarantee you that one or more of the shapes aren’t closed.

For what it’s worth, “Closed” means a single, continuous loop. We very often see shapes made of disconnected lines that have been grouped together, but not actually connected to each other.

A post was split to a new topic: How do I set this up correctly?

I use that feature always, but the spacing of this font means I have to edit the first letter so it overlaps the rest of the word.

I’ll send the file here.

When I have a font where the first character is not close enough to overlap the next, I break this into two distinct text objects and nudge then together as shown below,


-

Thats what I do and thats where the problem was starting. If I highlighted just 1 word it will weld but if I select all of them it doesn’t. It worked fine before the upgrade. Is a lightburn or dxf best to send over?

There are two different “weld” options here, one is a Text option (RalphU is showing this in the image they posted above), the other is one of the Boolean tools, used for any shape. The key is understanding how they work and why, so you get the look you are after. This should assist, Modifier Tool - LightBurn Software Documentation. And the video below is also worth review.

and,

Sorry, I use Ctrl+W. I’ve been doing it the same way since the beginning(80k names at a rough guess) its just since this update its hit and miss with certain name lists.

Sorry for taking up your time!

Please post the LBRN file you’re working with so we can have a look. I can practically guarantee you that there’s something in the font or file that isn’t a closed shape.

1 Like

test.lbrn2 (3.3 MB)
If I select all with CTRL+A and then press CTRL+W nothing happens. if I select each one and press CTRL+W it seems to work.

If you do an Edit->Select open shapes you can see that there are portions of “Andy” and “Will” that are open shapes. Fix those and weld should work without issue.

Thanks, I did it and it showed Marc as being open but no the other 2. Once I removed it they welded fine.

Quick edit: I reprocessed the same list but this time it worked fine, no open shapes. Any idea what this could be?

That’s odd. You worked from the test.lbrn2 file that you uploaded?

Can you explain what you’re doing when you say “reprocessed”? How are you generating this?

Yep, same file.

By reprocessed I paste the list, add a offset to thicken the letters. Then I move the non-overlapping letters so they overlap and weld.

I don’t know what to make of this. Can you try downloading the file from the site and checking again? I can’t imagine this would be system dependent.

Are you pasting from another source and pasting as text?

Not certain but it’s likely somewhere between the offset and movement where something is getting broken. Would be hard to tell for sure unless you could identify a reproducible case.