What are the default polarities for Ruida 6445 Controllers in LIghtBurn

(1) I’ve been trying to search through the forum topics to answer my question. Many discussions come close, but I haven’t found a solution for my laser head homing to back right corner and grinding after I upgraded my Ruida 6442 to a Ruida 6445G controller.

Controller: Ruida 6445G
Limit switches? Yes, back (top) right – this is where I have set “home” to be.
Read/Open/Save/ Write config files - yes.

Display: X:10000 and Y: 10000.

Whenever I hit “Home” in Lightburn, the laser head goes to back right and grinds away. And whenever I boot up my laser cutter or press the Reset key it does the same thing. And whenever I try to position the laser head anywhere in the workspace using the set laser position tool / icon, it either does not respond or moves and starts grinding at the front of the machine.

I’ve tried various settings for the limit trigger, limiter polarity, and direction polarity under Lightburn’s Machine Settings. Now, I’m afraid that I may have changed too many different parameters that I’ve really kludged things up, but even when I disconnect the laser from the computer, I get the same problems – so I don’t think that Lightburn is the problem, but I was hoping it might be the solution.

There aren’t really defaults - it’s entirely dependent on what machine config and what motor controllers you have. Limiter polarity is whether the limit switch is normally open or normally closed. Direction polarity is whether the motor controller direction line should be +5v or 0v for positive moves. Key Polarity is just the direction that the keypad makes the motor move.

Enable the limit trigger, or at least enable homing. Play with Direction Polarity to make the motor move the right way when you power up. Limit Polarity is set correctly when the limit switch is triggered properly. You can test that without homing by looking at the diagnostics+ window in the controller menu and jogging to home.

This is handled inside your Ruida controller, not lightburn. On startup the Ruida wants to home the machine. It does that by moving the X and Y axes to a corner and waiting for the limit switched to trigger in that corner. If you do not have limit switches, it will hit it’s mechanical limit and start to grind.

You should hook up limit switches in your machine to protect itself.

This might be caused by the machine not being homed properly.

Yeah I know that feeling. Lucky for you I made a backup of the default setting to refer to. These were the settings how my controller arrived from a dealer. I assume it is fully stock, but you never know. Maybe it can help you compare settings. I hope it is allowed to share this file. Here it is:

Hope it helps !

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.